Jump to content

Help with USB audio issue iATKOS s3 v2 on Dell GX620


10 posts in this topic

Recommended Posts

Hello All.


First let me say thank you to all the ppl working on osx86 community. Second although I have successfully installed 10.5 versions in the past, tweaking kext, add ven ids and all that good stuff. This is my first attempt with 10.6, I really didn't think it would work for my system.


Anyhow, on to my issue. Everything seems to be working properly. Video, Sound through onboard audio, usb.


Except that when I am using my usb headset to listen to audio it starts to crackle and pop when I move the mouse around, or if I scroll up and down. Its a plantronics .audio 655 and comes up as C-Media Usb audio device.


From searching around on the forum and using google's site: feature I have installed several kext and fixes and none seem to make the crackling and popping go away.


Im not sure if this has anything to do with it, but I sort of remember something about the kernel, system.kext and seatbelt.kext having to match. I did a uname -a and got back Darwin Kernel Version 10.2.0. When I do a kextstat I don't see the system.kext or the seatbelt.kext. These are the usb kexts that are loaded:

AppleUSBAudio (2.6.4b17)

AppleUSBHub (3.8.4)

AppleUSBEHCI (3.7.5)

AppleUSBUHCI (3.7.5)

IOUSBFamily (4.9.6)


When I eject a usb thumb drive, and reconnect it, it mounts right back up. In the system profiler it show it as only 12mb/s



After I installed all of the below items I did an update to 10.6.4 via the software update, it restarted right back up, I didn't have to change out any kext or kernels, as with 10.5 days.


I have installed 10.6 using iATKOS s3 v2 using the following options:


Bootloaders =


Chameleon V2 RC4


Bootloader options =


Graphic Enabler




Patches =


All default already checked

Modified Kernel =

qoopz 10.2.0

Sleep Enabler




Drivers =

Main Hardware =





EFI string






So I don't know if I am on the right path or if i am completely wrong. Any help would be greatly appreciated. I hope I gave enough info on my system and install method.


Thank you!

Link to comment
Share on other sites

I thought of something else, could this be caused by grounding issue? I ran my 10.5.8 install and sure and behold, the issue was present there too.


My system is a bit of a hackenstein. Its a dell GX620 mt stuffed inside of a full tower case. I had to mod the back to make the ports fit the back.


Any ideas how I can make sure that it is grounded properly?

Link to comment
Share on other sites

Ok, well it turns out that my grounding theory was wrong. I installed Windows 7 on the same computer, same usb headset, and it works perfectly. No buzzing, scratching or even crackling sounds when I move the mouse, scroll or move windows around.


So I guess its a driver issue. Since I installed windows, the first thing I did was to install everest. So I know have the exact hardware names and such. I'll keep looking to see if I can find the right kext, or edit them. I'll keep posting here in case i find a cure, just incase someone else finds they have this issue.

Link to comment
Share on other sites

  • 2 weeks later...

Ok, so what I'm trying next is to do a vanilla install, using chameleon boot cd and a retail DVD. So far I was able to boot, and everything seemed to be working. It just didn't load my kext from the /Extra folder, not sure if I have to have an /extra folder on each drive where I have osx installed. I did this late last night so I didn't get a chance to test my usb headset. I will do so when I get home from work. If all goes well I will be installing chameleon on the efi partition. Will report back.

Link to comment
Share on other sites

Ok so the "vanilla" install does the same thing. no change at all. So since last time I have also installed iPortable to another partition on the same drive. What do ya know, it works fine with that install. So I tried to install ALL of the kext from the iPort install, including the ones in the extra folder to my newest install. But again, no dice. Still the same thing.


I'm losing my mind, the system pretty much works perfect except for this one thing. I just don't get it. :wacko:

Link to comment
Share on other sites

You don't need any USB bus fix you just need the AppleAC97Audio.kext. from here http://www.insanelymac.com/forum/index.php...t&p=1557327. USB audio works fine.


Did I understand you to say you did a Vanilla Install---that means vanilla Kernel?


Thanks, but that kext didn't work either :wacko: also I don't know what I'm talking about, like I said, I'm losing my mind. What I meant was that I installed it via the retail disk using a chameleon boot cd and then used a modified kernel.


thank you for the help.

Link to comment
Share on other sites

Thanks, but that kext didn't work either :( also I don't know what I'm talking about, like I said, I'm losing my mind. What I meant was that I installed it via the retail disk using a chameleon boot cd and then used a modified kernel.


thank you for the help.


Your MB should be earthed via the power supply. You have probably tried moving mouse & usb audio in different ports, trying different mouse etc

Good luck

Link to comment
Share on other sites

Ok so this is def a driver issue. As I stated before, I have multiple installs for testing. One of which is the iportable install and all the others are either retail or iATKOS, both of which are 10.6.3. However the iportable is 10.6.2, again this was the only install where the usb headset sounded great. Well I just updated the iportable install to 10.6.4 combo updater via software update.


So what do you think happened after reboot, yup! The scratching and popping appeared. So now I need to figure out what kext from the iport 10.6.2 are the ones that make my headphones work without issue. Arrg!


So I figured, since the iport install worked with my headset I would try and make that my system default. Everything seemed ok except for video, I had enabler, strings in the boot.plist. Everything the same as in the 10.6.3 systems where it was working just fine. after a couple of reboots adding one kext at a time. I just said screw it, I'm just going to update and see what happens. Well like I said, scratching and popping showed up, but it fixed my video! Transparent menu bar, and ripples when I add widgets.


So this is what I have found


Headset working in 10.6.2 install, but video not working.

Headset not working in 10.6.3/4 installs. Video works perfect.


Oi my head!

Link to comment
Share on other sites

  • 8 months later...

Having the same prob here. I have a Dell Inspirion 6400 with Radeon 1400 - osx 10.6.4 (with later versions no graphics possible)


Was hard to get the graphics working. Finally managed it - was very happy. But when i plug in my external USB soundcard it has this crackling. Tried different soundcards - same result. USB-hdd seems to work fine.


So either no graphics support or no usb sound!


Any suggestions?

Link to comment
Share on other sites


  • Create New...