Jump to content

Boot loader option choices problem


9 posts in this topic

Recommended Posts

My booter is in a USB pendrive. I prefer that. I don't know if it is related with an issue that I don't know why is happenning.

The problem is, when I start, and the booter comes to the menu, by default the selection is in Snow Leopard

(I didn't set anything, is done by default), and if I press enter, It says doesn't boot for any problem (I don't remember now the message), and if I redo again, same behaviour occurs. But if I select another choice, and go back to that option, it works good.

So, it is sound like is a question for the first time, that something is not initialize, but if I select another option and go back, it works.

I am doing something bad?


Link to comment
Share on other sites

Post the contents of the com.apple.Boot.plist in /Extra on your Flash Drive.


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">








<key>Kernel Flags</key>

<string>arch=i386 pmVersion=20 -v</string>







Link to comment
Share on other sites

Your com.apple.Boot.plist has its entries sorted alphabetically. I realize this may sound strange but that usually means that the file is corrupt.


I've make a fresh one for you with the same settings, using the plist editor that comes with Apple developer tools.

The only difference is that I've replaced the timeout flag with InstantMenu=y so that you can manually select the boot device.


Some PC BIOS sometimes annoyingly shuffle the drive order when booting from a USB drive.

Therefore you cannot be sure that the default boot device will always be the same (as far as Chameleon is concerned) when you're booting from a flash drive. Besides your boot.plist being corrupt I think your problem might be some variant of that behavior.


If, after a couple of reboots you can verify that your OS X harddrive is always in the same place (lucky you) then you can put your timeout value back and remove the instant menu flag.


Also you might find this interesting:


After reading you might want to update your Chameleon bootloader to a more recent version, depending on which boot flags you would like to use - such as "Hide Partition" and "Default Partition" for example. I recommend the latest version of RC5:


Link to comment
Share on other sites

Playing around I could get the behaviour that I want, without any error. Thanks man.

Now I am using C2RC5, but the problem is that I don't get the memory speed correctly. I don't know why, because is supposed to be automatic, maybe I am doing something wrong, tell me if you can help me.


I've attached 4 captures, 2 with AsereBLN and another 2 with C2RC5.


Thank you very much.





Link to comment
Share on other sites


  • Create New...