Jump to content

[Aiuto] ripristinare Kernel Vanilla dopo averne installato uno nuovo...


Hero!!
 Share

10 posts in this topic

Recommended Posts

Dopo varie peripezie ho scoperto che per far funzionare la mia X3100 su snow era quello di partire con il flag 32bit... purtroppo prima avevo installato un kernel legacy per fare alcuni test... come faccio a tornare al vecchio?

Link to comment
Share on other sites

il file da sostituire è il mach_kernel

se hai un back up bene

altrimenti lo estrai dall aggiornamento della versione del sistema installato

 

dal terminale digitando ls vedo che ci sono due file, mach_kernel e legacy_kernel... come faccio a capire quali dei due viene caricato? c'è un modo per capire se quello che carica è il vanilla o il legacy?

Link to comment
Share on other sites

dal terminale digitando ls vedo che ci sono due file, mach_kernel e legacy_kernel... come faccio a capire quali dei due viene caricato? c'è un modo per capire se quello che carica è il vanilla o il legacy?

 

 

Il kernel è richiamato dal com.apple.Boot.plist.

 

Trovalo e postalo.

Link to comment
Share on other sites

Il kernel è richiamato dal com.apple.Boot.plist.

 

Trovalo e postalo.

 

dentro c'è scritto legacy_kernel... basta mettere mach_kernel e tutto torna come prima? :) Considera che uso un CD di Boot con Chamaleon RC4 per avviare Windows o OSX ;) Il file com.apple.Boot.plist è riferito a quello su osx o quello nella cartella extra?

Link to comment
Share on other sites

sisi ho Windows... cmq ho rimesso mach_kernel e cancellato il file legacy_kernel e tutto va (come prima)... Per avere la certezza matematica che il kernel sia quello come faccio? C'è qualche utility che mi dice quale Kernel ho in uso?

 

Ho notato una cosa alquanto strana... L'installer del Kernel Legacy aveva aggiunto un "kernel flags" con impostato arch=i386 ma sono sicuro che non veniva utilizzato! Se lo impostavo manualmente al boot vedevo l'applicazione della sua funziona (praticamente forzo i 32bit e viene caricato il kext della X3100 altrimenti vado a 1024x768)... questo mi fa pensare che in effetti il file com.apple.boot.plist sia un'altro ;) E' possibile che sia quello del CD di Boot che uso?

Link to comment
Share on other sites

sisi ho Windows... cmq ho rimesso mach_kernel e cancellato il file legacy_kernel e tutto va (come prima)... Per avere la certezza matematica che il kernel sia quello come faccio? C'è qualche utility che mi dice quale Kernel ho in uso?

 

Ho notato una cosa alquanto strana... L'installer del Kernel Legacy aveva aggiunto un "kernel flags" con impostato arch=i386 ma sono sicuro che non veniva utilizzato! Se lo impostavo manualmente al boot vedevo l'applicazione della sua funziona (praticamente forzo i 32bit e viene caricato il kext della X3100 altrimenti vado a 1024x768)... questo mi fa pensare che in effetti il file com.apple.boot.plist sia un'altro :wacko: E' possibile che sia quello del CD di Boot che uso?

 

Ciao,

è qualche giorno che stò chiedendo qui come configurare la mia SVideo (anche io ho una X3100) puoi indicarmi quali kext hai utilizzato e che procedura hai seguito per installare la scheda?

Magari se mi puoi postare qualcosa (tipo i tuoi kext per esempio..)

 

Saluti

Danny

Link to comment
Share on other sites

 Share

×
×
  • Create New...