Jump to content

Triple Boot Project: OS X 10.6, win7 Pro, Ubuntu 10.04


fragment137
 Share

8 posts in this topic

Recommended Posts

Hi all,

 

I'm new to the multi-boot scene. I've done a couple of dual boots with Windows/Ubuntu, but it's pretty user-friendly and I want to "stretch my legs" by throwing OS X in there... Here's my system info and what I've tried so far:

 

Hardware:

ASUS G51Jx-A1

 

Intel i7 Core 720QM 1.6Ghz

500GB SATA HDD

nVidia GTS360M

Audigy EAX Advanced HD 4.0

 

Software:

Mac OS X Snow Leopard 10.6 (Offical Retail)

Windows 7 Professional (Official Retail)

Ubuntu 10.04 (Directly from http://www.ubuntu.com/)

Nawcom's Darwin boot CD (With MBR Support!)

EasyBCD 2.0.2

 

 

UPDATED SEPT. 20TH 2010

 

I've read over countless tutorials and run into various issues, but I've wired it down to very specific steps for my system. I installed OS X first, using Nawcom and LOTS of help from this tutorial for the ASUS G51Jx-X3. It installed fine and aside from needing some configuration it runs very well.

 

I opted out of making my initial install on my internal HDD. Instead, I bought a cheap 80GB HDD and an external enclosure with an eSata port on it. This worked wonderfully! I have a full install on the external HDD and am currently working on installing it to my internal drive.

 

I ran into a problem with my G51JX-A1 when trying to boot without the cd... I had to specify for the kernel to only use 4gb of my 6gb's of ram, in order to initially get the OS to boot...

 

If you have an ASUS G51Jx-A1, have tried following the guide linked above, and are having trouble with the initial reboot BEFORE updating to 10.6.4, try using these bootflags:

 

	 mach_kernel rd=disk0sX -v -f maxmem=4096

 

Replace "disk0sX" with the location of your kernel. To check which partition it's on, there are a variety of methods listed around the site. These bootflags worked for me to get the External install running, so they should work for other G51Jx-A1's too!

 

The only problems I have remaining are very minor compared to what I've already accomplished. I still have to get the internal wifi working (There ARE stories of people getting the Aetheros 9285 fully functional in 10.6.4... so here's hoping!), as well there's minor problems with the sound. Every time I boot, the mic's Input Gain is up and I can hear myself... there's apparently a fix for it which I'm currently hunting down.

 

Any help or comments are appreciated and I will gladly post details later once my configuration is working!

 

- fragment137

Link to comment
Share on other sites

... Very intresting. Did your OSx86 "distro" come with some sort of *sum? If so, then use it. Try reinstalling OSx86. Here is how to do it while keeping your current bootloader.

 

Thank you for this information, but I decided that I was going to restart and try again.

 

I reformatted my HDD using the GPT and have a successful installation of OS X 10.6 running. I'm currently in the process of trying to follow this tutorial and I've gotten lost at step 5.ii of the POST INSTALLATION. After installing Chameleon and putting DSDT.AML into the /Extra folder, the author talks about SMBIOS.plist and com.apple.Boot.plist as existing in some sort of "attachment"... I'm very confused at this point, as I've looked around my system drive and can't find either file anywhere, and I'm not sure where I'm supposed to be getting them from as it's not specified in the tutorial! If ANYONE has any ideas I welcome them; I'm inching closer to getting this beaut up and running at full steam!

Link to comment
Share on other sites

I have had some experience in dual booting and the easiest way I can think of is installing everything as long as windows is last and use easybcd (google) to modify your bootloader this supports max and linux OS. cheers.

 

This is what I plan to do, but I can't seem to get Mac OS X to boot on it's own, which I believe I need to accomplish first before installing the other OS's and having a successful bootloader with EasyBCD.

 

My question is what is the purpose of SMBIOS.plist and why can't I find it?!

Link to comment
Share on other sites

An update on my triple boot project:

 

I ended up buying an 80GB hard drive and an external enclosure with eSata to save myself the trouble of corrupting my internal drive.

 

Thus far, I have a successfully booting install of OS X 10.6.4. Almost everything works including an 11n USB Wifi Adapter I bought. The only thing that DOESN'T work is the sound!! I've tried installing from "VooDooHDA_perf_64b.zip" but the sound just REFUSES to work! Any insights and help is appreciated! :P

 

To be honest I'm not sure how to start troubleshooting this!

Link to comment
Share on other sites

hi,

 

i have the same setup but on a vaio notebook. since vaio was pre-installed with vista, i ended up upgrading the vista into win7. then i partition my hard drive using disk management in win7. 25G for mac osx and another 25G for Ubuntu 10.04. I installed OSX on the second partition then Ubuntu 10.04 on the third. since Ubuntu 10.04 now uses GRUB2 bootloader, It can now detect my windows 7 and OSX. I do have the same list in OSX, a 32 bit and a 64 bit OSX. Doesn't bother me at all. Since having an option to run a 32bit and a 64bit OSX gave you the power to install some kext files as your drivers.

Link to comment
Share on other sites

An update on my progress in Triple booting:

 

I have a solution for my Wireless Network adapter. I used the TRENDnet TEW648UB with a generic RealTEK Driver, and it works great! It will however disconnect sometimes if it's overloaded... I.E. Installing WoW and watching too much Youtube, lol..

 

EDIT: Sound now works, just trying to get the Input Gain to stay off when logging in... Internal WiFi still doesn't work, just trying to work out the kinks on that one...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...