Jump to content

Problems with Nvidia GeForce 7300GT


Malygos
 Share

4 posts in this topic

Recommended Posts

Hello. Long time reader, first time poster.

Since this is a problem that has plagued me ever since I had my computer, and it still bugs me in OSX I really need help in this thing. Please bear with my on this, because if I had this problem solved, I would finally have my PC up and running in perfection and then I could hope to run better games that I can now.

 

My PC is a Intel Core 2 Duo at 2.13Ghz, installed in a ASRock 775Dual-VSTA. My graphics board is a Point of View Nvidia GeForce 7300GT 512MB. I have a system composed of OSX, Windows Vista and Windows XP.

 

I have had problems with the graphic board ever since I had my PC, although at first I didn't notice, because I didn't had games powerful enough to stress it - the only thing that awakened my attention was some one time artifacts that disappeared. Possibly the first thing that my board ruined was EVE Online: every time I ran into an enemy ship the computer would freeze and self reboot.

I had more problems. World of Warcraft ran flawlessly in Vista, except for the fact that sometimes (they were random but mostly in Arenas) the screen went black for an amount of time between 5 seconds to 1 minute. Vista then gave me a warning than a driver by the name of nv....something failed and was reloaded or something.

Stalker: Shadow of Chernobyl and X3: Reunion had an interesting problem in XP - in some objects, the textures were like stretched to infinite if we got too close to the objects. I also had trouble running HD video (such as Fringe or One Piece) on Vista, some parts of the screen began to flicker and show artifacts.

 

Considering all this things, and knowing at the time my machine was ideal for OSX I changed my things to it. After trial and error (and a lot of help with forums like this) I got the system running.

Since I started to use Chameleon I needed to flash my graphics board BIOS in order to be recognized (after flashing, none of the problems above mentioned disappeared, unfortunately, although Vista started to recognize the board as a removable drive).

However some errors persist in OSX. In World of Warcraft, sometimes my screen flickers (flashes between black and the current surrounds 2-3 times per second). When I try to change WoW from fullscreen to windowed my system sometimes freezes, although the cursor still is functional. When I type something into Firefox sometimes the system freezes like above. The only way that I found was to force to Log Off with the keyboard shortcut and then cancel the countdown.

 

I know this is a really weird problem, and I don't even know if you can help me, but since this is one of the few technology forums I know about, and since this problem also affects OSX besides Windows, I thought some of you may have found it and solved it.

 

Anyway, please help.

Link to comment
Share on other sites

I have done a lot of research and decided to replace my BIOS to a similar board's one - in fact Point of View launched two boards with the same GPU, althoug one has a passive dissipator (my bloody case) and one with a fan system.

 

After the update, little has changed. I did notice some stability with the texture problem in X3 but I haven't tried more things.

 

I believe now that my board is faulty (or a part of it), but yet I'm not sure, because I never had one ;)

 

Another question - do you moderate so that I see my reply asking for further help deleted out of nothing?

Link to comment
Share on other sites

If the card exhibits similar errors on two different operating systems then it's a hardware issue.

 

Try a different power supply and test the card in another PC to rule out motherboard and PSU issues.

 

Check for (even slightly) bulging capacitors on the card, if you see any, replace them immediately.

I've successfully fixed failing video cards, motherboards and power supplies this way.

 

If nothing changes then it's time to throw it in the trash.

Link to comment
Share on other sites

  • 3 years later...

I apologize for the (very) late reply, but as I was reviewing some stuff I recalled this account and, hence, this problem.

 

The board was indeed defective, although it only stopped working completely in August 2013. I've been using an older graphics board I had laying around that allows me to do most of the stuff I used to do.

 

At any rate, thanks for the help and again, sorry about the late reply.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...