Jump to content

Update from 10.5.2 to 10.5.6 in Toshiba Satellite L45-SP2056


1 post in this topic

Recommended Posts

How're you doing, guys. Long time no see. It's been about 2 years since I tried to get OS X in a PC, so efforts are back now. :D

 

Well, my problem is this one. I have a Toshiba Satellite L45-SP2056 that has:

  • Intel GMA945GM (8086:27A2)
  • Atheros AR5007EG (168C:001C)
  • Realtek RTL8139 (10EC:8139)
  • MS Audio for ADI 1986 (11D4:1986) (don't know if this is the right one)
  • Intel Celeron M 440 - 1.86 GHz

 

By now the only install that has works with no problems at all is Kalyway 10.5.2, but I have no audio and no wifi. I'd been trying all this week to get them to work by crawling the forums, with no avail... so I resigned to be without audio and wifi.

 

Now, when I tried to get iWork 09 to work, it requires me to have 10.5.6 or higher to work. There's where all my problems began:

  • With Apple's Combo Update it just doesn't work.
  • With Apple's Combo Update, applying the "rm -rf"+"Dontstealmac to dsmos" method (don't know how this is called, Netkas Method?) - blue screen after reboot.
  • Recommended method of updating from 10.5.2 to 10.5.3 to 10.5.4 and so on, until 10.5.6 - blue screen after 10.5.3 update (Kalyway Combo Update, BTW).
  • Installing iPC 10.5.6 after Kalyway's 10.5.2 - blue screen after reboot.
  • Installing iPC 10.5.6 directly - blue screen after install.

 

As you can see, I'm ending at the same point: blue screen after update.

 

Now, Kalyway 10.5.2 works flawlessly in graphics: QE/CI Hardware support, no artifacts and native resolution (1280x800).

 

So... what should I do to update OS X and not to die while trying?

 

Thanks in advance. :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...