Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Sign in to follow this  
alexs

OSx86 won't boot in VMWare

Recommended Posts

I have dual boot setup with XP and OSx86 10.4.7. I am using Acronis OS selector to select between the partitions. Both boot just fine.

 

I want to boot the OS X partition in VMWare. I tried the following, neither works.

 

Select "Physical disk" Partition 0 to boot VMWare--Get MBR error.

Select "Physical Disk" entire disk, boot Acronis OS selector in VMWare--OS X starts to load, but I get a "Kernel Reset.." dialog box from VMWare as soon as the grey apple screen appears.

 

Anyone have any tips for me? I would like to use the same physical partition to boot OS X by itself, and within VMWare while running XP. Thanks.

Share this post


Link to post
Share on other sites
Advertisement

The first try was the good way, but you have to give the virtual machine something to boot. It has it's own MBR, even though it sees your drive's mbr.

 

Since you have acronis disk director, let's use it, although other tools can be used.

 

First, create the acronis bootable cd from disk director; it's a bootable cd that contains a. disk director and a. os selector. (It will be usefull for you in other situations anyway, like re-enabling os selector when you need to.)

 

Now here's the test I did successfully: I created a new vmware machine, custom, choosing the osx disk partition as the vm's disk, and 'other' as type of os. (I also chose to not make it networkable for this test, one detail less to worry about; you can re-enable it later if you're successfull).

 

I now started the vm, quickly clicking inside the booting screen so i could press F2 to enter bios options; once there i set to boot first from cd. I then exited, accepted changes, and it rebooted on the acronis boot cd.

 

Once on the acronis boot cd, I chose to run disk director. It showed me my whole disk's partitions, only the osx partition being not unknown (0xAF). Now I only needed to make that partition active: right-click, check in the context menu (advanced->make active, or something like that). That's it. I was hoping that this way the vmware virtual disk container would build it's own MBR and choose that partition for booting.

 

Upon closing disk director and rebooting, osx loaded, although quite slowly of course.

 

The procedure above seems quite longish, but the big point is to force vmware to build its virtual mbr and knows what to boot, and you can use any appropriate tool for that, as long as you make it within vmware.

 

good luck.

Share this post


Link to post
Share on other sites

I can get it to START to boot, but it crashes... whether it boots from the partition or from the DVD image...

 

I'm going to try to download a different patched image and see if that will work. Although I don't know why I should need to do that, because I have read lots of threads about people using the JAS 10.4.6 image in VMWare, which is what I have been using.

 

Edit--tried it with the 10.4.3 JAS image. same thing. Extensions off (-x). Same thing. see attached.

 

The attached Archive.zip is the VMWare log file for this VM, as well as the settings file, if anyone is interested in taking a look at them.

 

The VMWare workstation I am using is downloaded from the vendor's web site, so it is a known good copy.

 

WTF?!

post-47549-1154430278_thumb.jpg

Archive.zip

Share this post


Link to post
Share on other sites

Checked out the link--mine boots fine natively, and not at all in vmware--even from the install dvd (real or ISO), and I have tried three different install DVDs, all with the same result. Weird.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×