Jump to content

Reparing Raid0 chaneleon efi boot


insmac22
 Share

3 posts in this topic

Recommended Posts

I've been running a fairly standard 10.6.x snow for some time now, booting regularly from a Raid0 setup (2 disks) using chameleon 2RC3

 

After upgrading to 10.6.4 I noticed that I cannot boot from the secondary HD (booting from primary is OK). I don't know when this happened, but I'm unable to "repair" the situation.

 

Chameleon stops at the Boot0: done prompt.

With various combinations of Boot0 (RC3, RC4, RC5pre8) I get slightly different behaviour: Loops on Boot0: GPT or plain hang-ups. It seems boot1 is never "called".

 

I can boot from the second disk if I start from 1st disk then select second disk at the chameleon prompt, so /Extra and /boot in "Boot OSX" are correct.

 

My disks are 500G, standard EFI partitions and the auxiliary partitions are called "Boot0" and "Boot1".

 

I followed the normal chameleon raid instructions:

 

fdisk -f boot0 -u -y /dev/rdisk0

fdisk -f boot0 -u -y /dev/rdisk1

 

Then

 

dd if=boot1h of=/dev/rdisk0s3

dd if=boot1h of=/dev/rdisk1s3

 

And then copy "boot" in the root of the rdiskXs3 partitions.

 

My MBR partition contains a single protection partition which is marked active. I have tried copying MBR and the first 2 sectors of rdisk0s3 to rdisk1s3 (From the working to the non-working partition) but "no go".

 

The same thing happened to me some months ago, and I fixed the situation by repartitioning and recreating the raid0 setup. Now I would like to understand the problem and understand how to fix it.

 

My setup:

 

P5KC, Q6600, DDR3-1067 4GB

OSX 10.6.4 (almost vanilla).

2 x Seagate 500G, Raid0

The usual mix of /extra/extensions, custom dsdt etc.

 

any ideas would be greatly appreciated, as I have tried all an failed :(

 

Thank you.

insmac22

Link to comment
Share on other sites

I've noticed recently that I am only ever booting from my Primary (boot drive set in BIOS.)

I can tell this as my seconday drive has not created any caches on the Boot OSX partition.

This is new, as previously both Boot OSX partitions had cached files.

 

Have you tried to set your secondary drive as the boot HDD in BIOS and then see if it will boot?

 

NOTE - if there is no cache files on your seconday drive it may well fail on the first boot. I have noticed this a few weeks back when i decided to clear these caches.

 

D

Link to comment
Share on other sites

Yes, I'm booting from one or the other drive using the boot menu (F8) from the P5KC BIOS (original, but I also tried with a cross-flashed one). This should be equivalent to selecting a different boot disk in the BIOS.

 

I'm generating the /Extra cache manually so it's always up to date:

 

kextcache -m /Volumes/Boot1/Extra/Extensions.mkext /Volumes/Boot1/Extra/Extensions

 

The point is that it won't even reach the boot1h loader on the secondary drive. Swapping drives (physically) does not change things. The same drive that boots as primary will boot when secondary. The one that won't boot will never boot (primary or not): By boot I mean loading the Chameleon boot-selection menu.

My boot on the secondary stops here:

boot0: GPT
boot0: testing
boot0: testing
boot0: done

I think it's really a problem with boot0 that cannot locate the correct EFI partition to load boot1h from. The contents of the EFI partition must be OK, because when I boot with boot0 from primary and on the chameleon menu I select the secondary drive for loading kernel it works (as normally).

 

I'm not sure if it's a bug in chameleon/efi or some sort of corruption...

 

My Raid0 setup was generated with chameleon RC3, but using RC3, RC4 etc has no effect. I guess I tried to update the RC3 install on the secondary disk with RC4/RC5 when I first discovered I cannot boot from the secondary at all.

 

BTW: I'm using both the SATA channels on the ICH9 on my MB and also booting from a SIL3132 (works, but again from the first HD only).

 

I'm short of ideas. Tried using gptsync to create a mixed MBR/EFI partition, but that resulted in the raid not being recognized (ouch... had to rebuild MBR by hand).

 

So... guess I need to rebuild something in the EFI, just don't know what. :rolleyes:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...