Jump to content

RTL8101E/RTL8102E and AR5001 not working


bci24sg22
 Share

7 posts in this topic

Recommended Posts

Hello everyone! :) I just installed Mac OS 10.6.3 on my laptop CQ61-125EQ and the network cards (Ethernet and wifi) doesn`t work.

 

  • the ethernet card is an Realtek RTL8101E/RTL8102E
  • the wifi card is Atheros AR5001

The Mac OS see the ethernet card as a RTL8103E card and it doesn`t work.

Any ideea how to install at least one of the network card to access the internet???

 

Cheers!

Link to comment
Share on other sites

  • 2 weeks later...

This is all the info that i get with the command hwinfo --wlan in my ubuntu:

 

 20: PCI 200.0: 0282 WLAN controller							 
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_168c_1c
  Unique ID: y9sn.9AnOduZyIOF
  Parent ID: z8Q3.6XhEowSpRr2
  SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Atheros AR242x 802.11abg Wireless PCI Express Adapter"
  Vendor: pci 0x168c "Atheros Communications Inc."
  Device: pci 0x001c "AR242x 802.11abg Wireless PCI Express Adapter"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x137b 
  Revision: 0x01
  Driver: "ath5k"
  Driver Modules: "ath5k"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0xd6000000-0xd600ffff (rw,non-prefetchable)
  IRQ: 16 (no events)
  HW Address: 00:24:2c:2e:31:53
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v0000168Cd0000001Csv0000103Csd0000137Bbc02sc00i00"
  Driver Info #0:
 Driver Status: ath5k is active
 Driver Activation Cmd: "modprobe ath5k"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #7 (PCI bridge)

Link to comment
Share on other sites

  • 1 month later...

Is strange, but i had Wireless Card AR5001x PCI Desktop version and works in Snow native, do you tried add the pci dev to info.plist ?

 

For RTL8101E check this link: http://www.realtek.com.tw/downloads/downlo...p;GetDown=false

 

If none adapter works still, then check this link too: http://www.insanelymac.com/forum/index.php?showtopic=183356

Link to comment
Share on other sites

  • 6 months later...
Whats the ID of Atheros AR5001?

 

Type: Ethernet Controller

Driver Installed: No

Bus: PCI

Slot: Slot-2

Vendor ID: 0x168c

Device ID: 0x001c

Subsystem Vendor ID: 0x144f

Subsystem ID: 0x7131

Revision ID: 0x0001

Link Width: x1

Link Speed: 2.5 GT/s

 

I'm struggling to get it working right now, it shows up in System Profiler but still doesn't work.

Link to comment
Share on other sites

 Share

×
×
  • Create New...