Jump to content
InsanelyMac Forum
mtest

[SOLVED] Snow L. installed OK, but netbook won't boot from HDD, booting from USB install drive works fine !

Recommended Posts

Hi all,

I have a small issue with my fresh SL 10.6.3 installation on a Samsung N130. -_-

 

The installation goes very smoothly, no problem at all, using iATKOS S3 v2 on an external USB drive (had to restore the ISO to the drive and then make the drive bootable using Netbook Maker 0.8.4rc1).

 

My only problem is that I cannot boot my OSX directly from the bootloader's menu.

 

When I choose my Mac partition in the bootloader, I can briefly see the apple on a grey background and then automatically the computer goes back to the BIOS Post boot sequence. :(

 

The -v -f -x options does not change anything to the problem. Using -v I can't see any problem, everything goes way to fast.

 

The only thing I can say is that the reboot seems to happen at the moment where usually there is a switch between the text mode and the video mode.

 

The weird thing is that if I boot on the USB drive, then the same OSX partition is showing in the bootloader's menu as well. From there the computer can boots normally and I can enjoy my Snow L installation. :blink:

 

I'm quite new to this but it looks like a configuration problem of the bootloader itself... Maybe pointing to the wrong kernel or wrong root partition...

 

Appreciate your help.

 

Thank you very much. ;)

Share this post


Link to post
Share on other sites
Advertisement

Boot from the usb your hdd Mac OS X partition, install a chameleon pkg, (the rc5 is the last one) to your Mac OS X partition, reboot and see if that fix it, otherwise check the bootlist file on /Extra folder

Share this post


Link to post
Share on other sites

Issue fixed !

 

I've found several reports from people having a similar problem and one of them mentioned that replacing the kernel could be the solution.

 

I looked on my USB drive that can boot my HD OSX install and found several kernel files on it, one of them being named 'mach_kernel.atom'.

 

I gave a try and copied this patched kernel to my OSX partition on the HD, reboot and voilà !!!

 

The problem then is that my OSX booted but with a wrong screen resolution, no keyboard, no touchpad, nothing ! I just ran Netbook Installer again and on the next reboot everything was back in order (except sound, but this I will try to fix it later).

 

I'm still wondering what's the benefit of the use of iATKOS in my story...

 

So the thing to remember is that when you boot from a bootloader installed on a different drive obviously (at least with Chameleon) the bootloader takes the kernel from the external drive.

 

Anyway, now I'm happy with my Samsung N130 running Snow Leo 10.6.3 :wacko: , which is much better than this crappy Windows Seven Starter edition that comes by default with it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • It seems nice that chris1111 provided a patch, but I can't -- in good conscience -- download a random binary file from github and run it on my system.    What is so proprietary about his patch that he can't include source? I think I'll wait until the updated driver comes out before I update...  Does anyone know where to look for updates to the webdriver from Nvidia? I've ever found a page that lists them, just links to the actual files to download, and that root is not 'browsable'. I'd like to monitor that site to see when a version is updated for the 17E202 build. Once that is released, I can update OSX and should be fine.  
    • hey MaLd0n  It's been a while since I used clover, so a lot of things went rusty. Can you please look at my setup and guide/help what should be done next?  https://fex.net/354949878474?fileId=441517695   Current setup:  GA-Z97X-UD3H Xeon e3 1245v3  Msi GTX 1050ti Gaming X
    • Hi @fabiosun and thank's for your patience with an old and stubborn man.   I am 100 % sure that my MSR 0xE2 register is unlocked thank's to you.   My system is 100% stable and I haven't had one kp with this configuration in the last two weeks.    I'm now running without TSCAdjustReseat.kext and I can't se any issues in performance with or without that kext. What I however can se is that the amount of total energy consumed during the test-cycle are 10 times higher without the kext (three times Cinebench CPU and two times Luxmark open CL) as you can see in the output from my AppleIntelInfo.kext attached in my earlier post.   I have tested running Cinebench five times in a row with or without TSC kext and have exactly the same performance (see attached files). Temperature is not a problem at all.   Everything seems to be fine so I guess I have to wait and see if upcoming 10.13.5 maybe recognise Intel Xeon w series processor as native.     
    • Tried with HPET enabled and disabled so I don't think it's that. I'd tried with bus ratio before to no effect but wouldn't hurt to try again. The clock runs at the correct speed.
    • could be an HPET / TSC Sync issue. does your system clock slow down or run faster then it should. also check cpu and buss ratios.


×