Jump to content

ALC889 Issues on Intel DH57DD mobo with MultiBeast 2.0

1 post in this topic

Recommended Posts

Hey all,


Built two systems over the weekend with rackmounted cases for some friends who want to have computers running dj stuff (Like Ableton and Reason if you wanna know) with their live instruments.


Both systems are based on the Intel DH57DD board.

Both are running OS X 10.6.3 (fresh install from new DVD).

Used TonyMacs sweet boot disc and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 2.0.


One PC has a 2.8 GHz Dual Core processor and a 250 gig HD

The other has a 2.8 GHz Core i7 and a 64 Gig SSD (system screams - loads OS in under 20 seconds!)


I followed the guide on this forum (slightly different board):



I have ethernet up and running (from process in guide above) and have installed updates and most everything appears to be going pretty well.


I have 3 lingering issues. None are huge deal breakers for my friends, but I'm just curious enough and a perfectionist enough to try and get it right. Take a look. Can anyone provide some help?


1. Neither machine has working audio (they'll be using firewire audio devices anyway, so not a big deal... but still...) It's a Realtek ALC889. I've tried using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 2.0 to install the appropriate Legacy Kext, HDAEnabler, and the AppleHDA 10.6.2 Rollback - as well as various combinations of those 3 kexts and the ones for the ALC889a with no success on either system. I also tried loading the AppleHDA.kext from here:


also with no success. Anyone got any other ideas?


2. The Core i7 system will not restart correctly. It shuts down OS X but then hangs. The computer doesn't ever power down, much less, get started again. I've repaired cache and permissions several times and tried reloading the EvOreboot.kext in Extra/Extensions - no dice. Exact same kext setup on the dual-core system and restart works like a charm. I will say that the problem seems to have appeared after I installed the custom ethernet kext, but as both systems use this kext, why would it only effect the restart on the i7? Again, thanks for any tips/suggestions!


3. The dual-core system refers to show anything other than "unknown processor" in the "About this Mac" section. SMcputype insmbios is set to 257. I think that should be correct, but it's not working.


I feel like these are all relatively minor issues, and was blown away with how easy this was to actually accomplish. Massive kudos to the devs who have put this together. Hoping somebody can get me across the finish line! Thanks again!

Link to comment
Share on other sites


  • Create New...