Jump to content

[resolved] logical errors on my boot hdd

5 posts in this topic

Recommended Posts

I tried repairing with fsck -y but I am getting...


bad super block: magic number wrong

unable to rebuild b-tree (or something like that) and then it says the disk cannot be repaired.


it's retail snow leo install on an external usb drive... updated to 10.6.3. everything was running fine.

I am currently downloading diskwarrior boot image and I am going to try booting it using boot123 or something similar... any suggestion? warnings ?


I can actually access all files using transmac on windows... so the drive should be clearly repairable (or so I think)


all help is greatly appreciated.

Link to comment
Share on other sites

It looks that way, yes.


I have tried but I can't figure out how to boot my Disk Warrior CD using my Chameleon Boot CD.


Please post here later if it works for you.


The easiest way would be to just run it from another installation of OS X.

Link to comment
Share on other sites

installed snow leo on a 16gb usb stick... ran diskwarrior... skipped step 9 coz it took forever and then some and at the end it crashed... everything works now... still haven't found any corrupted files.


p.s. it's insane... you can even run snow leo from a usb stick these days...

Link to comment
Share on other sites


  • Create New...