Jump to content

Sony Vaio SZ with Dell Wireless 1390 installation report


3 posts in this topic

Recommended Posts



Yesterday I received the Dell Wireless 1390 miniPCI-express. So I opened my Sony Vaio SZ, removed the Intel 3945 card, put the Dell one ...

Verified that the card worked under Windows (which worked well after installing the Broadcom Drivers from the Lenovo 3000 package available there : http://www-307.ibm.com/pc/support/site.wss...ocid=MIGR-63550 0


Then I went one installing again MacOS X with the 10.4.6 DVD patched by JaS.


Selected the Intel base package, the SSE3, Common Wireless.


Added the following lines to get the ethernet card working in: \System\Library\Extensions\IONetworkingFamily.kext\Contents\PlugIns\AppleYukon.kext\Contents\Info.plist















<string>Yukon Ethernet Adapter 88E8036</string>

























Then I repaired the permissions, rebooted.

Both wireless and ethernet working....


Installed SwitchResX, installed a new 1280x800 resolution


I then installed the patch to see the battery in the top bar. Unfortunately, while it shows up fine, it's not updated always showing the value detected at boot time.

Installed the ALPS driver, scrolling works but is far too sensitive with default settings, will need to look into that.


So remaining main issues:

1-Battery meter in menu bar not updated

2-Unit can't go to sleep, won't be able to restart the laptop. This means that OS X is of no use to me :blink:


Remaing items not working:

-Build-in web cam and fingerpring reader


Not tested, but I believe they should work:

PCMCIA card,

Memory Stick reader

PCI-Express card reader


If anybody can clear up some of the issues and a way around them it would be greatly appreciate.




Link to comment
Share on other sites

  • 1 month later...

which model of sz do you have?

I have sz1m/b and I don't have see3.Can I install this patch without trobles?

I also tried to modify like you appleYukon.kets but it still doesn't go.In system profiler I see

no modem but in Network/location there is ethernet.When I go to network setup however I can't select it.Do you know why?

Link to comment
Share on other sites


  • Create New...