Jump to content

duplicate open with (in snow leopard 10.6.3)


3 posts in this topic

Recommended Posts

I am using OS X 10.6.3

whenever I right click a file in Finder, I got multiple open with,

 

I had tried

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

 

and deleting files

com.apple.LaunchServices,plist 
com.apple.LaunchServices.QuarantineEvents

 

also tried with OnyX

 

but finder still showing duplicates open with

 

There is a strange thing, I tried to capture the screen using Grab, but .... when Grab is active the "Open with" is correct and there are no duplicates.

 

Is there other program besides Grab that I can use to capture the screen?

 

Any suggestions/ideas?

Link to comment
Share on other sites

I changed the kernel to vanilla 10.6.3 (before I was using teateam modified kernel) and now I am able to capture the screen shot using Grab.

 

I noticed the pattern, they are repeated 4 times, no matter what file I selected.

 

Now I am suspecting that perhaps there is a third party kexts/application interferes with Finder, because Path Finder doesn't show any duplicates. But I prefer to use Finder than the heavy Path Finder

post-508994-1272217441_thumb.jpg

Link to comment
Share on other sites

i confirmed this is a bug, perhaps Finder and PS2 mouse (as the trackpad is recognized) don't match well.

this is happening with VoodooPS2 and ApplePS2, but not when I right click the icon using an external USB mouse.

however, there is a simple workaround, i only need to right click anywhere except on a file, then right click the file again, and the duplicates are gone.

 

perhaps there is a memory leak within the kext? Are there any other alternatives besides VoodooPS2 and AppPS2?

Link to comment
Share on other sites

 Share

×
×
  • Create New...