Jump to content

SATA drive not recognised


9 posts in this topic

Recommended Posts


I just tried to install OS X86 on my PC! But when i come to the screen where i can select my hard disk, and i open the Disk Utilities, i only see my DVD drive, and not the hard disk.

I am using an Asus A8V Deluxe motherboard, and the wiki says, that won't be a problem.

The partition where Os X needs to come is FAT32 (logical). Also primary won't work.

And uuh.. Please don't tell me any VMWare-solutions, cause i really want it NATIVE!


Ubuntu install can see my HDD, and Windows can only see it if i insert a floppy disk.

Can someone help me? I already searched the wiki and the IRC channel.



More information:

Asus A8V Deluxe

AMD Athlon 64 3000+ Venice (so with SSE3)

Radeon 9800 Pro

WD 250GB SATA300 16MB (set the jumper to sata150)

2*512MB memory

Link to comment
Share on other sites

Vmware disk can to copied to partitions, so don't wory you could use the Vmware method and get native.

How big are the partition on the drive? And want type are they. And by the was you can't install OS to a logical drive. It must be primary and I think id=af or type=0afh


Link to comment
Share on other sites

But... The whole hard disk isn't recognised!

And as i said, i also tried primary partition to install it on. And i even said that the partition type was FAT32.

It is 30GB big.

And.. Is that copying from VMWare to Partition easy, or do i need to burn linux live cd's?



oh and i'm using the Hotiso copy :)

Link to comment
Share on other sites

quickverson keybaords bracking, search forum


Partition effect os x seeing drive, make sure your desired partition is id=af.



No linuk Cd other than it's good to be able to set windows back to active if this go wrong and your mchine urns off.

So set the partition active. and type=id, the same size as your image or expain the image, fix disk latter

and use the 'dd'program like this to copy to parttion

dd if=FreeBSD-flat.vmdk of=\\?\device\harddisk0\partition2 bs=32256 skip=1 --progress

where FreeBSD-flat.vmdk is the image and harddisk0\partition2 is the partition you want

Test in Vmware


Link to comment
Share on other sites

I think the only way to install with SATA HDs without installing via vmware or using a patched DVD (which I have no idea how to do) is to buy a PCI SATA controller that's supported natively by OS X. There's a thread about this somewhere in the forums.

Link to comment
Share on other sites

  • 3 weeks later...

I have a ASUS A8V Deluxe with 2 Samsung HD:


170MB SATA1 (1.5Gb/s)

250MB SATA2 (3Gb/s, with jumper setting to 1.5 mode)


OSX 10.4.3 works perfectly on SATA1, but crashes on SATA2.


My GeForce FX5200 is not work, but I don't know if I need a driver for GeForce (I used to try many, but don't works) or for AGP.

Link to comment
Share on other sites


  • Create New...