Jump to content

Finder Bug?


1 post in this topic

Recommended Posts

I've been downloading a large torrent with about 80 files in it. When I looked at the files in the finder several times today (opening and closing the windows) I was surpised that the modification date/times weren't changing. I opened up a terminal and did a "ls -alrt" on the files and found that they all had current dates/times as the should because the torrent is still downloading. I tried doing a "sync" to flush the disks and went back to the finder and still nothing. There is no "refresh" on the finder so I tried opening and closing finder windows just to make sure I was getting it to refresh as best I could. Still nothing.


Finally, I paused my torrent and rebooted. Then the finder showed the expected date/timestamps on the files HOWEVER after restarting the torrent an hour ago, the files date/times haven't changed even though if I pop a terminal window open I can see they have all been modified within the last minute.


If I do a "Get Info" on one of the files, the date/time is correct. Just the action of doing the Get Info on a file makes the date/time of that particular file show corretly in the Finder list view also.


Any ideas? Is this normal behavior for the Finder?


UPDATE: I went into a shell created a file test.txt. I went back a minute later and touched the file and watched the date/time update in the finder list view correctly. So maybe this a "Transmission" client thing and the way it handles file IOs.


thanks -


Link to comment
Share on other sites


  • Create New...