Jump to content
InsanelyMac Forum
oldnapalm

Instalação do Snow Leopard via USB

Recommended Posts

Instalação do Snow Leopard via USB usando o myHack ou OSX86 ModUSB

 

O que você vai precisar:

 

- Mac OS X funcionando (pode ser em outro PC ou Mac);

Atualizado: se você só tem o Windows, pode usar o programa TransMac e um CD de boot.

Use a opção opção "format with disk image". Se a imagem for comprimida o programa vai pedir para expandir, abra o arquivo (open disk image), clique com o botão direito sobre ele, selecione "expand", salve uma imagem expandida e repita o procedimento usando a nova imagem.

 

transmac.png

 

- Drive USB (pen drive) de pelo menos 8 GB;

- Instalador myHack (http://osx86.sojugarden.com/downloads/) ou OSX86 ModUSB (http://blog.nawcom.com/?p=569);

- DVD ou DMG do Snow Leopard.

 

Procedimentos:

 

Abra o Utilitário de Disco, selecione a partição do drive USB e clique em Apagar. Selecione o formato Mac OS Expandido (Reg. Cronológico) e clique no botão Apagar...

 

apagarp.png

 

Agora clique em Restaurar, arraste o Mac OS X Install DVD para Fonte e a partição do drive USB para Destino, então clique no botão Restaurar. Esta operação leva vários minutos.

 

restaurar.png

 

Terminada a restauração, rode o instalador myHack. Lembre-se de clicar em Alterar Localização da Instalação... e selecionar o drive USB como destino, caso contrário será instalado sobre o sistema que está usando.

 

alterar.png

 

Clique no botão Personalizar e selecione as opções adequadas ao seu sistema.

 

personalizar.png

 

com.apple.Boot.plist - Instala um arquivo com.apple.Boot.plist em /Extra, configurado para usar a kernel flag arch=i386, EthernetBuiltIn e modo gráfico VESA 1024x768.

 

GraphicsEnabler - Adiciona a opção GraphicsEnabler=Y no arquivo com.apple.Boot.plist citado acima.

 

GraphicsDisabler - Remove algumas kexts gráficas para forçar o modo VESA. É usada por padrão se estiver criando um USB de instalação. Não use esta opção se estiver usando algum injetor ou string EFI.

 

Chocolate Kernel - Instala a chocolate_kernel e modifica o com.apple.Boot.plist para usá-la por padrão. Apenas para processadores não suportados pela kernel vanilla (Pentium4, i5, AMD, etc). Não selecione se você tem CPU Core 2 ou i7.

 

ApplePS2Controller - Instala as kexts AppleACPIPS2Nub e ApplePS2Controller, para dar suporte a teclado e mouse PS/2. Usado principalmente em laptops, que normalmente têm teclado e trackpad conectados a uma interface PS/2.

 

EvOreboot.kext - Adiciona funcionalidade de reiniciar e desligar em sistemas que usam NullCPUPowerManagement.kext.

 

IOATAFamily.kext - Fornece suporte PATA (IDE) para vários sistemas. Também possibilita o uso de dispositivos SATA com modo AHCI desativado em várias placas baseadas em ICHx. Inclui AppleIntelPIIXATA.kext, IOATABlockStorage.kext e IOATAPIProtocolTransport.kext na pasta plugins.

 

IONetworkingFamily.kext - Inclui suporte para várias placas de rede não suportadas ou que não são 100% funcionais. Inclui AppleBCM5701Ethernet.kext, AppleYukon2.kext, AppleIntel8254XEthernet.kext, Intel82574L.kext, AppleRTL8139Ethernet.kext, RealtekR1000.kext, AppleUSBEthernet.kext, nvenet.kext e AppleUSBGigEthernet.kext na pasta plugins.

 

LegacyAppleRTC.kext - Previne o erro de "CMOS Reset" encontrado em várias placas mãe. Deve ser removida (e substituída pela correção no DSDT) antes de iniciar a kernel x86_64.

 

NullCPUPowerManagement.kext - Desativa a AppleIntelCPUPowerManagement.kext, necessária até que você modifique o DSDT para suportar SpeedStep nativo.

 

SleepEnabler.kext - Ativa o funcionamento do repouso (sleep) em vários sistemas com AppleIntelCPUPowerManagement desativado. Nova versão, testada no 10.6.0 a 10.6.3 e não causa kernel panic como a versão anterior.

 

 

Com o USB de instalação criado, faça o boot por ele e instale o Snow Leopard numa partição do HD. O myHack modifica o OSInstall.mpkg e o OSInstall framework para permitir que se instale em partição MBR.

 

Após o término da instalação, faça o boot novamente pelo USB, mas selecione iniciar pelo HD.

 

Com o sistema rodando, instale o myHack na partição do Snow Leopard, ou na partição EFI caso tenha usado esquema de partição GUID.

 

Se optar por instalar na partição EFI, execute o seguinte comando no terminal

diskutil list

Veja o número do HD onde instalou o sistema e substitua o X no próximo comando por este número

sudo diskutil eraseVolume "HFS+" "EFI" /dev/diskXs1

 

A configuração do Chameleon pode ser feita pelo aplicativo Lizard (http://forum.voodooprojects.org/index.php/topic,842.0.html).

 

lizard.png

 

Nas preferências do Lizard, configure o Extra folder Path. Selecione a pasta Extra da partição onde você instalou o Chameleon.

 

configu.png

Share this post


Link to post
Share on other sites
Advertisement

Nunca usei o myHack por isso queria esclarecer algumas duvidas ...

 

Segui o tutorial pra não desviar do procedimento e assim ter respostas baseadas no mesmo.

Meu video reconheceu nativamente com a exibição do video de entrada Boas Vindas ... e o audio somente pelo fone de ouvido que é USB.

Picture1.jpg

 

A instalação ainda esta como ficou e nenhum ajuste foi feito (ainda esta sem rede e sem audio onboard) e não fiz a instalação do myHack no HD pois é nisso que moram minhas duvidas.

 

A janela do instalador mostra assim:

Picture2.jpg

 

As duvidas ...

 

1. Deixando marcado com.apple.Boot.plist o que existe na L/P/S não vai mais ser usado?

2. Precisa deixar marcado GraphicsEnabler? ... sendo que o video esta 100% fucnional.

3. NullCPUPowerManagement.kext e SleepEnabler.kext deixo marcado? ... pode fazer o S.U. de boa?

4. Quais as marcações a fazer baseado no imagem acima?

 

A rede eu não sei se foi um caso isolado mas depois que fiz o restart e voltei pro Leopard não acessava a precisei desligar e ligar novamente pra funcionar. Mas isso eu vou fazer depois mesmo pois no Leopard eu tenho aparentemente duas kexts rodando e preciso saber se isso esta certo hehehe ...

 

Picture_3.png

Picture_4.png

Share this post


Link to post
Share on other sites
1. Deixando marcado com.apple.Boot.plist o que existe na L/P/S não vai mais ser usado?

Com o Chameleon v2 o de /L/P/S nunca é usado, mas sim o de /Extra.

 

2. Precisa deixar marcado GraphicsEnabler? ... sendo que o video esta 100% fucnional.

Deve estar funcional porque tem GraphicsEnabler=y no boot que você usou, mas quando fizer boot pelo HD, se não tiver esta opção, ou alguma kext "enabler", ou ainda uma string EFI, não vai carregar os drivers da nVidia.

 

3. NullCPUPowerManagement.kext e SleepEnabler.kext deixo marcado? ... pode fazer o S.U. de boa?

Pode marcar, se mais tarde fizer o fix do SpeedStep no DSDT basta remover as kexts. Eu não cheguei a testar o update com a SleepEnabler, mas o cara que fez diz que funciona.

 

4. Quais as marcações a fazer baseado no imagem acima?

Todas as opções estão explicadas no primeiro post, tem que ver quais são necessárias no seu sistema.

 

A rede eu não sei se foi um caso isolado mas depois que fiz o restart e voltei pro Leopard não acessava a precisei desligar e ligar novamente pra funcionar. Mas isso eu vou fazer depois mesmo pois no Leopard eu tenho aparentemente duas kexts rodando e preciso saber se isso esta certo hehehe ...

Estranho. Você instalou a IONetworkingFamily.kext do myHack? Estava funcionando no Snow?

 

Já aconteceu comigo, eu tenho o Snow e o Leo, ambos funcionam, mas algumas vezes reiniciando num e entrando noutro a rede pára de funcionar.

Share this post


Link to post
Share on other sites

Bom Dia.

 

Como é que eu me livro nesta instalação do kernel panic do IOATAFAmily?

Marcando ou não no myhack installer ele aparece.

 

Obrigado.

 

 

Com o Chameleon v2 o de /L/P/S nunca é usado, mas sim o de /Extra.

 

 

Deve estar funcional porque tem GraphicsEnabler=y no boot que você usou, mas quando fizer boot pelo HD, se não tiver esta opção, ou alguma kext "enabler", ou ainda uma string EFI, não vai carregar os drivers da nVidia.

 

 

Pode marcar, se mais tarde fizer o fix do SpeedStep no DSDT basta remover as kexts. Eu não cheguei a testar o update com a SleepEnabler, mas o cara que fez diz que funciona.

 

 

Todas as opções estão explicadas no primeiro post, tem que ver quais são necessárias no seu sistema.

 

 

Estranho. Você instalou a IONetworkingFamily.kext do myHack? Estava funcionando no Snow?

 

Já aconteceu comigo, eu tenho o Snow e o Leo, ambos funcionam, mas algumas vezes reiniciando num e entrando noutro a rede pára de funcionar.

Share this post


Link to post
Share on other sites

Resolvido, refiz tudo marcando novamente o IOATAFAmily e está instalando agora.

Mas tenho uma dúvida, fiz o processo de restauração de uma cópia do Mac OS X Install DVD RETAIL, é essa mesma? Baixada da internet.

 

Valeu.

 

Bom Dia.

 

Como é que eu me livro nesta instalação do kernel panic do IOATAFAmily?

Marcando ou não no myhack installer ele aparece.

 

Obrigado.

Share this post


Link to post
Share on other sites
Resolvido, refiz tudo marcando novamente o IOATAFAmily e está instalando agora.

Mas tenho uma dúvida, fiz o processo de restauração de uma cópia do Mac OS X Install DVD RETAIL, é essa mesma? Baixada da internet.

 

Valeu.

Exatamente, deve ser utilizada uma versão "retail" do Snow Leopard, ou seja, um DVD original, sem modificações.

 

O uso de cópias baixadas da internet não é incentivado, mas deve funcionar.

 

Quanto ao IOATAFamily panic, existe um fix por DSDT, explicado nesse tópico

http://outlawcowboy.org/forum/showthread.php?t=17

A vantagem é que a kext modificada pode ser substituída numa atualização e o sistema pode voltar a ter o panic, e o fix via DSDT vai continuar funcionando independente da kext ser atualizada.

 

Na versão 10.6.3 o problema foi resolvido.

Share this post


Link to post
Share on other sites

eu to com um proble, seguinte...

tenho apenas 1 hd, formatado como GUID, com 3 particoes

1 delas ja instalado o w7

outra com o leopard 10.5.2

e outra vazia

 

quando eu formato o pendrive pra colocar a imagem, eu formato como GUID tambem

instalo o myhack belezinha

consigo avancar pra instalacao at'e a tela de escolher a linguagem de instalacao pro snow leopard, clico em avancar e fica carregando a instalacao eternamente

 

bom, alguem tem alguma ideia do que eu posso fazer?

 

nao sei se ajuda, mas o hardware 'e

E8400

GA-EP35-DS3R

ATI HD4850

(soh pra confirmar, quais configuracoes exatamente eu deveria marcar no myhack?)

Share this post


Link to post
Share on other sites
consigo avancar pra instalacao at'e a tela de escolher a linguagem de instalacao pro snow leopard, clico em avancar e fica carregando a instalacao eternamente

Fica lendo o pen drive ou fica parado?

 

Se você já tem o Leopard pode usar esse método, não precisa do pen drive

http://www.insanelymac.com/forum/index.php?showtopic=215559

Share this post


Link to post
Share on other sites

Ola, gostaria de esclarecer uma duvida, as kexts selecionadas no hack s'ao instaladas no snow leopard diretamente (interrogacao, teclado bixado). E antes, quando eu usava apenas o chameleon, tinha que aplicar o uuid em tres arquivos, nao precisa mais disso (interrogacao). Grato.

Share this post


Link to post
Share on other sites

As kexts selecionadas no myHack são instaladas em /Extra/Extensions na partição selecionada.

 

Não entendi sobre "aplicar o UUID em 3 arquivos". Se você se refere ao "hardware UUID", o Chameleon 2.0 RC4 injeta automaticamente, não é mais necessário usar kext para isso. O myHack instala uma versão modificada do Chameleon baseada na RC4, que tem este recurso.

 

Na verdade o myHack é apenas um instalador que facilita as coisas, mas tudo que ele faz é instalar o Chameleon e as kexts que você seleciona, além da fakesmc que é essencial. Se preferir, pode instalar os itens individualmente. Esse tópico mostra várias formas de instalar o Chameleon

http://www.insanelymac.com/forum/index.php?showtopic=209787

Share this post


Link to post
Share on other sites

To com Problema aqui na hora de restaurar a imagem para o pendriver. quando vou restaurar,aparece o seguinte erro: nao foi possivel localizar nenhuma informação de escaneamento. a imagem de origem precisa ser escaneada antes de ser restaurada.

 

se eu for restaurar a imagem com ela montada, vai demorar bem 1 dia,, e eu sempre restaurei só o .dmg e deu certo. em 15 minutos ja tava restaurada... mas agora só da esse erro,, independente da imagem que eu use,,ou pen driver e etc.... :(

Share this post


Link to post
Share on other sites

Nunca vi esta mensagem.

 

Você tentou montar a imagem, deixar o sistema fazer a verificação, depois desmontá-la e então fazer a restauração?

Share this post


Link to post
Share on other sites
Nunca vi esta mensagem.

 

Você tentou montar a imagem, deixar o sistema fazer a verificação, depois desmontá-la e então fazer a restauração?

 

Ola a todos...Old esta mensagem ocorre quando se tenta utilizar de uma DMG modificada, a exemplo de nos mesmos efetuarmos a substituicao do Osintall.mpkg modificado para MBR. Resumindo, se a imagem do Snow nao for retail, ocorrera esta mensagem ao tentar restaurar...espero que ajude...

 

Obs...as imagens DMG do Snow que ja foram modificadas para instalar em MBR sao para instalar via Mac (outro Leopard ja instalado)...eh que eu mesmo redimensionei (abri) e substitui o Osinstall.mpkg a fim de evitar ter de instalar somente em GUID. Assim instalo de outro Mac em MBR direto. Quando quis usar uma DMG para montar um USB de instalacao, so deu certo com a retail intocada...

 

Abracos

Share this post


Link to post
Share on other sites

Oi galera do pomar transgenico,

 

Nao entendo quase nada de terminal e sistemas, mas estou indo.

Estou seguindo o tutorial certinho, montei a pen drive sem problemas, bootei, instalei.

 

So na hora das opcoes do MyHack que tive duvidas, minha tela n era igual a do tutorial, tinha algumas opcoes a mais e eu n sabia o q escolher, Apenas tirei o Sleep.

 

Agora estou dentro do Mac os que esta rodando no pc, mas o video ta uma resolucao ruim, nem o wireless nem o som funciona, mas a rede on board funciona.

 

Estou com duvida onde instalar o Chameleon 2.0, particao efi ou onde esta o sistema ?

 

Tenho apenas 1 hd com uma particao de 300 para o mac e a outra particao eh livre para arquivos, mas ainda n defini seu formato.

 

Placa mae gigabyte x58 extreme

processador i7 950

gtx nvidia 275

hd sata 2 (rodando na bios ahci)

monitor 24 (1900x1200)

wireless pci

Share this post


Link to post
Share on other sites

O Chameleon você pode instalar tanto na EFI quanto na partição do sistema, funciona das duas formas.

 

Sobre áudio e vídeo, veja no fórum "perguntas frequentes", tem um tópico sobre cada assunto.

 

http://www.insanelymac.com/forum/index.php?showforum=203

 

Veja qual o chipset da placa wireless para saber se ela é suportada. Nas perguntas frequentes tem um tópico sobre como identificar dispositivos PCI no Mac OS.

Share this post


Link to post
Share on other sites

Instalei o Chameleon pelo pkg na particao do sistema e depois acabei instalando pelo lizard, so n achei a tela GENERAL para indica a pasta dos Extras, alias, nem achei onde ele foi instalado para achar a pasta dos extras..

 

Qnd reiniciei apareceu o seguinte erro

 

depois de passar pelo darwin, na hora da maca~ com a rodinha carregando, a tela escurece e aparece a seguinte msg em varias linguas

 

YOU NEED TO RESTART YOUR COMPUTER. HOLD DOWN THE POWER BUTTON UNTIL IT TURN OFF, THEN PRESS THE POWER BUTTON AGAIN.

Share this post


Link to post
Share on other sites

como bootar pela pen drive e entrar no hd ?

qnd chega no darwin, escolho o hd e da aquela msg em varias linguas.

 

pelo -x -v, passou pela tela do myhack, depois terminou na tela do terminal assim:

 

dsc08390z.jpg

Share this post


Link to post
Share on other sites

Estranho, talvez seja algo que o myHack instala.

 

Como falamos no chat, funcionou instalando o Chameleon e as kexts básicas com os pacotes do HackBoot.

 

Quanto à placa de vídeo, parece que você precisa inserir o ID da sua placa no Info.plist das kexts. Se não funcionar com o GraphicsEnabler, tente com a NVEnabler.

 

http://www.insanelymac.com/forum/index.php?showtopic=215980

Share this post


Link to post
Share on other sites

Fiz a instalação conforme o tutorial, e a instalação foi concluida com sucesso, mas quando mando iniciar o sistema trava conforme imagem.

Já tentei iniciar com -x mas trava no mesmo ponto.

 

O pode estar acontecendo?

 

Configuração do notebook DV2872br:

Intel Core 2 Duo T5550 de 1,83

NVIDIA GeForce 8400M GS

 

foto0003n.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×