Jump to content
ErmaC

[Mini Guida] Abilitare L'account root

4 posts in this topic

Recommended Posts

Abilitare l'account root in Snow Leopard

Scrivo queste brevi righe per chi voglia usare l'account root che in Snow Leopard e' disabilitato di default.

 

Vi avviso che abilitando suddetto "user" potreste essere esposti a "pericoli" di sicurezza

quindi prendete queste info con le giuste precauzioni (vi posso consigliare di non usarlo per navigare in internet)

Io personalmente uso il root account per le operazioni di manutenzione del mio sistema.

Iniziamo:

- Andiamo nella cartella Sistema --> Libreria --> CoreServices

- Entrati in questa cartella avviamo Utility Directory, togliamo il lucchetto (sblocchiamo l'applicazione), e successivamente inseriamo le credenziali di amministratore.

- Dal menu nella barra di sistema (Composizione) selezioniamo "Enable Root User"

- Scegliamo "Change Root Password" dal menu e scegliamo una password per l'user root

Abbiamo finito riblocchiamo l'applicazione e facciamo il log-off

 

Ora nella finestra di login avremo ..altro... clicchiamo e inseriamo come nick(nome) root e come password quella che abbiamo scelto in precedenza...

 

Successivamente potete continuare ad usare il vostro standard account,

se poi siete stufi e non volete piu' usare il root account dovete solo invertire il processo usando lo standar account per disattivare il root account.

 

Fatene buon uso :)

 

Fabio

Share this post


Link to post
Share on other sites
Advertisement

Non capisco che senso ha?

Basta avere un account amministratore e puoi fare tutto quello che fa root, perchè andare a rischiare problemi con root?

Share this post


Link to post
Share on other sites
Non capisco che senso ha?

Basta avere un account amministratore e puoi fare tutto quello che fa root, perchè andare a rischiare problemi con root?

 

Questa breve spiegazione vuole essere una "dritta" (trucchetto) su una funzionalita' disabilitata, non immediatamente accessibile.

 

Oggettivamente con l'account aministratore fai anche tutto (inserendo costantemente la password)

con l'account root no.

 

Poi di senso puo' averne anche poco.(Ma la miniguida ha lo scopo di spiegare la possibilita' di usarlo).

 

Fabio

Share this post


Link to post
Share on other sites

Aggiungo per completezza anche la possibilità del comando su da terminale (avendo root abilitato come ha illustrato iFabio) si esegue la serie di comandi necessari, si chiude il terminale e non c'è la necessità di fare logout e loggarsi come root

 

Così le sapete tutte e scegliete come fare.

 

Giorgio

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Vyzantion
      I can not manage to install Catalina on this legacy Asus machine that runs Mojave fine. When the installer boots up, DiskUtility does not see the internal hard-drives, neither the master SATA one or the the slave, ATA one. I have discussed this already on the Clover section with Slice, he told that some kext seems to have changed from Mojave to Catalina, he told me to use IOReg. Since then, I have postponed my work on Catalina due to the issues regarding the Mojave supplemental updates.
      I have decided to start a new topic in here, due to visibility reasons and some new turn. The latest version of the dosdude1 patcher for unsupported Macs, discussed on Macrumors forums, patches the installer so that DiskUtility sees the internal hard-drives, I am able to install Catalina but, on first boot, the OS gets into a kernal panic with the message ”still waiting for root device”. I have searched online for this error, I have found Information regarding previous macOS versions with solutions that seem to have little to no relevance for the present issue.
      Before installation finishes, I receive a message like ”Installation finished on Macintosh HD Data”, instead of ”Installation finished on Macintosh HD”. I admit this split between the two in Catalina still confuses me, perhaps this is how it was suppose to be? Perhaps something that was suppose to end up on Macintosh HD ends in Macintosh HD Data?
      I admit the DVD-Rom and hard-drives are wired kinda of weird by some guy in a PC service, he said this is the optimum combination, something the ATA hard-drive is slave to the DVD-Rom. Perhaps this causes confusion into Catalina? On Mojave this configuration was fine. 
      Probably the solution suggested by Slice is the best, to replace one or more kext from Catalina with the Mojave versions of them. I do not know yet how to identify and replace them. If any other solutions seem possible, I am open to them.
      Specs:
      Asus P5P41TED motherboard.
      Intel Core 2 Duo E 8500 
      2 gb ram DDR 3
    • By osxone
      Breaks out my shield and gets ready for the flac
       
      I deleted a line out of the root which was associated with my Bluetooth device
      sadly like all things I now realize I shouldn't have done that tried to find the deleted line and well, was not able to.
      I now have no Bluetooth devices even when I plug in different usb Bluetooth dongles.
      so my question to those with more  wisdom is :- is it possible to extract the missing line from the Mojave installer and re install it
      or is it a re install only?
      I am not too concerned if it is a re install, we all learn and even an old git like me still learns. I did try x code Bluetooth to re install that way
      but for some reason it did not work.
      remember go easy you will be an old git one day
      thanks and waits for the stick
      osxone
    • By sachin7788
      Hi, 
       
      I have prepared the USB installer using 
       
      http://www.insanelymac.com/forum/files/file/426-el-capitan-mbr-patch/
       
      And now when boot using all the combinations of boot flag ( USBBusFix=Yes PCIRootUID=0 -v -x -f IGPEnabler=No, GraphicsEnabler=Yes npci=0x3000) 
      Each time it gets stuck at 
       
      Still waiting for the root device
       
      Please help, Does below would help
       
      http://www.insanelymac.com/forum/topic/306777-guide-usb-fix-el-capitan-1011/
       
      thanks
      Sachin 
    • By yubo56
      hp dv7t-6c00 Specs:
       
      2nd generation Intel® Core i5-2430M Processor (2.4 GHz, 3MB L3 Cache) Turbo Boost to 3.0 GHz
      1GB AMD Radeon HD 7690M GDDR5 Discrete Graphics [HDMI, VGA]
      6GB DDR3 System Memory (2 Dimm)
      750GB 7200 rpm Hard Drive with HP ProtectSmart Hard Drive Protection
      17.3-inch diagonal Full HD Anti-glare LED-backlit Display (1920 x 1080)
      Blu-ray player & SuperMulti DVD burner
      HP TrueVision HD Webcam with Integrated Digital Microphone and HP SimplePass Fingerprint Reader
      802.11b/g/n WLAN
      6 Cell Lithium Ion Battery
      Standard Keyboard with numeric keypad
       
      Tried both myHack with Mavericks
      and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] with Lion,
      both hung on the same place
       
       
       
      Problem:
       
      I'm trying flags "-x -f -v GraphicsEnabler cpus=1" but I hang at "waiting for root device" on booting from the installer. Verbose output says something like "Version of IOUSBFamily version requested by GenericUSBXHCI.kext incompatible (5.0.0a1)" (sorry, this isn't verbatim, I don't have the exact output with me)
       
      I tried looking at the Info.plist for the IOUSBFamily kext, and it said version 4.4.0, while GenericUSBXHCI requested 5.0.0a1; I've been unable to find another version online? I do not have an AHCI option in my BIOS.
       
      Does anybody have any experience with my laptop? I don't mind if I can't use Mavericks, any OSX version will be plenty for me.
       
      Sincerest thanks from one very confused noob,
      yubo56
       
      P.S. I'm a student still, and while I will try my best to test all suggestions promptly schoolwork does come first, so apologies in advance if I don't check up in a while!
    • By Tyler Worth
      For some reason i can run ML on VMware with this machine but I cant install for the life of me.
       
      I followed this Tut: Click here
      For some reason I am getting stuck at Still waiting for device. (picture attached)

       
      My Rig:
      CPU: Intel® Core™ i7-3630QM Processor
      Graphics: NVIDIA® GeForce® GTX 670M with Optimus™ Technology 3GB GDDR5
      Memory: 12GB DDR3 1600MHz memory
      HDD: 1.0TB: 500GB (7200rpm, Serial ATA) + 500GB (7200rpm, Serial ATA)
      Optical: DVD-SuperMulti drive (+/-R double layer)
      Wifi: Intel® Wi-Fi® Wireless networking (802.11b/g/n + WiDi Capable)
      Bluetooth: Bluetooth® V4.0
      USB:4-USB (3.0) ports
      Any one help me PLEASE!
       
       
      UPDATE:
      So I was able to Boot and install ML using a boot CD which was from OSX86.net But I cant boot into the OS I have tried the following boot flags;
      -v -F -x maxmem=4084 busratio=18 npci=0x3000 PCIRootUID=0 and 1
      This is what I get

       
      Instead of getting Still waiting.... Error I get a Kernel Panic. But I myself cant figure this out.
      Any help would be awesome.
×