Jump to content

MyHack, I seriously screwed my REAL iMac (early 2008) 8,1 firmware/EFI


7 posts in this topic

Recommended Posts

DUMBEST thing I have ever done. I have built my own OSX86 box. I am smarter than this.



Accidently used MyHack to ruin my firmware/EFI on my 'authentic' real iMac (Early 2008), model 8,1



There is ZERO information on 'firmware restoration' on Apple.com support.


I CAN boot to the original Leopard system restore OSX installer. Have tried restoring from Time Machine.


Won't boot. Only white screen instead of the Apple logo.



HOW TO RESET? Anyone hosed a real Mac with MyHack installer accidently? I CANNOT be the first....



Thanks for ANY info! The local shop reccomends trying to install again via Target disk mode.... I need firmware restored, the problem is NOT on the hard drive... How to 'flash' the EFI firmware, now wrecked by Chameleon...?????


Rhett (rhettt@gmail.com)

Link to comment
Share on other sites

I dont think there is anything to do but reinstall your Mac. Chameleon states that you shouldnt install on real Macs, doesnt say exactly why but neither does it say how to recover. Hope you can, and please let me know. I know ONE OF THESE DAYs Im going to do that too...

Link to comment
Share on other sites

Oh believe me I have tried to reinstall...



1. Restore from Time Machine

2. Fresh install of 10.5 from factory 'hardware restore OSX installer"



Still won't boot from anything BUT that hardware restore disk....



Will try installing via Target Disk Mode tonight....

Link to comment
Share on other sites

myhack does nothing to firmware.


boot to the snow leopard disc using either 'c' or 'option' held down on the keyboard.


in one of the menus there'll be a 'startup disk', use it to boot to the installed OS on the hard drive, from within the installed OS re-bless the hard drive like normal.


sudo bless --folder=/Volumes/[yourhddname] --file=/Volumes/[yourhddname]/System/Library/boot.efi --setBoot


these GUI tools like myhack are idiotic, just FYI.

Link to comment
Share on other sites



i ended up having to re-install from factory OSX installer DVD.


crashed/froze at end of Disc 2 content. Hard Reset.


It installed Disc 2 content AGAIN, restarted successfully,




Time Machine restore after that and I am back 100%...


MyHack is a nice 'dummy proof' tool for OSX86, but WHY is the default install location "Macintosh HD"?


Why no, "Sorry, try choosing a USB drive instead. You could be ruining your Macintosh install." popup dialog?



I have learned from my mistake.



Link to comment
Share on other sites


  • Create New...