Jump to content

Need help in getting 4890 to work (OK Got it to recognize, but no QE)


DraggyGarg
 Share

8 posts in this topic

Recommended Posts

NVM Guys, I got it fully work!

 

Hello guys,

 

Here's my setup : EP45 UD3R, Snow Leopard (10.6.2), XFX Radeon HD4890(Running the default BIOS).

 

So far I have tried the exotic patchers by netkas and all I get is a garbled screen, I even tried placing a custom ROM but to no avail. All I really wish for is to run my resolution at 1680 x 1050(Which is my monitor's default res.), does anyone have any idea? When I try to force the resolution via com.apple.Boot.plist, it reverts to 1400 x 1050 for some odd reason.

Link to comment
Share on other sites

Hi there! is it possible to share your method? i cant get mine to work at 10.6.2

 

I second that request. I have an XFX 4890 from newegg, product model HD-489X-ZSFC, that I have not been able to get even the correct resolution working. Every time I try to boot, I get a garbled screen that is unreadable. The only way I can get it to boot is with safe mode. I would be very interested to hear your setup/method.

Link to comment
Share on other sites

I take no responsibility of what this might do

 

Make sure all your ATI drivers are in vanilla condition(Meaning they are same as when you installed them), do not delete any of them and make sure you don't have ATY_Init.kext, EVOenabler.kext or Natit.kext(Various enablers) before installation

 

Make sure you have updated to 10.6.2, now get the fol. packages(You can Google it, if you cannot find them, I'll attach them later)

1) framebuffers for 48x0 and 3870x2.pkg

2) 7_radeon_hd_48x0_drivers.pkg

3) QE_CI_Exotic patch 10.6.2.pkg

Install them in the given order(Do not reboot in any of the steps or after the install)

 

Now get LegacyHD4800Controller.kext(Can be found in netkas' Mac OS X 10.6.2 blog post) and place it in /Extra/Extensions. After that, download and run Kext utility(So that it will re-build extension's cache and setup permissions, just for safety measures). Then try a reboot, you can also try booting with -x32 flags(And if you get the restart notice, try the -v flag to know what exactly happened).

 

Also in /Library/Preferences/SystemConfiguration/com.apple.Boot.plist add

<key>GraphicsEnabler</key>

<string>y</string>

<key>PciRoot</key>

<string>1</string>

Under <dict></dict> tags.

 

I did the above to get it properly working, you may not require everything of the above to get it working or it may not work for you.

Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...