Jump to content

GMA 4500 driver for Snow Leopard


49 posts in this topic

Recommended Posts

After going through pages of posts on this topic previously, I decided to start this new topic for ONLY SNOW LEOPARD INSTALLATION ON GMA 4500MHD laptops. I know it is not possible for now to have kexts supporting gma4500 graphics ..... that too on Snow Leopard Installation. Some hacked gma3100 kexts available for OSX 10.5 systems but nothing for 10.6.


Fine, but atleast I want to have my native resolution of 1366*768*32. But I cant find any solution. There are many solutions for 10.5.x. I tried them all , like..


<plist version="1.0">





<key>Kernel Flags</key>

<string>"Graphics Mode"="1366x768x32"</string>


<key>Boot Graphics</key>


<key>Quiet Boot</key>












adding "Graphics Mode" key & "1366x768x32 string in the com.apple.boot.plist


all in vein.....the 10.5.x tricks not applicable as the plist located on extra , not in /library/preferences/system configuration. I also tried putting the modified plist there but no solution. Still Stretched out 1024x768.


I'm really frustrated. Isn't it possible to have native resolution in Snow Leopard having GMA4500???


Please Help...& please dont frustrate me with any 10.5.x methods. Kexts or mods that really work on Snow Leopard are needed




HP Compaq CQ60-209TU

IntelGMA 4500M


Windows Vista


Windows 7


Snow Leopard 10.6.1 ... tripple boot

Link to comment
Share on other sites

Not working for me. Anybody with some update please. Has anyone tried this installer? Anybody else get it working? Common post some solutions which will really work ....... or is it to be concluded that it can not be done??



you must boot in 32-bit mode in order to have native res...try boot flag arch=i386 at boot

Link to comment
Share on other sites

Weah...I was forget to tell u about the x86 mode but...u have to know that this it not a real driver...this is kind of temporarily version, to joy the native resolution. With no QE/CI your CPU will return to an oven after 30 minutes of running full screen movie for example!


I can`t figure this out. Over the 80% of the newest laptops from the middle class are with this f...ing graphic controller, and there ins`n ONE working driver for Mac or BSD based systems... This is RIDICULOUS !!!

Link to comment
Share on other sites

Simply, I can`t help U because I don`n know nothing about any kind of "CODE". I`m just a Graphical Designer.

And I`m not charging U guys for the missing of the driver. The fault is not yours... The question is WHO are the people writing the nVidia or ATI drivers and even the Intel....and where are they now, why the manifacturers makes only WIIIIIIIIINDOWS drivers... I hate this "MULTIPLATFORM" OS...like every one here :)

Link to comment
Share on other sites

Guys, please dont blame yourselves. You are doing a fabulous job. Without your help, it is not possible for me to run snow leopard on my hp compac. Imagine the price of a 17inch apple macbook running Snow Leopard & compare it with HP compaq cq60. Its a huge amount of money we are gaining isnt it? thanks to you I now have fully functional keyboard, HD sound, Ethernet, Wifi, even Webcam. With only 1/4th price to pay , I got near fully functional snow leopard .... & its only because of you guys. So, hats off to you.....


I have something to ask.As you surely understand that my laptop is a dual core ... so the question of 64bit doesn't arise. So I presume it always boot into 32bit? Stil the driver yo give not working but I will retry with a reinstallation as I experimented so much with different kexts lately ..... that may prevent it. I will late you know the result.


I have a VMware installed in my Windows 7 running MacOSX 10.5.7. Its got only native resolution & its more than usable for me. What i just expect to have a similar native resolution in snow also , thats all I want & nothing more ... & with masters like you around ... I know its only a matter of time. Surely I can expect fully functional QE/CI enabled Snow Leopard in my dual core laptop for just 1/4th price to spend.


So keep the good work ..... & keep trying.

Link to comment
Share on other sites

Did you try the ahhkolaa'dsdt.aml ? Before I installed it I got black screen too.

i did put the DSDT.aml on the root of the drive, but i'm not using chameleon, I'm using BOOTTHINK with is writen by Chinese, is there any way I can boot DSDT.aml without chameleon?

thanks for your replies!

Link to comment
Share on other sites

I used the bash script on my Acer 5735Z running OSX SL 10.6 (Installed from SnowOSX Universal) and i get native res (1366x768x32) on 64bit. Actually, everything works except QE/CI.


Edit: Im also using Chameleon 1.12 as for some reason Chameleon 2 killed my wifi (with DSDT.aml in root)

Link to comment
Share on other sites

Hi I am MrComputerWhiz. The one who made the package. And may I be any help to you?


Hi MeComputerWhiz,


Thank you for showing up and give us a help on GMA 4500 driver. my Laptop is Dell Vostro 1320, the native resolution should be 1280x800


Here is the 64 bit snow leo (10.6.2) showing in the system profile




Type: GPU

Bus: Built-In

VRAM (Total): 64 MB of Shared System Memory

Vendor: Intel (0x8086)

Device ID: 0x2a42

Revision ID: 0x0007

Kernel Extension Info: No Kext Loaded



Resolution: 1024 x 768

Pixel Depth: 32-Bit Color (ARGB8888)

Main Display: Yes

Mirror: Off

Online: Yes



Anything else you need to do the testing. Please let me know.





Link to comment
Share on other sites

  • 1 month later...

Hi all good day


thanks for opening the talk about intel gma 4500mhd kexts needed for all having it on their laptops under mac os x snow


leopard 10.6


my laptop: dell vostro 1015 intel c2d 2,2ghz 3g ddr2 800 sdram memory sata hard ahci gpt 250g intel gma 4500mhd


i hope from developers to help to find the needed kext thanks before all

Link to comment
Share on other sites

  • 2 weeks later...

so i get 1280x800 from gma4500 using chameleon with installing attached 3100 kexts and double-installing attached 3100 soft cursor disable kext and

writing to /extra/com.apple.boot.plist


<key>Kernel Flags</key>








and as i ovastand

in all the machines with osx systems steel there are two troubles with intel GMA4500

1)still we have not 64-bit system (

2)cannot watch movies on vlc player even on 32-bit mode of macosx


anybody knows the way to resolve?



Link to comment
Share on other sites

Hello I have Dell Vostro 1520, It came with Intel G45 video card, I used http://www.insanelymac.com/forum/index.php?showtopic=191746 this method to install SL,


I have searched everywhere and Spent 2 weeks on this, After Installing 4500 patch 2 , screen just goes black, I try to install Final Cut Pro it says , it needs 128min ram to install and my video card has 0MB


2 question


1) Will I be able to make it work with Patch ( i need 10.5.7 kext , i think to make it work)


2) even if it works Will I be able to use FCP with that setting


Hope to get some help It's first time posting on Insanely MAC



Link to comment
Share on other sites

2 question




so its bad news man but i have get the same message about my gma4500 on vostro 1320 when

i've try to start "main stage' -- already with 1280x800 - so i think it is realy hard to port

freebsd or linux driver coz nobody stil cannot - another gma4500 topics lasted at july-august.

now macos with gma4500 is steel just for music,

and not-moving pictures, not for video(

Link to comment
Share on other sites


  • Create New...