Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
nozz93

VIA VT1708S 5.1 in 10.6

Recommended Posts

Hey everyone, I installed Snow Leopard Retail a while ago and everything is working fine. Except my sound... fassl helped me to get all five outputs to appear in Snow Leo with VoodooHDA and all outputs work correctly in the Audio-MIDI-Setup. I configured the outputs as 5.1 surround device and sound comes out of the right speakers. Now the problems start: When I listen to music (or something else using stereo sound), the sound comes out of the rear speakers. It won't come out of the front speakers, doesn't matter whether I switch the outputs in the Audio-MIDI-Setup, the sound keeps coming out of the rear speakers (black connector). Temporary, I put my green speaker connector into the black connector at the sound card and the black at the green one. Is there a way to switch the outputs without switching the cables?

Second problem: I have no volume control with the configured 5.1 device. I can regulate the volume from every single output but not with the outputs combined to one device.

Does anyone have a solution for my problems?

 

Edit: Wow, forgot my VoodooHDA.kext! Should've attached it. It has a modded Info.plist. Also attached my codec dump.

nozz.txt

VoodooHDA.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

i could cry! trust me! you solved my problem!!! i had only 2 channel out and now i have 6!!! :(:P

for your problem try using winamp with setted codecs for surrounding... it worked for me under windows!

just a question... do you know how to modify voodoohda to obtain 8 channel? i have 7.1 :D

Share this post


Link to post
Share on other sites

ok i see winamp doenst work in osx

and i have the problem you have...

but...

i saw that in midi config it's impossible to change the predef device for SYSTEM out...

as you i have 3 x unknown devices (3 couples of out... 2 front 2 rear sub and center)

you can create a 5.1 adding the 3 devices

but you cant change the device unknown as the predef for system... you see the face of finder ?

i cant change that...

 

 

edit: maybe is it possible to edit kext so that it create just one devices with 6 out? it wold easier to configure andio...

Share this post


Link to post
Share on other sites

but this kext that u've published are modified for VIA VT1708S

 

or are normal vodoohda?

 

 

 

you've solve all your problems now?

Share this post


Link to post
Share on other sites

No, unfortunately not :/ What I uploaded was a modded plist version of VoodooHDA 0.2.1. I'm playing around with 0.2.5.2 at the moment. I'll upload it when it's fully working. The only things working now are line-out (green output) and line-in (mic). Don't know whether SPDIF is working, at least it's in the outputs list.

Share this post


Link to post
Share on other sites

have you try to modify dsdt?

 

 

i've try your kext but don't works.

is it important modify also info.plist? i've to get in nozz.txt?

Share this post


Link to post
Share on other sites
No, unfortunately not :/ What I uploaded was a modded plist version of VoodooHDA 0.2.1. I'm playing around with 0.2.5.2 at the moment. I'll upload it when it's fully working. The only things working now are line-out (green output) and line-in (mic). Don't know whether SPDIF is working, at least it's in the outputs list.

I've installed your modified VoodooHDA from the first post of the topic. My front line-out is working fine :) , but... my speakers are connected to rear outputs... and I have no sound in they :P ...

Share this post


Link to post
Share on other sites
No, unfortunately not :/ What I uploaded was a modded plist version of VoodooHDA 0.2.1. I'm playing around with 0.2.5.2 at the moment. I'll upload it when it's fully working. The only things working now are line-out (green output) and line-in (mic). Don't know whether SPDIF is working, at least it's in the outputs list.

 

Did you ever get sound fully working for VT1708S?

Share this post


Link to post
Share on other sites

I modified VoodooHDA 2.5.6 for 1708s.. I have LineOut(Green), headphone front, mic front, mic rear, lineout (black), and both spdif out working.. Can't seem to get LineIn, or the other two lineouts working though :/

 

VoodooHDA.kext.zip

Share this post


Link to post
Share on other sites

works almost perfectly. The front mic works but not the back. I have not tested the Subwoofer but the most important thing for me was getting the mic to work and now it does!

 

many thanks!

 

I modified VoodooHDA 2.5.6 for 1708s.. I have LineOut(Green), headphone front, mic front, mic rear, lineout (black), and both spdif out working.. Can't seem to get LineIn, or the other two lineouts working though :/

 

VoodooHDA.kext.zip

Share this post


Link to post
Share on other sites

Anyone can create a legacy.kext for VIA VT1708S because i have inserted the "device (HDEF)" in DSDT but it doesn't work because i have not PinsConfiguration, Layout-ID in the HDEF and i have not a legacy !

 

 

Please help me, i work to the sound since 2 weeks !

 

Visit this link : MacOnPC ; this my method with my dsdt and my Legacy(not working) !

Share this post


Link to post
Share on other sites
works almost perfectly. The front mic works but not the back. I have not tested the Subwoofer but the most important thing for me was getting the mic to work and now it does!

 

many thanks!

 

I have another updated version I'll upload later which has everything but rear microphone, and one rear LineOut. I can't seem to connect more than one PinComplex to a Input/Output so you ultimately have to choose between some pins.. Unless someone knows how to overcome this?

 

 

Anyone can create a legacy.kext for VIA VT1708S because i have inserted the "device (HDEF)" in DSDT but it doesn't work because i have not PinsConfiguration, Layout-ID in the HDEF and i have not a legacy !

 

 

Please help me, i work to the sound since 2 weeks !

 

Visit this link : MacOnPC ; this my method with my dsdt and my Legacy(not working) !

 

I've tried long and hard to get AppleHDA working, but without any luck.. I really don't think it's possible with this codec :D if you figure out how, let me know

 

VoodooHDA 0.2.61 edited for Via 1708s VoodooHDA.kext.zip - Original kext source

 

Working:

Rear LineOut (Green)

Front Headphone

Front Mic

Rear LineIn (Blue)

Rear LineOut (Black)

Rear LineOut (Orange)

and both SPDIF-Out

 

Not Working:

Rear Mic

Rear LineOut (Grey)

Share this post


Link to post
Share on other sites

Aie ! :( Thanks for you informations ! I want tested your kext ! Yes it work but i have this message :

 

Kext org.voodoo.driver.VoodooHDA - library kext com.apple.iokit.IOAudioFamily not found.
Can't load kext org.voodoo.driver.VoodooHDA - failed to resolve library dependencies.
Kext org.voodoo.driver.VoodooHDA failed to load (0xdc00800e).
Failed to load kext org.voodoo.driver.VoodooHDA (error 0xdc00800e).
Couldn't alloc class "VoodooHDADevice"

 

I have all the originals kexts !!! Do you want try for me to activate Mic rear and grey lineout please ??? I have all my

connections in work with audio system 5.1 !

Share this post


Link to post
Share on other sites
Kext org.voodoo.driver.VoodooHDA - library kext com.apple.iokit.IOAudioFamily not found.
Can't load kext org.voodoo.driver.VoodooHDA - failed to resolve library dependencies.
Kext org.voodoo.driver.VoodooHDA failed to load (0xdc00800e).
Failed to load kext org.voodoo.driver.VoodooHDA (error 0xdc00800e).
Couldn't alloc class "VoodooHDADevice"

 

 

You can ignore this message, or remove the following from info.plist

 

 

 

<key>OSBundleRequired</key>
<string>Local-Root</string>

 

 

 

And I'll upload another version of the kext later with grey output working, and rear mic. (Although, you will no longer have linein, or front headphone)

Share this post


Link to post
Share on other sites
You can ignore this message, or remove the following from info.plist

 

 

 

<key>OSBundleRequired</key>
<string>Local-Root</string>

 

 

 

And I'll upload another version of the kext later with grey output working, and rear mic. (Although, you will no longer have linein, or front headphone)

 

 

Thanks !!! I'll let you work on it, thank you for your advice ;)

Share this post


Link to post
Share on other sites

what about the volume problem with vt1708s that you can't lower the output volume? anybody found a solution on that?

Share this post


Link to post
Share on other sites
what about the volume problem with vt1708s that you can't lower the output volume? anybody found a solution on that?

 

 

not for me

Share this post


Link to post
Share on other sites

Why you can't works all channels... i have seen in the link (code source) :

 

Witch gives us max 9 devices in OS X

 

It's that ? No solution to have all channels ok ?

post-127387-1273692424_thumb.jpg

Share this post


Link to post
Share on other sites
what about the volume problem with vt1708s that you can't lower the output volume? anybody found a solution on that?

 

 

NOTHING for me.

Share this post


Link to post
Share on other sites
what about the volume problem with vt1708s that you can't lower the output volume? anybody found a solution on that?

Are you on AMD? If so this issue is not Audio / Audiocodec related - you need to CPUID patch SystemUIServer for Volume Control in menubar to work. ;)

Share this post


Link to post
Share on other sites
Are you on AMD? If so this issue is not Audio / Audiocodec related - you need to CPUID patch SystemUIServer for Volume Control in menubar to work. ;)

 

And how do you that? Do you need to use marvins amd utility?

Share this post


Link to post
Share on other sites

Hehe solved thanks to Leichenfresser who put me on the right track. My sound works with the menu slider and keyboard slider working. Steps Below.

 

Slow way (but definitely works):

 

1) Go here http://osx86.net/f7/volume-control-issue-t6092/ and do post #5

- This will get your menu slider moving (but volume doesnt change). Dont worry one step at a time.

 

2) Go here http://www.insanelymac.com/forum/index.php...83321&st=40 and install the voodoohda.kext from post #58

- Now your menu slider completely works and your volume is changeable

 

3) go here http://www.insanelymac.com/forum/index.php...83321&st=40 and do post #126

- This will fix your keyboard's volume controls among probably many other things as-well.

 

 

 

or,

 

 

 

Fast way (shoud work - somone please test it for me):

 

1. open marvins amd utility

2. enter password

3. select create patcher package

4. browse /system/library

5. run

6. goto the 'amd.patch.folder' on your desktop and copy 'patches' folder to the root of your HD

7. Edit patches/cpuid.txt and remove all lines regarding files stored in /System/Library/Extensions and lines regarding FrontRow.app (*thanks Leichenfresser*)

8. restart the computer and boot into single user mode by typing -s (tap tab twice when you see the bootloader/lizard). Enter the below commands

 

/sbin/mount -uw /

cd /patches/

./replace.sh

./patcher ./cpuid.txt

reboot

 

9. Install the attached modified voodoohda 2.61 kext which correctly links pcm to volume

10. Reboot again

 

Thats it, let me know if it works for you guys.

 

I dont know if the attached voodoohda kext has all the features from the previous posts but its the only one that allows volume adjustment. Feel free to modify the attached voodoohda further if need be.

VoodooHDA_261_HP_HDX18.kext.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×