Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Colin1497

Toshiba Portege R200 Install (working so far)

5 posts in this topic

Recommended Posts

Since I didn't find a direct reference, I thought I'd put something together for the next person who Googles it. I'm up and running so far with my R200. There are a couple different versions of this laptop, but most of the components are common. I believe the WiFi cards are a major difference, so YMMV.

 

I found a very good Dell 610 guide that got me up and running with the basics:

 

Please use your favorite torrent app and download iPC_OSx86_10_5_6_Universal_PPF5_Final -

 

Steps to Install - No Dual Boot - Pure OSX86 - INstructions have been tested multiple times. It works.

1. Boot to disk, select Language

2. Go to Tools --> Disk Utility

- Click on Drive listed on the left

- Click on Erase Tab

- Select Mac OS Extended (Journaled)

- Name your drive anything (ie. Macintosh HD)

- Click on Erase

- Close the Disk Utility

3. Press Continue

4. Select the drive you want for the install - Press Contnue

5. Click "Customize" in the lower left corner.

6. Select these options

7. Kernel - 9.5 VooDoo

8. Drivers

Video --> Intel --> GMA900 (if you have the ati card, select X3100)

Chipset --> LegacyAppleIntelPIIXATA

Audio --> Other Audio --> AC97

Wireless --> Don't choose anything for now, see below and we'll get it running after we install

Ethernet --> I haven't tried getting this up and running yet.

USB Drivers --> Select the two options listed

Power Management --> Select all options, 5 listed

Fixes and Patches -->

~ ACPI Fix

~ Time Machine Patch

~ IOPCIFamily.kext patched

~ Seatbelt.kext 10.5.5

~ USB Mount Fix

~ Optional - not tested - Shutdown Restart Fix

Applications - All of them except Marvin's AMD Utility

9. Press Done

10. Click on Install

11. Click on the Skip button for Disk Verification

12. Install takes about 10 minutes from this point.

13. Press F8 on first boot – type in "- f" for the first reboot.

 

At this point you are most of the way through.

This is what doesn't work:

  • TrackPad, Keyboard and Volume Buttons ( We are going to fix )
  • WiFi (we are going to fix)
  • Ethernet – I'll post when I get it going

You will need an external mouse and keyboard once booted in. The mouse and trackpad do not work at this point. You will need to download this package and open it with Pacifist. DO NOT Execute the pkg as it will render everything you have done up to this point usless.

 

KEYBOARD AND MOUSE Install

 

1. Download Package PS2Fix1054.

2. Right Click on the Package and Open With Pacifist

3. After 15 Seconds, Click on Not Yet (Support Charles if you use this App)

4. Expand contents of "Choice0"

5. Expand contents of "appleps2controller.pkg"

6. Right Click "ApplePS2Controller.kext" and select the option "Install to default location"

 

OK, at this point you're running except for networking. I next found a good post on the Atheros 5212.

 

I downloaded the Rar that is linked and installed the next Kext with the kext helper app that came with the distro and, bingo, I am up and running and installing apps. I just used a USB drive to x-fer files back and forth before I got WiFi running.

 

There still are a few issues with suspending and restarting, so I set it to not go to sleep, and I haven't got my ethernet going yet, but I'll update as I get more stuff ironed out...

 

The R200 was the lightest ultra portable in its day and was my travel laptop for a long time and you can find them around for pretty cheap. Better than a netbook if you grab one on eBay....

Share this post


Link to post
Share on other sites

So, after a little while running it, basically with my wife using it to browse the web, I've got the following issues identified:

 

1) I've had (I think) 2 kernel panics. Not the end of the world, I guess.

2) Power management isn't perfect. I have battery info but it doesn't like to wake up from sleep/hibernate properly. So far I'm just avoiding those modes. Also, I've noticed that occasionally the fan will just go to its highest speed. Not sure what's up with this one.

3) I can't choose to automatically log onto my wifi network or things hang up

4) I can't choose to rebooot, I have to shut down and do a fresh boot or it hangs during boot.

 

I'm probably missing some other issues that I haven't yet discovered, but that's where I am so far.

Share this post


Link to post
Share on other sites

I have also a R200.

 

Today I installed iPC 1.5.6 and got almost everything working now.

For the PS2 error, you can install the PS2 keyboard patch from the DVD install.

Atheros 5005 working with no problem, full functional

Sound working fine

Video, working fine, I think (QE working fine..)

 

Haven't installed the bluetooth yet

 

I have some problems with about this mac, as it crashes everytime I click on it, sending me to the Login Screen.

 

Sleeping is working fine, reboot also.

The battery meter isn't showing anything, even without the charger it says is conected to the charger.

 

Haven't go any further with the test, but is working.

If someone know how to fix those problems, would be great!

 

Regards

Share this post


Link to post
Share on other sites

I am having trouble booting this thing from a usb drive.

 

As you know, the Portege R200 doesn't have a cd drive and I am wondering, what is the absolute correct way to boot this installer from a USB drive? Did you use an external disk drive to boot from a DVD or did you work some magic to get it to boot from a removable drive?

Share this post


Link to post
Share on other sites

Despite my finest efforts to install OS X from a USB stick, I was unsuccessful.

 

I bought an external DVD drive to run the installation, and I can confirm, it works!

 

Some issues ocurred that made the installation weird:

  • I downloaded the Torrent you specified, but I couldn't find a Time machine patch when customizing the installation.
  • The computer blinks an underscore on the screen for about one to two minutes before actually booting from the cd.
  • The CD wouldn't boot (instead of booting, a text saying "'com.apple.Boot.Slist' not found" blinked on the screen) when I only waited when it asked to either press F8 or wait or press any key to boot from the cd. I got it to boot by customizing the boot by pressing F8 and writing "-v" (without commas).

I don't exactly know what I did by using -v but it worked.

 

This method works and if you do everything by the book, you will have a working Toshiba Portégé R200 Hackintosh laptop. Enjoy! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×