Jump to content

64-bit works fine, but 32-bit hangs?


5 posts in this topic

Recommended Posts

I've got SL installed on my ASUS P5K and it works almost perfectly in x86_64 mode, however I can't get it to boot at all with arch=i386. If I do a verbose boot, it hangs at line 'ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out', which I don't think is an issue. As far as I can tell, up to this point, the boot log is virtually identical to the x86_64 log.


I've tried removing a couple i386 only kexts I installed while getting it up and running, and moving the NVidia drivers out of the /S/L/E directory to no avail. Any other pointers? I'd really like to get my wireless and Envy24 working.


Also, and much less important, there's a weird issue with USB where sometimes either my keyboard or mouse (or neither) will not work at boot. The devices don't even light up as normal. A 'hard' reboot fixes this. Anyone seen it?

Link to comment
Share on other sites

I've got SL installed on my ASUS P5K and it works almost perfectly in x86_64 mode, however I can't get it to boot at all with arch=i386. If I do a verbose boot, it hangs at line 'ACPI_SMC_PlatformPlugin::start...


I have different hardware to you, but exactly the same problem, i.e. it works great with the 64-bit kernel, but hangs with the 32-bit. Mine even hangs at the same spot, which is right before the GUI loads. Although, as you said, I don't think this error message has much to do with it, I think it's whatever's happening *after* that. Perhaps something graphics card related?


Here's my hardware:


Mobo: Gigabyte GA-EP43-DS3

CPU: Q6600

Gfx: MSI 8600GT Dual DVI


Here's my kexts:








These are from the Extra.zip from the lifehacker article. Also in that archive is:






Does anyone know if any of those kexts are 64-bit-only? I am guessing there is one driver or configuration setting that isn't being applied or is conflicting with the 32-bit kernel, causing this hang.


Is it possible the DSDT might need to be changed to boot in 32-bit mode? I'm yet to decompile that and have a look, plan to try that next.


In the meantime it would be great to hear anyone's thoughts on what could possibly be causing this behavior (even if they're just wild guesses!)


More info:


I have tried booting with both:






arch=i386 -legacy


(and again, both of those with -v, with -v -x, and with -v -x -f.)


PS. One last thing I should mention. The above is all post-installation, booting my HDD from the USB key.


I have also tried booting the actual installer image in 32-bit mode. It dies at almost the same spot, except it gets 1 step further. It changes the graphics mode, screen goes blue, then it fades down to gray instead of fading down to reveal the wallpaper and GUI. I can move the mouse around, and about 5 seconds later it beach balls and stays that way for at least 20 minutes.

Link to comment
Share on other sites

I too had the same problem. Try installing the chameleon on the same partition as SL rather than on a separate partition.


This solved my problem


I actually did install Chameleon (plus all the Extras.zip contents, etc.) onto the HDD and got the same result.


Perhaps I need Chameleon RC3 though? I just saw this thread and I'm not sure if it's related (the OP edited the original post, so I'm not sure what his original complaint was) but sounds like it might be.


I was sure I downloaded RC3 but I do recall seeing RC2 displayed on the boot loader screen. Anyway thanks for your reply! I am not near my Hack at the moment, but will experiment with this tomorrow.


@error501, interested to know if you were booting from USB or from the same partition?

Link to comment
Share on other sites

I've got a dual-boot SL/Win7 setup. SL is on the first EFI partition, Win7 on the second, and a third for shared data. I installed Chameleon with the downloadable installer, not manually. I checked all the kexts I used and they all had 64 bit binaries in them so I don't think that's it. I also moved all the NV* drivers out of /S/L/E and they definitely weren't getting loaded in 64-bit (but I still got a GUI), and still the same issue.


I'll poke around with the Chameleon install.

Link to comment
Share on other sites


  • Create New...