Jump to content

GeForce 7050/nForce 620i problem


5 posts in this topic

Recommended Posts

Hey, i've been trying all day to atleast get to an install screen but it hasn't worked. So far i've tried JaS 10.4.8 and iDeneb 10.5.6 but neither worked. The JaS one kept restarting after Darwin and iDenebs one got stuck on "Still waiting for root device".


I use an Acer Aspire M1640 with a Hitachi 250gb IDE hard drive and the DVD drive that came with the Acer, i'm not sure what make, but it's SATA. The motherboard is an Acer MCP73, the northbridge is Geforce 7050 and southbridge is nForce 620i. I found a thread about how to install for nForce but it didn't say anything about 620i, just 610i and 630i.


I've tried to change to AHCI but my BIOS doesn't give me the option. When I change so RAID the DVD drive doesn't boot. I think I just have to accept that it's not gonna happen for me :)

Link to comment
Share on other sites

  • 1 month later...

Ok, i've managed to install iDeneb 1.4 but I had to use an IDE DVD drive to it.


I chose:

Voodoo Kernel with Seatbelt Fix




Firewire Fix


Afterwards I got the Using 10485 buffer... error so I removed AppleACPIPlatform.kext and AppleAPIC.kext and replaced them with kexts from JaS 10.4.8.


I then got the Still Waiting For Root device error. So I replaced AppleSMBIOS.kext and ACPI_SMC_PlatformPlugin.kext and it booted but only with cpus=1 -f.


Now I have problems, I want to use both cores but I read I need to flash my BIOS, trouble is the guy that does it doesn't seem to be around anymore. Also OSx can't see my SATA Hard drive or SATA DVD drive and i'm limited to 128GB on my IDE drives.


I've tried installing the nForce kexts but they don't work. I guess my only option is to try again but chose another ATA fix. Hopefully this will help someone with the same hardware.

Link to comment
Share on other sites

I got both cores working by installing Chameleon and a DSDT fix :)


Now I have problems using both a PS/2 keyboard and USB mouse. (it worked fine before I installed Chameleon) I'll try installing a kext for both and see where that gets me.


Does anyone know if my nforce chipset is supported at all? I really want to use my SATA dvd drive and hard drive. I also have to fix the 128GB limit somehow.


edit, Ok i've got PS/2 and USB working, I had to take off everything except the keyboard in the kext. Now all that's left is the SATA :(

Link to comment
Share on other sites

  • 3 months later...

Hello I have the exact same computer as you (with some modifications) and I tried and tried to get os x on it but I failed. If you are completely successful I will be VERY happy. :( The things I modded are:

vid card==>EVGA Nvidia GTS 250

ram==>2 2gb ddr2 Samsung

hd==> 500gb Seagate (I kept the 320gb Samsung it came with as well)

And I'm currently using a wireless mouse and keyboard, don't know if that matters.

Link to comment
Share on other sites

  • 5 months later...

Hi Bro, I'm in the same situation as you are.

I have the exact same model (Acer Aspire M1640).

I HAD To change my CDROM to an IDE Also.

Which I Did, I got stucked at the Buffer 10485 section. I have no idea what I did wrong lol.

My OSX86 is iDeneb 1.4, Should I go with 1.6 Lite ? If so please let me know, send me an email at S-Mallette@Live.com


Please help me, I might help with other things hehe

Link to comment
Share on other sites


  • Create New...