Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Problem with Wireless USB Network Adapter

1 post in this topic

Recommended Posts

I purchased this adapter: model F5D8053 from Belkin and can not get the thing to work reliably. I have experienced hours at night where it works just fine but other times cuts out after about 3 or 4 minutes. At times during the day it's fine while others it won't stay connected. There seems to be no rhyme or reason. I've removed and reinstalled several times now and nothing seems to be working. For $75 I expected a little more.


To make things stranger, it seems to cut out--as if overworked--when I have two or more browsers open (due to lag in one or the other). Can the browsers be causing an issue, or is it more likely that the adapter's connection cutting out is causing the browsers to freeze up? I don't know the tech side of them that well so I couldn't say.


Any suggestions? I'm using XP Essentials on a PC (but this shouldn't be any different than on a Mac, right?). If you need any more information, more than happy to give.





Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.