Jump to content

How do I change resolution and get my audio going?


11 posts in this topic

Recommended Posts

Hello all, I have a Winbook X530 and have been playing around with this OS for a few days.


I know nothing of OSX and how to get it to work, and I have hit a wall with a few problems.


Everything seems pretty solid, I've got access to my hard drive, itunes doesnt crash, etc, I am even using wifi through my Belkin USB G card.


Overall it's fast and pretty.


But, no matter what I try I cant figure out how to get my screen to adjust to 1280x800 and get my sound working.


I used a linux live cd to get some info on my hardware:


-The audio comes back as:


Intel Corp 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC '97 Audio Controller (Rev 03)


Numbers are: 8086:24c5 (rev 03)


-And my video information comes back as:


Intel Corp 82852/855GM Integrated Graphics Device (rev 02)


Numbers are: 8086:3582 (rev 02)


They're not too different from the Dell 700m that seem so widely used here.


Any information that would help direct me where or how to go about fixing these two things would be greatly appreciated.


Thanks all!

Link to comment
Share on other sites

Have you tried typing "Graphics Mode"="1280x1024x32" as a boot command? (With quotes).


If this works, you can edit a couple files to make it standard, but make sure this works first.


If it works all you need to do is add this string to your com.apple.... boot.plist so that you don't need to enter it on every boot :

<Key>Graphics Mode</Key>


Link to comment
Share on other sites

Well, he wanted a widescreen resolution, anyway.


Heaven forbid anyone does a search:



It even says 855gm chipset in the sticky thread.


Thanks to the both of you!


I actually did the search and didnt even see that sticky... like I said, I am as new to this as a baby is to breathing.


I'm very overwhelmed. I am sorry for the redundent post.


I'm going to try what has been posted and see what works.


Thanks again!


Also, now that it appears the resolution is fixable, any idea of why my sound doesnt work? It doesnt even show an audio system in the system information.


I know it works ok as all the linux boots I've tried find and use the audio right out of the gate.


Thanks again!

Link to comment
Share on other sites

Alright, I went through the tutorial linked but I am running into some real problems.


Basically, I dont have a AppleIntel830.kext in my extensions folder. I do have a AppleIntelIntegratedGraphics.kext but I cant save the modification as I dont have permission, obviously a root type of thing.


I guess I should mention I used the markler tiger DVD installer, with the modified patch thing. Could that be the problem? Could that also be why my sound doesnt work?


Ugh, I'm so lost here.

Link to comment
Share on other sites

"root" is basically the Unix term for administrator, "god" of the system that can do anything. Since you installed the Marklar image, you should have root priveleges since you're the system adminstrator. Go into System Preferences, and check out the User Accounts section to make sure you're signed in as administrator.

Link to comment
Share on other sites

Yep, it says I'm "Admin".


So all should be well, still I'm stuck with some big problems. I'm missing files.


For instance, I need "AppleAC97Audio.kext" to get my audio working but I cant locate it. It's not on my hard drive and I cant find it on the install image.


Any suggestions???


Thanks agian!!!

Link to comment
Share on other sites

  • 2 months later...

Video Fix - run native @ 1280x800

For 855GM Intel chipsets (Dell 700m has this for integrated video), you can modify the Info.plist of the to make it work properly


AppleIntel830.kext -> Info.plist

Remove the 0x35828086 from the 830 portion

Change the 0x25828086 to 0x35828086 in the 915 portion


AppleIntel915.kext -> Info.plist

Change the 0x25828086 to 0x35828086 in the 915 portion


AppleIntelIntegratedGraphics.kext -> Info.plist

Change the 0x25828086 to 0x35828086


IT works garunteed. if u want the kexts email me at nitantsoni(at)msn.com

Link to comment
Share on other sites

What if you have a non intergrated graphics card?? how do you change the res fra 1024x768 to 1280x800?? will it help if you have a driver for the card?? (Mobile Radeon 9000) Im stuk in 1024x768 and "Graphics Mode"="1280x1024x32" don't work.. my card is VESA 2.0 and the res is in the list when i type video?


Note that I have searched the forum but with no luck

Link to comment
Share on other sites


  • Create New...