Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
stv9

[SOLVED] Help Please: SigmaTel STAC 92XX C-Major HD Audio

5 posts in this topic

Recommended Posts

Hi,

 

The only distro I could get working on my Dell 1520 is Kalyway 10.5.1 with the ciqe-1440x900-pack.zip that fixes the blue screen and Grey restart screen. All the other distros of OSx86 gave me kernal panics especially osx86's with the Voodoo kernal.

 

I have read through alot of topics but none of the suggested solutions work.

 

I have tried all of the AppleHDApatchers with the frog icon in the other topics, I even made my own Audio Codec Dump in Linux but the Patchers do not get SigmaTel STAC 92XX working.

 

The AppleHDAPatcher says don't use on osx86 after 10.4 ...so is there a new Patcher out there or kext for SigmaTel STAC 92XX C-Major HD Audio?

 

I appreciate any help you can give me, thanks

 

 

******** UPDATE ********

 

I got my SigmaTel Audio 92xx working on my Dell 1520.

 

I don't know which post I found the solution in put here is what you need to get SigmaTel 92xx High Defiotion Audio working on a Dell 1520

Instructions.txt

AppleHDA.kext.rar

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Hi! Is it possible to get codec AD1981 running with AppleHDA on HP Compaq 8710w? It works nicely with VoodooHDA. Speakers and HP are switching automatically.  Internal and HP mic also work - no switching in SysPref but it works when mic is plugged in and internal mic works when hp mic is unplugged.   It has same weird pathmap - connected directly:  Playback: nid=5 [pin: Speaker (Analog)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001 nid=6 [pin: Headphones (Grey Left)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001   But inputs are really weird. There are 5 nodes from input to HP mic/Internal mic nid=4 [audio input] | + <- nid=21 [audio selector] [src: mix] bindSeq=00000003 | + <- nid=12 [audio mixer] [src: mix] bindSeq=00000003 | + <- nid=30 [audio selector] [src: mic] bindSeq=00000001 | + <- nid=8 [pin: Microphone (Grey Left)] [src: mic] bindSeq=00000001 + <- nid=31 [audio selector] [src: monitor] bindSeq=00000002 | + <- nid=24 [pin: Microphone (Analog)] [src: monitor] bindSeq=00000002 Can pathmap like that even work with AppleHDA? What codec should I patch? I tried patches from AD1984 but no luck.    These are manually patched verbs: 00571c10 00571d01 00571e17 00571f90 00570C02 00671c20 00671d10 00671e21 00671f03 00771cf0 00771d00 00771e00 00771f40 00871c30 00871d10 00871e81 00871f03 00971cf0 00971d00 00971e00 00971f40 00a71cf0 00a71d00 00a71e00 00a71f40 01671cf0 01671d00 01671e00 01671f40 01771cf0 01771d00 01771e00 01771f40 01871c40 01871d01 01871ea0 01871f90 01971cf0 01971d00 01971e00 01971f40   Codecgraph and linux codecdump attached. Thx for any help or suggestions.              codec.txt 2.svg codec.txt
    •   Yes, 'cause APFS log is coming before clover boot screen.
    • and you suspect apfs on before clover issues  
    • Can someone help me? I have an HP PRODESK 400 G4
      Corei5 7500
      4GB
      video card AMD R5 230 Caicos 6450 I can not put the video card to work on High Sierra. Can you tell me which kext to use? I discovered the id of my board through this link >>https://github.com/Clover-EFI-Bootloader/clover/blob/master/rEFIt_UEFI/Platform/ati.c
    •   I think you are very close to this.   But I have another unpleasant mention of past practice - the motherboard Gigabyte GA-X150 Plus WS. All reports showed an unlocked MSR, but without the KernelPM and AppelIntelCPUPM confidently caught KP.


×