Jump to content
Sign in to follow this  
Tony Danza

Execute .sh in GUI...without chmod +x

3 posts in this topic

Recommended Posts

So, I'll have to provide some background info so you know what's going on. I'm setting up a preconfigured .conf for Viscosity (OpenVPN). What my sh script does is copies all the pertinent files to the correct folders and runs sed to customize it for the particular user. Normally you'd just chmod +x it to make it executable..in this situation EVERYTHING needs to be rolled up into one click as this will be distributed to 'uninformed' users and needs to be foolproof.

 

I've tried "sh->app" rollers such as platypus and they suck and only run half of my script at best.

 

So experts, I Ask, how does one make a self-contained, executable .sh script that can be distributed and executed on multiple computers without ANY user intervention beyond "download this and double click it"

 

Thanks in advance,

 

Pat

Share this post


Link to post
Share on other sites
Advertisement

Have you ever found a solution for this? I am trying to solve the exact same issue...

 

I basically just want to be able to set a file to executable for everyone and have that permission apply on ANY machine. Is this possible???

Share this post


Link to post
Share on other sites

Can't you simply just make it a .app?

 

I've never tried a shell script in a .app without setting it executable, but you could always make it an applescript app. use Script Editor (or Applescript editor in 10.5) ... use the Applescript command "do shell script" and make it run the same shell script... save the final working part as an application, and it'll give you a .app anyone can click on and run.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×