Jump to content

Pro Tools 8 and MBox 1 dropout problem, error -9156.


6 posts in this topic

Recommended Posts

Recently, my hacmac has started having problems with Pro Tools 8 and my Mbox 1, in that it frequently cuts out with the error -9156. I'm unsure what exactly is causing the problem, but I don't have this issue with Pro Tools on windows (however I much prefer creative work within the Mac environment). I have all the the settings maxed out for buffersize.


My first assumption was a USB issue, but I'm not certain exactly. Anyone had a similar problem? Or any suggestions?


The problem occurs if the project is loaded from an internal harddrive or external usb drive. It just seems crazy to have these sorts of problems on a quad core system.


Here's a video of the issue at hand:



As a composer, this problem is extremely frustrating! I hope someone can help me!



Kalyway 10.5.5

C2Q Q6600 CPU

2GB Ram

Gigabyte GA-G33-DS3R Motherboard

Link to comment
Share on other sites

Alright I've got a bit closer to solving this strange issue.

Firstly, I can 100% confirm it is not a hardware issue, as my Mbox works perfectly when connected to an actual Mac.


After searching the forum, I came across this post. It seems that similar problems can occur with other USB soundcards, not just MBox's. The post was crucial because it suggested that accelerated video was the cause.


I then installed QuartzSimple, and enabled Quartz 2D Extreme. This completely fixes the problem to an extent... while playback works flawlessly, any attempts to scroll the window whilst the song is playing seem to require too much CPU and once again cause the error to occur.


I went a step further and trashed all the NV* kexts (I have an 8800GT 512MB). Upon reboot I was in software mode, but Pro Tools worked flawlessly, with scrolling and no dropouts. I then tried to install NVKush, but that didn't work. I then used EFI studio, which didn't work either, until I used the NVinstaller. But now some of the kexts have returned:








I believe that these, somehow, are the cause of the USB sound issue, as although I now again have acceleration, Pro Tools has exactly the same problem.


If anyone knows an alternative way to get 8800GT hardware acceleration without these kexts, please reply!

Link to comment
Share on other sites

  • 2 weeks later...

Oh, that is bad! I've got protool 7.4.2 running on ATI and Intel based video systems. I've just built a new hackintosh with a 8600GT. I'll try putting protools on it, see if I can recreate your problem. Can't do it now as it is rendering a video and will take a few hours.



Link to comment
Share on other sites

I ran PT 7.4.2 (MBox2) on a EP45-UD3R with a 8600 GT (512meg), install was 10.5.6 (IPC final) and 10.5.3 (Kalyway 10.5.2 and update). Both installs were using strings and stock video drivers. I used to use NVinject on 10.5.2 but it quit working. how odd.


Anyways the test results was the same error message, random times, reads as follows.


CPU usage is holding off USB audio. Remove some plug-ins, delete some tracks, or increase the"H/W Buffer Size" in the Playback Engine dialog. (-6104)


Playing with the buffers made no difference. Something else is wrong.


I then installed PT 7.4.2 (MBox2) on a Vostro 1720 (9600m GS, 512 meg ram), 10.5.6 (IPC Final) using NVdarwin and did an hours worth of Elastic Time and cut & paste with no problems.


You might want to try NVdarwin, see what happens.


You've got an 8800GT, one of the better stock Mac video cards. Have you tried osx86tools? It has a bunch of preconfigured strings. I find it works better to drag a copy of the "com.apple.boot.plist" from the Library/Preferences/SystemConfiguration to the desktop, open it up, get osx86tools to generate the string and copy and paste the string into the open boot.plist file, then drag the desktop (hacked) copy back to L/P/SC. Make a back up of the boot.plist file first.





Link to comment
Share on other sites

  • 3 weeks later...

Qjimbo, Did you find a solution? I did a retail 10.5.6 install on my EP45-UD3R with the 8600gt using strings last week. Just installed PT 7.4.2. It runs perfectly. I highly recommend retail installs. This computer is 15-20% faster than the iPC 10.5.6 install.



Link to comment
Share on other sites


  • Create New...