Jump to content

Very slow USB transfer speed.

3 posts in this topic

Recommended Posts

I am getting quite frustrated with this forum,nobody seems to answer any of my questions at all,I hope this does.

I know there were topics like this,but no one seems to have gotten a real solution to the problem.

I know what is going wrong,I just dont know how to fix it.

So my mobo has a SiS 964L chipset with dev id 7001 for USB1.0 controller and 7002 for USB2.0 controller.

The problem is that the transfer speed of my external usb HD is very slow,less than 1mb/s!

My system profile shows this for every USB device I plugged in,eg USB keyboard and mouse.


USB Bus:


Host Controller Location: Expansion Slot

Host Controller Driver: AppleUSBOHCI

PCI Device ID: 0x7001

PCI Revision ID: 0x000f

PCI Vendor ID: 0x1039

Bus Number: 0x43


By looking at that I know that my system is loading USB from the USB1.0 controller with OHCI driver which is slow.

I have the EHCI kext in my IOUSBFamily.kext but it never really loads,with the following error during boot:


USBF: 1.161 AppleUSBEHCI[0x30f5000]::UIMInitialize - could not get chip to come out of reset within 100 ms

USBF: 1.161 AppleUSBEHCI[0x30f5000]::UIMInitialize - Error occurred (0xe00002c9)

USBF: 1.270 AppleUSBEHCI[0x30f5000]::UIMFinalize - could not get chip to come out of reset within 100 ms

USBF: 1.271 AppleUSBEHCI: unable to initialize UIM


I've tried the PCGenUSBEHCI.kext from the EHCI thread,also all the kexts from Slice's thread,none of them work,sometimes all my USB devices wont even work at all.

I'm not sure if patching is needed in these kexts,since in the Info.plist I saw the dev id to be something like 0c031000 which does not match any of my USB controllers (70011039 and 70021039).

If someone is kind enough to help me solve the problem please do,I feel really hopeless and disappointed in this forum. :huh:

Link to comment
Share on other sites

  • 2 weeks later...

Slice's USB UHCI, EHCI and OHCI drivers should help if they were installed and loaded correctly. I suggest confirming you are indeed running those versions by checking the version of each in System Profiler or using kextstat.


I found that I had installed a kext called USBController and it has a directory called Content/Plugins and in that was anothe rset of IOUSBFamily.kext drivers which were being loaded instead of the ones in /System/Library/Extensons/IOUSBFamily.kext/Contents/Plugins.


It took days to figure out what was actually happening and I didn't notice till I worked through all the USB driver versions.



Link to comment
Share on other sites


  • Create New...