Jump to content

Geforce 8600 GTS not workin with EFI-Strings


4 posts in this topic

Recommended Posts

hey guys,


I'm trying to get my Geforce 8600GTS running with QE/CI. I tried every possible way i could think of but nothing has worked so far.

i tried normal install of nvinject (kernel panic caused NVDAResman.kext)

then I implented my device and vendor id into the kexts like described in the osx86 wiki (scroll down to geforce 8600gts) ... same as before but when i start up in safe boot mode both displays are workin with changeable resolution but only software core image und no QE.

in the end i tried using EFI Strings to get my graphs to work.. therefore i used osx86tools and implented the string but i only get core image (software), the resolution can not be changed and i haven got QE.


system specs are down below.

I hope someone is able to help me fix this because I tried every solution described in the forum but nothin worked for me.

Thanks in advance.

Link to comment
Share on other sites

core vidia hasnt worked for me.

i tried the installer but it crashed with message postinstallscript isn't able to complete.

so i extracted the kext for my card with pacifist and installed it using kexthelper.

but only got core image software support.

then i noticed nvdanvhal50 and nvdaresman kexts were missing so i reinstalled them using leographsupdate1.0

after that i only got kernel panic caused by nvdaresman and geforce.kext

so i deleted the injector and tried again with efi strings but with the same result. then i deleted nvdaresman in safeboot and got stuck at the beginning with efi strings and only core image software.


and i already read the posted thread before submitting mine...

Link to comment
Share on other sites

Sounds like a right mess.


For starters you need to make sure that the OpenGL framework + all required Nvidia/Geforce extensions are present and that they all come from the same version of Leopard or Apple Graphics Update.


Since you're still on 10.5.2 your options are limited - the later graphics updates require 10.5.5 or 10.5.6.


There's also a slight possibility that the CoreVidia injector itself doesn't work with 10.5.2.


Therefore your primary objective should be to upgrade to 10.5.5 or 10.5.6.


For starters you can google the Kalyway 10.5.3 upgrade pack - it comes with a kernel too. Don't forget to install the kernel as well before rebooting.


Or maybe it would be easier to just go straight to 10.5.6 - that will take a bit more research work on your part though.

Link to comment
Share on other sites


  • Create New...