Jump to content

Wireless Card Switch Error


2 posts in this topic

Recommended Posts



So I've been running Leopard successfully on my Toshiba Satellite A100-0FH for some time now, but only recently did I realize that my roommate's laptop has the perfect wifi card for my install [there are currently no Intel 3945 agb drivers out for OS X].


My A100-0FH Toshiba Satellite Laptop has an Intel 3945agb Wireless Mini-Pci card in it. My room mate's laptop is a Gateway MT6452 Notebook with an RTL8187 Wireless Mini-Pci card. My room mate's allowing me to simply switch the two wireless cards.


I've put the 3945agb card in the Gateway laptop, but when I try to boot - nothing happens.


The fan comes on, the Hard Drive indicator light comes on; looks like it's about to start up - then it restarts.

The screen doesn't even come on.

The entire cycle takes roughly 8 seconds...


I've gone into my bios and checked out the DMI Log. It shows the following error message:

"Pre-Boot Error: CMOS Configuration Error"


I've tried removing my battery and letting the laptop sit untouched overnight thinking the CMOS might reset some settings - no luck.


When I switch the RTL8187 back into the Gateway Laptop, it boots perfectly.



Any ideas?


Thanks :3

Link to comment
Share on other sites

I think it could be related to two things :

  • Card not installed properly
  • BIOS Whitelist

First of all , make sure you've installed the card correctly.


If it still doesn't boot your BIOS might have some kind of whitelist which doesn't allow installation of new hardware (the hardware which differs from original hardware). In this case, just use google to find out how to bypass whitelisting.

Link to comment
Share on other sites


  • Create New...