Jump to content

What about PCI-E based controllers ?


4 posts in this topic

Recommended Posts

hi everyone,

 

well, i have a PCI Express(x1) card that give me an external eSATA2 port for an external HD.

this card is a JMicron JMB360 (based on JMicron 20360/20363 chipset) and is not supported nativly on my PC running iPC OSx86 10.5.6 Universal FINAL :

 

at first boot, the HD is listed into the SATA section of my system properties, under the label "Unknow AHCI Standard Controller" but i had to install the "IOPCMCIAFamily" patch to see my card listed into the PCI section of the system properties ("IOPCIFamily" patch did not work for that), with the labels :

card:mass-storage

Type:AHCI Controller

Driver installed:Yes

Bus:PCI

Slot:PCI Slot@1,0,0

 

so i thought everything was ok, and i was WRONG ... :(

 

a lot of disfunctions, including very strange behaviour (for exemple, all the 200Go data of the eSATA disk lost once :( , while i was using Disk Utilities to format another USB linked HD ...) and very, very, very low transfert rates (seems like floppy age is back :) ) ...

 

i tried to install the OSx86 system using "LegacyJmicronATA" (and/or) "JmicronATA" drivers inclued in the chipset section of the OSx86 distribution but both 3 configurations failed, bringing up a system little bit slower (maybe conflicts with the "AppleNForceATA", the "TEST edition" by MeDevil i use for the motherboard ...), insted of bringing my eSata controller works better ...

 

i thought maybe the reason of this mess was that these Jmicron drivers are for motherboard chipsets and install did not copy them into the right place, so i searched a folder like "/System/Library/Extensions/IOPCMCIAFamily.kext/Contents/PlugIns/" to copy the ktexts into, and i did (without deleting anything in this folder) ... but that made no difference.

 

i found a Jmicron Mac OSX driver ( ;) sounds me curious for an internal PCI-E card ...) for this PCI card on JMicron's website ... i installed it "as it comes" on my OSx86 system but that did not make any changes, and i tried again to copy the ktext into "/System/Library/Extensions/IOPCMCIAFamily.kext/Contents/PlugIns/" and once again, no changes ...

 

can anyone help me ?

Link to comment
Share on other sites

From the looks of it you have the same card I have tried to get to work in my machine. With that driver from the Jmicron site you mention one of the drives in my e-sata box would show up on the ATA bus never tried to transfer any data to it though when I attached my DVD burner it would allow me to burn to it ripping a CD to FLAC freezes the machine almost instantly so it has the greater than ~4gb of ram bug. I did find this page below where buddy claims to have it working with the on-board 363 controller you may want to give the .kext a try to see if it works for you, didn't for me but who knows its worth a try anyways.

 

http://www.insanelymac.com/forum/index.php?showtopic=149308

Link to comment
Share on other sites

thanks a lot, i'll have a look just right now

 

edit : installed and it look better in the system properties, with the new label "JMicron JMB36x" ...

 

but i'll have to wait until a real test because my external disk is not empty, i have to backup it before, no more data loss ...

 

thanks for your help MacUser2525 !

Link to comment
Share on other sites

well, after backup my eSATA HD, i tried to use and test it ...

 

with the new ktexts (i didn't know what to do with the "ioreg.txt" file ...), no more conflicts, the system doesn't get little bit slower anymore while processing data using JMicron's controller, and better than all, no more data loss ...

 

but ... at first sight, i didn't notice any improvements about transfert rates, new drivers didn't help ...

 

what finally made the difference about transfert rates was to change my HD format ... everything get normal after changing from NTFS to FAT32 !

 

i don't know if it's quite normal because of the NTFS patch OSX computers runs to enable NTFS writing, and if the same problem exist when using nForceATA drivers (i didn't noticed it and now, i don't have anymore internal NTFS HD in my computer to test it ...) but the difference between writing on NTFS and FAT32 is very very big (from about 4 to 50Mo/s) ...

 

 

@ MacUser2525 : thx one more time

Link to comment
Share on other sites

 Share

×
×
  • Create New...