Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
psychotropic

ALC272 kext

8 posts in this topic

Recommended Posts

I wrote a kext. I still have no sound, but I do have internal speakers, line out, etc... listed in my sound properties and it made a popping noise once on start up. It might also have something to do with the EFI string I added to my com.Apple.boot.plist too.

 

The whole kext comes from an ALC262 where I did the necessary tweaking in replacing all DevIDs with ones listed for ALC272.

 

I suspect the problem lies in the AppleHDA file in /Contents/MacOS. I hex edited it to replace all device ids with the ones for ALC272.

 

I get the following errors on start up:

 

Mar 23 13:43:12 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 1168 goto Exit

Mar 23 13:43:12 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != pathSet->getWidgetAmplifierGainRange ( &zeroValue, &minValue, &maxValue, &minDB, &maxDB, kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 248 goto handler

Mar 23 13:43:12 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "false == pathSet->isAmplifierGainAdjustable ( kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3572 goto Exit

Mar 23 13:43:12 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3527 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 1168 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != pathSet->getWidgetAmplifierGainRange ( &zeroValue, &minValue, &maxValue, &minDB, &maxDB, kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 248 goto handler

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "false == pathSet->isAmplifierGainAdjustable ( kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3572 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3527 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 1168 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != pathSet->getWidgetAmplifierGainRange ( &zeroValue, &minValue, &maxValue, &minDB, &maxDB, kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 248 goto handler

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "false == pathSet->isAmplifierGainAdjustable ( kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3572 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3527 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != widget->setUnsolicited ( true )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDACodecGeneric.cpp" at line 830 goto handler

Mar 23 13:43:13: --- last message repeated 1 time ---

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAWidget.cpp" at line 2294 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != widget->setConnectionSelectNodeID ( fSelectionsForEachWidget[inputWidgetIndex] )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 694 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 == controlRange" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/DspFuncLib/Functions/DspFuncVolume.cpp" at line 512 goto Exit

 

I'm enclosing the kext, my linux dump, a pinconfig, some device info, and my com.Apple.boot.plist if anyone wants to tear it apart. I'm much too busy trying to get 10.5.6 installed on my newer Core i7 desktop to even want to mess with this.

 

I have a Toshiba Qosmio X305-Q701

AppleHDA.kext_2.zip

ALC272dev.zip

Share this post


Link to post
Share on other sites

AppleHDA_ALC_272.zip

I wrote a kext. I still have no sound, but I do have internal speakers, line out, etc... listed in my sound properties and it made a popping noise once on start up. It might also have something to do with the EFI string I added to my com.Apple.boot.plist too.

 

The whole kext comes from an ALC262 where I did the necessary tweaking in replacing all DevIDs with ones listed for ALC272.

 

I suspect the problem lies in the AppleHDA file in /Contents/MacOS. I hex edited it to replace all device ids with the ones for ALC272.

 

I get the following errors on start up:

 

Mar 23 13:43:12 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 1168 goto Exit

Mar 23 13:43:12 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != pathSet->getWidgetAmplifierGainRange ( &zeroValue, &minValue, &maxValue, &minDB, &maxDB, kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 248 goto handler

Mar 23 13:43:12 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "false == pathSet->isAmplifierGainAdjustable ( kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3572 goto Exit

Mar 23 13:43:12 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3527 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 1168 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != pathSet->getWidgetAmplifierGainRange ( &zeroValue, &minValue, &maxValue, &minDB, &maxDB, kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 248 goto handler

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "false == pathSet->isAmplifierGainAdjustable ( kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3572 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3527 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 1168 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != pathSet->getWidgetAmplifierGainRange ( &zeroValue, &minValue, &maxValue, &minDB, &maxDB, kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 248 goto handler

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "false == pathSet->isAmplifierGainAdjustable ( kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3572 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 3527 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != widget->setUnsolicited ( true )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDACodecGeneric.cpp" at line 830 goto handler

Mar 23 13:43:13: --- last message repeated 1 time ---

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAWidget.cpp" at line 2294 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 != widget->setConnectionSelectNodeID ( fSelectionsForEachWidget[inputWidgetIndex] )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 694 goto Exit

Mar 23 13:43:13 James-Bolins-Hackbook-Pro kernel[0]: Sound assertion "0 == controlRange" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/DspFuncLib/Functions/DspFuncVolume.cpp" at line 512 goto Exit

 

I'm enclosing the kext, my linux dump, a pinconfig, some device info, and my com.Apple.boot.plist if anyone wants to tear it apart. I'm much too busy trying to get 10.5.6 installed on my newer Core i7 desktop to even want to mess with this.

 

I have a Toshiba Qosmio X305-Q701

 

After weeks of searching I FINALLY found a working kext for ALC272. I take no credit for creating this but I will be happy to share it with everyone in need! Feel free to PM me if you have any questions and enjoy your working sound!AppleHDA_ALC_272.zip

Share this post


Link to post
Share on other sites
AppleHDA_ALC_272.zip

 

After weeks of searching I FINALLY found a working kext for ALC272. I take no credit for creating this but I will be happy to share it with everyone in need! Feel free to PM me if you have any questions and enjoy your working sound!AppleHDA_ALC_272.zip

 

 

Who do we owe the credit of creating this kext?

Share this post


Link to post
Share on other sites

Thanks for this. I now have sound output on my Dell Mini 10v, the only thing left now is the microphone. Has anyone had any luck with this?

Share this post


Link to post
Share on other sites
AppleHDA_ALC_272.zip

 

After weeks of searching I FINALLY found a working kext for ALC272. I take no credit for creating this but I will be happy to share it with everyone in need! Feel free to PM me if you have any questions and enjoy your working sound!AppleHDA_ALC_272.zip

 

THANKS!!!!

 

Now my sound is finally working and I'm plased to have one of the cheapest netbooks with mac!!!!!!

 

For al those who have this netbook: eMachines by Acer EM250 series i'm happy to say that I have it working at 99% at MAC OSX... the only thing I don't have is the wireless working, but you can buy one or use a USB dongle.

 

I ONLY used this simple guide: http://www.webmaster-mexico.com/macosx-105...pire-one-AOA150 (also in english, por cierto, muchísimas gracias para el paisano quien lo hizo) and add ikellys' ALC_272 installer for having the sound working.

 

eMachines by Acer EM250 series Rocks with dual boot!!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Nice @yapan4 then we can join forces to make this as good as possible.
    • I had a weird situation, after running great for a while: yesterday I did a reboot and got a KP. Turns out the AstekFusion2Adapter kexts were causing the KP, strange thing is I didn't recall applying any update or a like.  I had to boot with the USB installer, mount the EFI partition to delete the old AstekFusion2Adapter kexts and replaced with the patched version contributed by despeinao. I'm glad the system is working again, not having to reinstall OSX.
    • i think the "red light" you are referring to is that you have a optical SPDIF output (3.5 mm) combo jack. it most likely will be "red" when audio is active. 
    • Domanda , ma il tuo configplist lo ha settato cosi Gengik????
      Noto molte cose atipiche , tipo aperto con Clover configurator nella sezione ACPI il nome DSDT.aml NON è selezionato , quindi in teoria NON dovrebbe caricare il DSDT che hai in Clover ACPI Patch , se usi SSDT x la CPU NON dovrebbero servirti quelle personalizzazioni sempre in configplist sezione CPU ...
      Secondo me dovresti partire da un configplist pulito , xche sempre secondo me c'è rimasto delle schifezze di qualche tool x installare facile    EDIT
      Scaricando il configplist di jolly NOTO ha impostato +o- come intendevo fare io , sistemando quello  sopra elencato e bammmmm NON avvia , mi forniresti x favore Hack info che trovi nella mia firma ???
      Grazie   Ho creato un configplist , se vuoi provare , dovrebbe essere pulito da ogni impurità , se funziona dovrai adattarli tutte le tue personalizzazioni x il boot ..... config.plist.zip
    •   Can you share the Clover folder that lets you boot?


×