Jump to content

Effor on 915 + Conexant AMC (AC97 compatible)


13 posts in this topic

Recommended Posts

Firstly, thanks for all the help from this forum. I finally got the GMA900 work fine. Now I am working on sound. The laptop has a combination of 915+conexant. I think it is not widely used, since the user base on Conexant in this forum seems not very large. I have tired a lot, but still hasn't any improver.

 

Could anyone give me some help or direction on this? Any suggestion would be very thankful.

 

Below is related information and what I have done.

 

Hardware:

Laptop Benq S52: PM 1.6GHz, 915 motherboard, GMA 900 Graphic integrated, Conexant AMC 2 channel Audio, Realtek 8139, AC97 softV92 Data Fax Modem with SmartCP

 

Detail on Audio:

Driver: Conexant AMC 2-Channel Audio

product ID: 266e8086 (from Windows XP, dxdiag)

subsys ID: 058b17ff (from Sisoft Sandra)

Connect to: 24488086 (intel PCI bridge) & 266d8086 (I think it is the AC97 Modem, because the modem id is the same) These information are from control panel->system

 

More information about Conexant:

Conexant used to be Rockwell, a modem manufacture. It had a Conexant Riptide chipset before, which work audio & modem on one. So I imgine here it may work in the similar way, but just a guess.

I have tried Conexant CX20468-31 driver, it can't be installed, so I guess not this chipset.

 

First bootup on OS X 10.4.5 &10.4.3:

AppleAC97audio.kext are loaded. but so volume control, no sound.

 

What I have done:

I have tried to modify AppleAC97audio.kext, AppleHDA.kext, AppleAzaliaAudio.kext with 266e8086, 058b17ff, or 266d8086. But no improvement on all three, though they all kextload successfully.

AppleAC97audio.kext works even worse. It doen't load at startup. I have tried to restore the orignal file, but still not load at startup.

 

IOHDAFamily and IOHDAudioFamily both satisfied.

 

It seems sound not as easy to handle as Graphic. :blink:

 

Really need help... :idea:

Link to comment
Share on other sites

:D OK... Seems no one can deal with it so far.

 

Anyway, Now I have made AppleAC97Audio loaded at startup. It seems need to delete both HDA and Azalia.

 

However, the sound it still not working.

 

AppleAC97Audio: Satisfied

AppleAC97intelICH: Incomplete

Dependency Erro: com.apple.XXXX.AppleAC97Audio: No Valid version of this Depedency

 

Some kinda this error showed OS X

 

Any Suggestion??? :P

Link to comment
Share on other sites

Get Some more info from SourceForge

 

266d 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller

******1025 006a Conexant AC'97 CoDec (in Acer TravelMate 2410 serie laptop)

******103c 099c nx6110/nc6120

 

266e 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller

******1025 006a Realtek ALC 655 codec (in Acer TravelMate 2410 serie laptop)

******1028 0179 Optiplex GX280

******1028 0182 Latitude D610 Laptop

******1028 0188 Inspiron 6000 laptop

******103c 099c nx6110/nc6120

******1458 a002 GA-8I915ME-G Mainboard

******1734 105a Scenic W620

Link to comment
Share on other sites

Information Update

 

Withe Everest in XP, now I am sure that the Audio Codec is Conexant CX20468 @ ICH6

 

Product ID: 266e8086

Subsystem ID: 058b17ff (17ff is the manufacturer of this laptop, Benq)

 

Then I search on the internet, and found something can be Codec ID

 

0x43585429(HEX)-->1129862185(DEC)-->CXT29(ASCII)

0x43585430(HEX)-->1129862192(DEC)-->CXT30(ASCII)

 

These look similar to ADSxx or decimal number in AppleHDA, don't they?

 

So I have tried to use these information to modified related Kext. disappointly, no improvement, but in prediction as well.

 

Can anyone give me a hand on this? PLEASE

Link to comment
Share on other sites

Glad to hear that. I have got the nessary data sheet, and can start the work at anytime. But problem is I will have 2 6000-word report to hand in next week. So the plan will be surely delayed.

 

Anyway, I will update when I have time to do it.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 year later...
  • 8 months later...

After couple week of searching, reading and debugging, I got my laptop Dell D410 almost 100% working (for my situation) except modem and wake up.

I installed Kalyway Leo 10.5.2 with the 2 wire trick of video port (common problem with intel 900 graphic chip set).

Video, USB, ATA, ps2 track pad, ethernet, and wireless are working natural with installation. But better after run application EXTENSIONS-REPAIR.

For audio (pci8086,266e), i used file AppleAC97Audio.kext from MACGIRL

http://forum.insanelymac.com/index.php?s=&...ost&p=29717

You are going to have some error statement pop up after paste to Extensions folder, use Extensions-repair to correct the error.

 

Hope this help.

Link to comment
Share on other sites

  • 3 months later...
 Share

×
×
  • Create New...