Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
johnlocke2342

"Still waiting for root device" after installing iPC

12 posts in this topic

Recommended Posts

Hi.

For the past months, I've been trying to install OS X Leopard on my PC desktop. I downloaded IATKOS, iDeneb, Leo4all, and finally Kalyway 10.5.2. This last one is the only one on which the installation process started, but it doesn't recognize my HD.

Yesterday, I downloaded iPC 10.5.6 and I just finished installing it on my PC, but it doesn't boot at all: I have a "Still waiting for root device" error. I've been looking in the wiki and I searched the forums with no result.

 

Here are my specs:

AMD Athlon X2 Processor

2 GB RAM

nVidia GeForce 9400 GT

200 GB SATA Hard Drive (Windows 7 Beta is installed on it and is working well)

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Try to set SATA mode to IDE or something else, NOT AHCI. This may cause this problem. Try to name your HDD partition for MAC OS X in just one word like: MACOS not MAC OS. Or it could be your motherboard incompatibility...

Share this post


Link to post
Share on other sites

SATA is already set to IDE, and I don't see an AHCI option. I'll try to rename the partition, but how? I have a PS/2 keyboard and an USB mouse so I can't rename it within the installer.

Share this post


Link to post
Share on other sites

"Still waiting for root device" :(

It looks like I also have a firewire error just before :

"Firewire unable to determine security-mode: defaulting to full secure"

Share this post


Link to post
Share on other sites

Hello,

 

i have the same error. Have tried several images, only the iPC Final 10.5.6 worked yesterday on my machine.

 

Asus P5N-E SLI Chipsatz: nVidia 650i + Realtek Soundkarte and Creativ X-Fi

Intel Core 2 Duo E8400 @ 3GHZ

GeForce 9800 GT 512MB

2GB Ram

IDE0 Master HDD

IDE1 Master DVD Player

 

Installation was okay... Have formatted the HD with Disk Utility and using GUID as Bootloader. At the Custom Settings i used the default Kernel (Vanilla) have only installed a few driver. And now, if i want to boot the installed Mac OS X my pc says: Still waiting for root device.

BUT WHY?!??!!? :)

jMicron COntroler is Enabled and FireWire, too.

Have s.o. an idea?

Share this post


Link to post
Share on other sites

Finally I have a soloution for this board!

 

My Installation looks like:

You need an IDE HDD at IDE0 Master. An IDE DVD Drive at IDE1 Master. An USB Keyboard + USB Mouse. iPC 10.5.6 Final release.

 

At first BIOS Settings:

-> Advanced -> Onboard Device Configuration:

HD Audio Enabled

nVidia LAN Enabled

Rest Disabled

 

-> Advanced -> Onboard Device Configuration->IDE Functions Setup:

SATA Controller 1, 2 Disabled

SATA Port 3, 4 Disabled

Rest Enabled

 

Insert the DVD and press F8 at the prompt and boot with the flag -v.

Make a partition with Diskultility using the GUID record.

 

Customize your installation:

 

NVKush

AppleNForce ATA

Dual Boot Time Sync

Apple SMIOS-27 Rev 3 Mac Pro

Chameleon with DSDT Custom Boot Picture

All Applications except AMD

 

After the installation you have to install the LAN driver http://www.insanelymac.com/forum/index.php?showtopic=125569 and the Audio driver ALC883 (Use the search funnction).

 

Have Fun!

 

P.S.: After the installation you can enable the SATA Controller and use the SATA Hardware under Mac OS X

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×