Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Guest

[GUIDA] QE/CI CON ATI 2400PRO 2400XT 2600PRO 2600XT

77 posts in this topic

Recommended Posts

Guest

Trovati i metodi per attivare QE/CI sulle ATI HD 2400 e 2600 PRO e XT su Leopard 10.5.5.

 

Importante: quando installate la vostra versione 10.5.5 non selezionate alcun driver video per il corretto funzionamento dei 2 metodi.

 

 

Metodo1) Ringrazio Demone per questo metodo

 

Il metodo funziona anche con HD 2600PRO e HD 2600XT sositutendo al punto 7 gli id descritti con quelli di tali schede.

 

1) Installare i driver più recenti da http://nvinstaller.com/ (9f23) compreso l'EFISTUDIO compreso nel pacchetto;

 

2) Aprire EFISTUDIO e clickare sull'icona "Device Path" scrivere "display" nel primo text box, premere il bottone "Get Path" poi premere il bottone "To Clipboard" e chiudere la finestra;

 

3) Da EFISTUDIO selezionare ATI Radeon HD2400 - 256MB (la prima voce in Display) e premere "Add Device"; si aprirà la finestra dell'editor;

 

4) Nell'editor sostituire il valore in dict/plist/key (di default PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0) ) con quello che avete copiato negli appunti precedentemente (se coincidono, saltate questo passo);

 

5) Nell'editor sostituite ogni stringa "Iago" con la stringa "Megalodon" (potreste incontrare anche "Lamna" come framebuffer, se l'avete sostituite anche questa stringa con "Megalodon"); anche "IagoParent" diventerà "MegalodonParent" ovviamente;

 

6) Fatto questo clickate "write to com.apple.Boot.plist" per inserire la EFI string nel sistema e chiudete EFISTUDIO;

 

7) Inserite l'id della vostra scheda (0x94c31002 per HD 2400Pro e 0x94c11002 per HD 2400XT) in ATIRadeonX2000.kext;

 

8) Riparate i permessi con Disk Utility;

 

9) Cancellate da /System/Library Extensions.mkext;

 

10) Riavviate con -v -f avrete QE/CI abilitati.

 

 

Metodo 2) Ringrazio el-rocje per questo metodo

 

Dovrebbe funzionare solo con HD 2400PRO e HD 2400XT Mi è arrivato un feedback di utente dal forum internazionale che con questo metodo è riuscito con HD 2600Pro 256. Quindi provate anche con le 2600 (pro e xt) poi lasciate le vostre esperienze, grazie.

 

Occorrono:

1. Questi kexts: http://tinyurl.com/3qcg8g

2. Kexthelper

3. Plist editor o textedit

 

Primo) Installate i kexts del package, riavviate ed avrete il cambio di risoluzione, ma senza QE/CI.

Secondo) Andate in /System/Library/Extentions e trovate ATIRadeonX2000.kext

Terzo) Non modificate direttamente questo file, spostatelo sul Desktop, trovate "Info.plist" ed apritelo con plist editor o textedit. Trovate la stringa con string "IOPCIMatch", mettete il vostro id (0x94c31002 per 2400 pro e 0x94c11002 per 2400XT) e salvate. L'id della vostra scheda può essere aggiunto indifferentemente all'inizio, alla fine o sostituire uno dei valori presenti nella stringa.

Quarto) Installate questo kext con Kexthelper. Riavviate: ecco QE/CI

Share this post


Link to post
Share on other sites

Scusatemi...io ho provato a seguire l'istallazione col secondo metodo qui descritto...ma il quartz extreme dice sempre non supportato...io ho una ati hd 2400 pro...ma per caso dipende dal monitor?? insomma io ho installato tramite cavo vga...

Share this post


Link to post
Share on other sites
Guest
Scusatemi...io ho provato a seguire l'istallazione col secondo metodo qui descritto...ma il quartz extreme dice sempre non supportato...io ho una ati hd 2400 pro...ma per caso dipende dal monitor?? insomma io ho installato tramite cavo vga...

No non dipende dal monitor.

 

Quando torno a casa ti posto ATIRadeonX2000.kext (il mio) e provi con quello.

 

Ciao, Giorgio

 

 

 

(ovviamente hai 10.5.5 perchè con 10.5.4 in giù non va)

Share this post


Link to post
Share on other sites
Guest
si ideneb v1.3 10.5.5. ti ringrazio veramente tanto...cioè...lo scarico da qui? scusa ma sai son nuovo...ehehee...grazie tantissime...

Si, tra qualche ora te lo posto in questo topic con le istruzioni per installarlo (lo scarichi da qui).

Ciao, Giorgio

Share this post


Link to post
Share on other sites

Troppo gentile davvero...ok...anche perchè funziona tutto...ma tranne questo quartz...quindi giochi non ne apre...applicazioni tipo toast, non istalla...alcune funzioni grafiche nada...ehehehe...ancora un mega grazie!!

Share this post


Link to post
Share on other sites
Guest
Troppo gentile davvero...ok...anche perchè funziona tutto...ma tranne questo quartz...quindi giochi non ne apre...applicazioni tipo toast, non istalla...alcune funzioni grafiche nada...ehehehe...ancora un mega grazie!!

Natit.kext.zip

ATIRadeonX2000.kext.zip

 

Scarica i 2 kext, mettili sulla scrivania, cancella quelli uguali che hai in /System/Library/Extensions e installa i due che hai caricato con Kexthelper.

 

Riavvia con -v -f e dovresti avere QE/CI.

 

Ciao, Giorgio.

Share this post


Link to post
Share on other sites

Giorgio ti ringrazio tanto...solo..cosa intendi con riavvia -v -f ? cioè devo reinserire il dvd di ideneb e fare il riavvio da li?

 

Giorgio...perfetto!!!! funziona alla grandissima...non ci sono grazie...a buon rendere...mitico....

Share this post


Link to post
Share on other sites

ciao volevo sapere io ho una ati radeon hd 2600 xt come faccio a sapere l'id e poi se la installo verrebbe riconosciuta come ati hd 2400 ?

 

scusa l'id che vedi in firma l'ho copiato in gestione preferenze però con lo sleep quella di priima non va

Share this post


Link to post
Share on other sites
Guest
ciao volevo sapere io ho una ati radeon hd 2600 xt come faccio a sapere l'id e poi se la installo verrebbe riconosciuta come ati hd 2400 ?

 

scusa l'id che vedi in firma l'ho copiato in gestione preferenze però con lo sleep quella di priima non va

Lid della tua scheda è 0x95881002

 

Per usare questo metodo devi avere una 10.5.5 e non aver installato nessuna altro driver ed injector.

Ciao, Giorgio.

 

Giorgio ti ringrazio tanto...solo..cosa intendi con riavvia -v -f ? cioè devo reinserire il dvd di ideneb e fare il riavvio da li?

 

Giorgio...perfetto!!!! funziona alla grandissima...non ci sono grazie...a buon rendere...mitico....

 

Perfetto, sono contento di esserti stato utile.

 

Adesso però resta tra noi e non sparire come fanno tutti appena risolto il problema.

 

Ciao, Giorgio

Share this post


Link to post
Share on other sites

tranquillo giorgio...leggo i post...e se un po della mia esperienza sarà utile pian piano la metterò in atto felicemente...in fondo aiutate...e non vedo il perchè non contraccambiare...solo sono un utente reduce da win...appena approdato nel meraviglioso mondo mac...insomma...datemi tempo, datemi tempo...ehehehe..un ciao!!

Share this post


Link to post
Share on other sites
Guest
Scusate la domanda da novizio..

ma gli id della mia HD2600PRO dove li trovo? :unsure:

Informazioni su questo mac/più informazioni/grafica monitor

 

 

Comunque il forum è stracolmo di topic dove si parla e si spiegano gli id delle periferiche.

 

A mio avviso, prima di provare una pratica complessa come questa, avendo di questi dubbi elementari, è meglio studiacchiare prima.

 

Ciao, Giorgio

Share this post


Link to post
Share on other sites
Informazioni su questo mac/più informazioni/grafica monitor

Comunque il forum è stracolmo di topic dove si parla e si spiegano gli id delle periferiche.

 

A mio avviso, prima di provare una pratica complessa come questa, avendo di questi dubbi elementari, è meglio studiacchiare prima.

 

Ciao, Giorgio

 

Io posso anche studicchiare..ma credo che le cose vadano pian piano assodate proprio con la pratica. Del resto questo problema mi preme molto poichè la risoluzione del video è pessima e mi crea problemi alla vista.

Quindi spero di risolvere questo problema e di riuscire ad imparare ad usare questo nuovo sistema operativo.

 

Credo che anche per te, all'inizio sia stato duro :unsure:

 

Ps.

Se magari hai da consigliarmi qualcosa da guardare per imprarare te ne soto grato :D

OT chiuso.

Share this post


Link to post
Share on other sites
Guest
Io posso anche studicchiare..ma credo che le cose vadano pian piano assodate proprio con la pratica. Del resto questo problema mi preme molto poichè la risoluzione del video è pessima e mi crea problemi alla vista.

Quindi spero di risolvere questo problema e di riuscire ad imparare ad usare questo nuovo sistema operativo.

 

Credo che anche per te, all'inizio sia stato duro :censored2:

 

Ps.

Se magari hai da consigliarmi qualcosa da guardare per imprarare te ne soto grato :D

OT chiuso.

 

Non volevo offenderti, per l'amor del cielo.

Basta leggere sul forum sia nazionale che internazionale (non esistono testi, il testo è il web), questo è un metodo complesso, che crea difficoltà anche a me, per cui bisogna avere un minimo di dimestichezza con aprire i kext, editare gli info.plist, inserire id, riparare permessi, estrarre ed installare kext; cose semplici ma che richiedono un minimo di pratica; lo dicevo per non farti riformattare molte volte (comunque se lo vuoi provare inizia e chiedi pure). Io ho riformattato tante volte la prima volta (comunque si impara anche sbagliando)

 

Per pura informazione, prima di installare il mio primo Hackintosh, pur avendo oltre 10 anni di esperienza in Unix ho letto quasi tutti i Topic per 3 mesi prima di provare ad installare.

 

Ciao, Giorgio

Share this post


Link to post
Share on other sites
Non volevo offenderti, per l'amor del cielo.

Basta leggere sul forum sia nazionale che internazionale (non esistono testi, il testo è il web), questo è un metodo complesso, che crea difficoltà anche a me, per cui bisogna avere un minimo di dimestichezza con aprire i kext, editare gli info.plist, inserire id, riparare permessi, estrarre ed installare kext; cose semplici ma che richiedono un minimo di pratica; lo dicevo per non farti riformattare molte volte (comunque se lo vuoi provare inizia e chiedi pure). Io ho riformattato tante volte la prima volta (comunque si impara anche sbagliando)

 

Per pura informazione, prima di installare il mio primo Hackintosh, pur avendo oltre 10 anni di esperienza in Unix ho letto quasi tutti i Topic per 3 mesi prima di provare ad installare.

 

Ciao, Giorgio

Tranquillo, non mi sono offeso ;)

Ritornando alla guida..ho provato a seguire la procedura e bene o male riesco a eseguire i primi punti ma mi fermo al 4:

"Nell'editor sostituire il valore in dict/plist/key (di default PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0) ) con quello che avete copiato negli appunti precedentemente (se coincidono, saltate questo passo);!

 

Allora io procedo così:

installo il pacchetto..faccio il punto due ..arrivo al tre..ma una volta che mi si apre l'editor..non riesco a capire cosa devo fare..cosa devo sostiuire ;)

 

:D

 

Ps.

Quando installo il package..mi da sempre installazione non riuscita. Perchè?

 

Grazie.

Share this post


Link to post
Share on other sites
Guest
Tranquillo, non mi sono offeso ;)

Ritornando alla guida..ho provato a seguire la procedura e bene o male riesco a eseguire i primi punti ma mi fermo al 4:

"Nell'editor sostituire il valore in dict/plist/key (di default PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0) ) con quello che avete copiato negli appunti precedentemente (se coincidono, saltate questo passo);!

 

Allora io procedo così:

installo il pacchetto..faccio il punto due ..arrivo al tre..ma una volta che mi si apre l'editor..non riesco a capire cosa devo fare..cosa devo sostiuire ;)

 

:D

 

Ps.

Quando installo il package..mi da sempre installazione non riuscita. Perchè?

 

Grazie.

 

1) per quanto riguarda il pacchetto c'è una corruzione sul server in questi giorni. Installa solo i driver e non Efistudio, lo estrai con pacifist e poi lo lanci.

Se ti viene il messaggio di errore non ha installato neppure i kexts per cui rifai l'installazione di 9f23.

 

2) Quando si apre l'editor devi sostituire nella parte in alto quello che hai copiato negli appunti se non coincide (98 volte su 100 coincide).

Share this post


Link to post
Share on other sites

giorgio, vorrei intromettermi per dire una cosa, che io quando provo ad installare 9f23 mi da' pure lo stesso errore e nn ora me lo ha sempre dato, lo scaricato più di una volta, ma nn avendone di bisogno, nn mi sono creato grossi problemi...

poi sinceramente nn ho mai capito l'utilità di questo pacchetto, dovrebbe contenere i kext per le schede video per la 10.5.5, ma se uno ha la 10.5.5, nn sono già presenti??? nn è una polemica e che nn lo veramente capito :D....

 

ciao, clipt

Share this post


Link to post
Share on other sites
Guest
giorgio, vorrei intromettermi per dire una cosa, che io quando provo ad installare 9f23 mi da' pure lo stesso errore e nn ora me lo ha sempre dato, lo scaricato più di una volta, ma nn avendone di bisogno, nn mi sono creato grossi problemi...

poi sinceramente nn ho mai capito l'utilità di questo pacchetto, dovrebbe contenere i kext per le schede video per la 10.5.5, ma se uno ha la 10.5.5, nn sono già presenti??? nn è una polemica e che nn lo veramente capito ;)....

 

ciao, clipt

Ciao clipt; 9f23 da l'errore da quando hanno introdotto Efistudio nel pacchetto. E' sufficiente non selezionare Efistudio ed installare solo i kexts. poi Efistudio lo estrai con Pacifist. Ieri sera ad esempio ho scaricato, installato tutto ed è andatao liscio: passato il file su un altro PC ha dato l'errore (qui non riesco a pensare una spiegazione, stranezze dell'informatica).

 

In realtà i kexts di 9f23 sono praticamente identici a quelli dell'aggiornamento Apple, tranne che per le ATI, dove hanno fissato nell'info.plist un problema per Radeon. Inoltre è allegato un OpenGL.Framework che consente di avere QE/CI con le 2400 e 2600 sfruttando il framebuffer Megalodon (abbandonato dall'avvento di Leopard) al posto di Iago (sino alla 10.5.4 si riuscivano ad attivare, con la 10.5.5 nulla da fare,. Demone, un utente, con i controc......i ha messo a punto questa possibilità).

 

Questo è quello che ho saputo e capito io. Ciao, Giorgio.

Share this post


Link to post
Share on other sites
Guest
Sono arrivato al punto 7..

il kext ATIRadeonX2000 che editor lo devo aprire per inserire l'id della mia scheda?

 

Grazie ;)

Sposti il kext sulla scrivania, click col tasto destro e scegli mostra contenuto del pacchetto. Clicca 2 volte col sinistro su Contents. Apri info.plist con textedit.

 

Quando hai modificato il kext, salva ed installalo con kexthelper (prima di installarlo con kexthelper, cancella quello in /System/Library/Extensions, se c'è rimasto).

 

In bocca al lupo.

 

Se non dovesse funzionare, mi hanno segnalato che anche il secondo metodo, più semplice, va con le 2600.

 

Ciao, Giorgio.

Share this post


Link to post
Share on other sites

Ho fatto tutta la procedura..adesso nella sezione monitor in preferenze di sistema ho anche varie risoluzioni ma non riesco a trovare quella più adatta al mio schermo.

Come faccio a vedere se l'ho installato correttamente?

 

In informazioni sul mio Mac mi dice che ho la ATI Radeon HD 2400 XT :D che non è la mia scheda :)

 

Grazie :)

 

Ps

Provo il secondo metodo

Share this post


Link to post
Share on other sites
Guest
Ho fatto tutta la procedura..adesso nella sezione monitor in preferenze di sistema ho anche varie risoluzioni ma non riesco a trovare quella più adatta al mio schermo.

Come faccio a vedere se l'ho installato correttamente?

 

In informazioni sul mio Mac mi dice che ho la ATI Radeon HD 2400 XT :D che non è la mia scheda :)

 

Grazie :)

 

Ps

Provo il secondo metodo

 

 

No, non provare il secondo metodo, va tutto bene!!!!!!!!!!!!!!!!. Il fatto che ti dica 2400XT è solo un fatto estetico, poi quando ho tempo te lo spiego. Guarda solo se hai Quartz Extreme attivato.

 

Non provare l'altro metodo, altrimenti combini un casino, bisogna prima cancellare delle cose, rischi di inchiodare il PC.

 

Poi non dire che non lo sapevi.

Share this post


Link to post
Share on other sites
No, non provare il secondo metodo, va tutto bene!!!!!!!!!!!!!!!!. Il fatto che ti dica 2400XT è solo un fatto estetico, poi quando ho tempo te lo spiego. Guarda solo se hai Quartz Extreme attivato.

 

Non provare l'altro metodo, altrimenti combini un casino, bisogna prima cancellare delle cose, rischi di inchiodare il PC.

 

Poi non dire che non lo sapevi.

 

L'ho letto troppo tardi questo post. Comunque per fortuna il secondo metodo ha funzionato ed ho ora anche il nome della mia scheda. L'unica incorrettezza è l"XT" in quanto la mia è una PRO ma se dici che è solo un fatto estetico deduco che vada bene così :D

 

Purtroppo mi dice Quartz Extreme:Non Supportata ed anche la risoluzione non è corretta..

Che faccio?

 

Grazie ancora ;)

Share this post


Link to post
Share on other sites

grazie giorgio della spiegazione...

sei stato chiarissimo ;)...

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×