Jump to content

Compaq Presario CQ40-121TU (CQ40-100 Series)


4 posts in this topic

Recommended Posts

I have a new Compaq Presario CQ40-121TU, with the specs:


- Celeron 575 (2.00GHz, 667MHz, 1MB L2)

- 160GB Hard Drive 5400rpm (Serial ATA)

- 2GB DDR2

- Intel GL40 (Cantiga GL)


I tried using the iAtkos v4i, since I already had success with it on my desktop pc. Unfortunately, it doesn't boot using the DVD and instead just hangs on the "Waiting for root device" part and shows "EHCI unable to obtain ownership from BIOS" errors. I think it might be a BIOS problem, and I saw on some threads that enabling the "hand-off" and "legacy usb" solves this problem. But dirt is more usable than Compaq's BIOS--which doesn't give any way to configure those things. I already tried booting using an external DVD drive with no success.


Is there any way I can install Leopard on this computer? I know it's not impossible since the hardware is more or less compatible, right? Can anyone suggest a fix or maybe another way? Will other "distros" work? I'm downloading JaS 10.5 right now...


Thanks in advance..

Link to comment
Share on other sites

  • 5 weeks later...
  • 5 months later...

  • Create New...