Jump to content

ACPI problem when booting - please help


Coltz
 Share

3 posts in this topic

Recommended Posts

I just had Kalyway 10.5.2. installed and almost fully configured (LAN, Video, USB) on my Toshiba A105 laptop, except for some cooling problems. So while I was trying diferent solutions to fix this problem I incidentally removed AppleACPIPlatform.kext (along with AppleCPUThermo.kext and AppleIntelPowerManagement.kext) without backing it up. Now when I am trying to boot I get the error: Unable to find drivers for this platform: \"ACPI\"... and booting is stopped.

 

I tried booting from the install disk and copying AppleACPIPlatform.kext from the installation disk to the /System/Library/Extensions folder of the /Volumes/MyMac disk where I had Mac OS installed, then running:

chmod -R 755 /Volumes/MyMac/System/Library/Extensions/AppleACPIPlatform.kext

chown -R root:wheel /Volumes/MyMac/System/Library/Extensions/AppleACPIPlatform.kext

diskutil repairpermissions /

 

but that didn't help, I still get the ACPI error.

 

How can I solve this and boot up again into a working Mac OS X? Please help. I don't want to reinstall the whole system from scratch.

Link to comment
Share on other sites

Did you remove the /System/Library/Extensions.mkext file?

You can also try entering these flags in the darwin boot console:-v -f -x

 

I did remove kextcache, not sure about Extensions.mkext.

Tried -v -f -x flags at boot - and it didn't help, reporting some dependencies problems.

 

Is there anything else I can do to solve this problem?

Link to comment
Share on other sites

 Share

×
×
  • Create New...