Jump to content

No audio details for Realtek ALC888 (G33 Express Chipset)


MacNutty
 Share

14 posts in this topic

Recommended Posts

I have Realtek ALC888 codec and my System Preferences shows LineOut and LineIn but my Mic, Headphone is not working, only external speakers are working. Also my System Profiler -> Audio (Built-in) shows no Built-in Audio device written in it. I tried all types of combination of AppleHDA.kext, Taruga Patch, ALCInject.kext and HDAEnabler.kext but no success.

 

What should I do to make it working and also get details of Built-in Audio in my System Profiler?

 

Please, please, please help...

Link to comment
Share on other sites

I am attaching linux codec dump which I got after booting from Ubuntu Live CD. In Linux the sound worked perfectly fine and also showed all audio hardware details. I used AppleHDA patch with the same codec dump but the problems did'nt resolved. Please help

 

Here is my Linux Codec Dump

codec_dump.txt

Link to comment
Share on other sites

  • 2 weeks later...
  • 9 months later...

Hi Guys!

 

I know it's been a while since you've resolved the Realtek ALC888 problems, as i can see in MacNuttys signature.

 

I've stalled out on this issue. I have a codec dump from Suse Live CD. I tried Tarugas HDA Patcher, which reports:

 

 

 

* Patching AppleHDA.kext to 0x10ec0888 Done

* Checking AppleHDA for patch Done

0001f4a0 cmpl $0x10ec0888,%eax

00020584 cmpl $0x10ec0888,%eax

* Checking for SPDIF Out Detected

* Checking for SPDIF In Detected

* Using the following nodes in pathmap

 

Back Mic: 9 34 24

Line In : 8 35 26

Speaker : 20 12 2

Headphone: 27 38 37

Spdif In : 10 31

Spdif Out: 30 6

 

* Copying new config to destination Done

* Repairing Permissions Done

* Deleting Extensions Cache Done

 

** Done patching - You can reboot now **

 

After reboot: no sound :-(

 

I've deleted every other audio kext, nothing will get it to work...

 

I think I'm missing something and I'd be happy to get a hint in the right direction.

 

My codec dump and the HDA.kext are attached

 

Thanks for the help....

codec_dump.txt

AppleHDA.kext.zip

Link to comment
Share on other sites

  • 2 months later...
  • 8 months later...
Just wanted to share this. Got my ALC888 working with the attached *.pkg

 

Even optical out works. About this Mac shows: No Built-in Audio ???

 

Any hints?

 

Hi,

 

I have a DG33FB(same chipset as you have I believe), and audio works in my machine, even shows up the Audio as Build In in the left side of system profiler, On the right side top, it shows,High Def Audio or something, and in the right side bottom shows all the channels and info available for a typical sound card.

 

I did try to use the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] ACL888 enablers, and got mixed results initially with the Legacy one providing feeble sound, and little sluggish.

 

However, I ran [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] again, and deselected the Audio KEXTs in advanced section completely and the sound came up smooth and loud.

 

Have been unable to get the front Jacks working fine this way though. WIth legacy, the front Jacks work fine with the limitation of sometimes sluggish and feeble sound. However, with the native one , it works fine without proper Front Jack functionality. Can live live it myself that way though.

 

I forgot to mention, I applied the 10.6.4 combo update too and had to run [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Again, deselecting any audio KETXts including deselecting any HDA enablers.

 

Quite Happy with a MAC OSX running on a PC.

 

If someone wants, i can post a Screenshot of the System Profiler screen.(currently logged into Vista, Installed Mac OS just for Fun and to see how it works).

 

If there is anyway, how I can expose more of my system details(for technical knowledge and right choices for it all to work fine on a G33 Intel original board, then please guide me on what information you would need and how to capture that on a Mac OS, I will be glad to help.

 

For Information for all who face issues after 10.6.4 Update, don't fret, no need to do a fresh installation again, I also got a screen which said, your System needs to restart, however, here is the process to follow.

 

Restart Machine

Boot from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Nvidia / or [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Supported ( I used the supported version).

At boot screen, select the installed MAC OS as the choice, Type -v just to be sure to check out if there are any panics.

Run [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

Select [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or your choices of Kexts etc.

Finish [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Installation

Restart Machine.

 

If you still get that Screen which says Computer needs to restart, Power off again,

Try rebooting with -x (safe mode). Mac OSX should now load up in safe mode. If required install [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] from safe mode itself, and then reboot.

 

It should all work fine now.

 

Most likely with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], all it going to work fine without having to select any additional KEXts so long as you have selected the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] option of [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] installation.

Link to comment
Share on other sites

  • 1 month later...
Just wanted to share this. Got my ALC888 working with the attached *.pkg

 

Even optical out works. About this Mac shows: No Built-in Audio ???

 

Any hints?

 

 

 

Hey. I'm a complete rookie with a Mac so I would really like solve this problem of mine.

I have installed this quoted patch and the sound still doesn't work. I have GA-EG41MF-US2H mobo. Can anyone help me please? I would really like this thing see working.

Link to comment
Share on other sites

 Share

×
×
  • Create New...