Jump to content

Bad Axe 2 Sleep and Wake - Fixed

5 posts in this topic

Recommended Posts

Just thought I would pass this on as I haven't seen it documented in any of the forums. I've been running a D975XBX2 based Hack for over a year now and everything has been great apart from sleep/wake.


I'm on EFI8 with 10.5.5 vanilla kernel and graphics strings for the 8800GT.


The machine would sleep and wake fine. But only once. The next time you asked it to sleep, it would simply hang. I haven't really bothered about this much as sleep/wake was never a major dealbreaker for me. However, last week I saw in the console/system log that following that first wake, the message "ioatacontroller device blocking bus" would fill the screen.


I rebooted with the only IDE device (optical drive) disconnected. Now sleep/wake works every time.


I rebooted again but with the IDE device connected to the primary channel. Sleep/wake works consistently but the machine takes three times as long to boot - "disc arbitration" times out during boot.


So I chucked the IDE optical drive out and installed a SATA version. Problem solved :unsure:


Was there a more sophisticated solution I could have employed here?


Anyhoo, just thought there might be someone else with similar probs. Hope this helps.

Link to comment
Share on other sites

I have only used sata drives in my bx2 since day 1 and sleep/wake has always worked.


Yes I think most people opt for SATA these days so it will be rare.


You're sporting a rather good xbench score in your sig there JedixJarf, does that include the disk test?

Link to comment
Share on other sites


  • Create New...