Jump to content

Boot 132 / EFI - What works, what doesn't from the boot partition with 10.5.4 retail?


4 posts in this topic

Recommended Posts

Ugh. Opera made me lose my draft. Hate when that happens.



Hi everyone. First I'd like to thank dfe,munky,turbo and everyone else who has gotten us to where we are now. I'm also really excited for the AMD users and the Voodoo kernel (up till a week ago, that would be me as well.)


So here's the deal - there's a LOT of threads and information about Boot 132 / Booting from the EFI partition. The problem is that none of them seem to be definitve threads like this:


Here's the state of the boot loader - you CAN do A,B,C. You cannot do D,E,F. G,H,I need to be worked around.


I'm at the point where I am a bit lost. First here's my setup


Gigabyte EP35-DS3L

Pentium Dual Core E5200 (Core2 based)

GeForce 8400GS (Asus Silent)


On-board Audio

USB Compact Flash Reader with a 32GB card - Contains Kalyway 10.5.2, OSX 10.5.4 Retail (from my DVD), and a Backup partition.


Under Kalyway 10.5.2, everything works - audio, USB 2.0 (makes for quick install from CF!), and graphics with NVInject 0.20.


Under 10.5.4 retail, using the CD I found in the CD thread (which is at home, I'm at work, I'll fix this info later unless others have it bookmarked - I can't find it) - I used the P35-DS3R CD I think. It worked, but no JMicron ATA, which was fine, cause I installed from the CF - installed retail in 8 minutes :-) I then tried the 'Generic' 40MB iso which worked for JMicron, but used dsmos instead of AppleDecrypt, which I prefer. I then took only what I needed and installed it on my EFI boot partition:




AppleIntelPIIXATA.kext (JMicron and SATA Enabler)

AppleAzaliaAudio.kext - Not currently working (see below)

HDAEnabler.kext - Not currently working (see below)


AppleSMBIOS.kext - Not sure this is the best version to use. Can't remember where it's from. Was using SMBIOSEnabler.kext I think



Here's the problems:

No audio.

Graphics - I get my higher resolution with NVinject 0.2.0 on either EFI partition or /System/Library/Extensions, but Software CI, and no QE.


I eneded up having to use:

NVInstallerV.41.pkg (after install remove NVinject)



in order to get QE and CI - I think. I need to re-do a clean install again, since I mucked around so much.


So here's the question - how can I get sound and graphics working? Do I *have* to put it on the real partition, or is there a way to get it going from the EFI boot? I thought I read there were issues with sound, that's why I'm quite confused at this point.


I hope to be able to use this thread for the purpose stated above, as to what works and what doesn't, and I will post a quick guide on how I did it later in the genius bar...to try and help others with my setup.


Thanks for reading, I know it's long. :-(



Link to comment
Share on other sites

Just a note - I know it's not your fault or exclusive to this post, but it touches on the confusion you refer to:


Please can people try to use the correct terms and names for things? so many things that *are not* EFI have now been called EFI that the term has lost all meaning. Likewise boot-132, boot-123 and similar terms are bandied about to refer to any one of a dozen variations on the Darwin bootloader code. We get noobs showing up all the time spouting boot-123 this, vanilla that & efi the other. Yesterday I saw a case where someone had installed 2 different bootloaders on top of each other thinking he needed both, because one was labelled "efi" by some DVD release builder.


There are poorly defined terms that have just sprung up, like "vanilla" which get bandied about, and folklore states that using the vanilla kernel will allow updates, which is entirely wrong & causes loads of people to mess up their installs.. I could go on..


So for instance: booting with system files on a reformatted EFI System Partition is not "booting from efi" however much it gets referred to as such. Those coming after will see this and thing it has something to do with EFI leading to all manner of confusion. Those who understand what these solutions do need to be aware that they must be understood by people with far less experience, and if the progress is accessible only to those who can see through the jargon and scarcity of documentation, then it remains a curiosity whilst the average user carries on with the old, familiar methods.


So please, everyone, before you use a term, make sure it means what you think it does, and don't use a term unless it exactly describes what you mean.

Link to comment
Share on other sites

Thanks Hagar. And you're right, in this case, indeed, I mean "Booting from EFI partiton (HFS+ Formatted)."


Could you modify the topic name to say EFI partition, please?


Also, the ISOs I referred to were from this thread:


http://forum.insanelymac.com/index.php?sho...14834&st=20 - Specifically the "Gigabyte GA-P35-DS3L_ISO" and Generic listed there.



Link to comment
Share on other sites

Graphics are fixed.

Clean install.

*No Kexts*

Use EFI Studio from this topic: http://forum.insanelymac.com/index.php?showtopic=76404

Generate an EFI string, and put it into com.apple.Boot.plist either in the root (ie /Volumes/EFI) or /Library/Preferences/SystemConfiguration of your EFI Boot partition, and you're good to go.

Trying to figure out how to get my sound fixed, and I'm good to go!

EDIT: http://forum.insanelymac.com/index.php?showtopic=129058 Legacy HDA - choosing the right codec helped. Couldn't get it to work with a 889a, because it's not an 889a. I misread it somewhere else. Ubuntu 8.04 Live CD gave me the right info, downloaded the 888 driver, made suare it had the OSBundleRequired -> Root setting in the plist, and I was good to go. Now Time Machine is broken, or rather, has been broken since I installed. Researching that now. I feel that SMBIOS and IONetworking are involved...



So to add to the thread: So injectors work, EFI strings work.



Link to comment
Share on other sites


  • Create New...