Jump to content

Certqain kexs dont load with boot-132


4 posts in this topic

Recommended Posts

I am using the EFI partition method to load kexts but I had the same problem when I was using the regular chameleon hard drive method. my only problem is that my patched IONetworkingFamily.kext (patched for time machine to work) AppleHDA.kext and ALCinject.kext (patched for stac9227 audio found here http://forum.insanelymac.com/index.php?sho...rt=#entry927846) wont load when using a boot-132 loader to load them from somewhere except for system/library/extensions. They work fine if I put them on the Macintosh HD extensions folder but not on the EFI partition (/Volumes/EFI/Extensions/). The same ahppened when I was using the chameleon bootloader which loads patched kexts from the hard drive. so right now, heres the status of my EFI partition:


IntelCPUPowerMDisabler.kext- loaded and working

dsmos.kext- loaded and working

AppleSMBIOSEnabler.kext- loaded and working

IOATAFamily.kext- loaded and working


IONetworkingFamily.kext- wont work when on EFI partition (Tried to bump up version, no luck...)

ALCinject.kext- wont work when on EFI partition (Tried replacing this with HDAEnabler.kext...not sure how HDAEnabler works but the way I was using it didnt work)

AppleHDA.kext wont work when on EFI partition


so, thankfully the 4 100% "necesary-to-boot-kexts" load and work, but the 3 kexts required to perfect everything do not work =(


Just incase you need to know- dell e520, intel core 2 duo 2.13 ghz 6420, sigmatel stac9227 audio, efi strings for geforce 8800GT 512mb, intel p965/g965 mobo, 4 gb 667 mhz ram.


Thanks for having a look guys!

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

i'm with the same problem here =/

using chameleon dfe for hard disk, and kexts are in /Extra/Extensions/


loads fine:


- AppleACPIPlatform

- ApplePS2Controller

- dsmos

- IntelCPUPMDisabler

- SMBIOSEnabler


won't load:


- ALCinject

- AppleHDA

- AppleIntelGMA950

- AppleIntelGMA950GA

- AppleIntelGMA950GLDriver

- AppleIntelGMA950VADriver

- AppleIntelIntegratedFramebuffer


i've put <string>Root</string> on each kext

my mobo is an GA-945GZM-S2

Link to comment
Share on other sites


  • Create New...