Jump to content



5 posts in this topic

Recommended Posts

I installed Leo4all LEOPARD 10.5.2 v2 found on the Bay.


Computer PC multiprocessor ACPI

processor Intel Pentium 4 660, 3666 MHz (18 x 204)

Motherboard Abit IL8 (2 PCI, 3 PCI-E x1, 1 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN)

Chipset Motherboard Intel Lakeport i945P

DIMM1: A-Data 1 GB DDR2-533 DDR2 SDRAM (5-4-4-11 @ 266 MHz) (4-4-4-11 @ 266 MHz) (3-3-3-8 @ 200 MHz)

BIOS Award (12/27/05)

Video: GeCube RADEON X550 Secondary (512 MB) Adaptator video GeCube RADEON X550 (512 MB) Accelerator 3D ATI Radeon X550 (RV370)


Multimedia: audio Realtek ALC880(D) @ Intel 82801GB ICH7 - High Definition Audio Controller [A-1]




OPTICAL UNIT TSSTcorp CD/DVDW SH-W162L (DVD+R9:8x, DVD-R9:4x, DVD+RW:16x/8x, DVD-RW:16x/6x, DVD-ROM:16x, CD:48x/32x/48x DVD+RW/DVD-RW)




I installed succesfully it with GUID and a MAC OS EXTENDED JOURNALED PARTITION


But when i try to restart it after the installtion.

It prompt me: Darwin.... and then a lot of things falling than it stops to STILL WAITING FOR ROOT DEVICE, repeating over and over again.


I found on the WEB this:



OSX86 | How to Fix OSX86 Still Waiting For Root Device Error Wednesday, 14th May 2008, 12:05 am These are instructions on how you might be able to fix the OSX86 "Still Waiting for Root Device" error.


These instructions may not work for you; however, I am publishing this method since the solution may save someone hours of frustration. This fix was confirmed working for someone who had successfully installed leo4all v3 and upon reboot received the above error. In this case the cause of the error is due to incompatible or incorrect kexts for your ATA controller.


Step One

Boot up using the LeoV3 DVD as if you are going to install Mac OS X again.


Step Two

Select Terminal from the Installer's Utility Menu.


Step Three

Now we are going to copy all the the ATA kexts from the install DVD to your hard drive. To do this enter a command like this:

cp -pr /Volumes/Leo4allv3/System/Library/Extensions/*ATA* /Volumes/MacHD/System/Library/Extensions/.


NOTE*: Replace Leo4allv3 with the name of your install dvd and replace MacHD with the name of your hard drive volume.


Step Four

Now we need to set the permissions for those kexts we copied

chown -R root:wheel /Volumes/MacHD/System/Library/Extensions/*ATA*

chmod -R 755 /Volumes/MacHD/System/Library/Extensions/*ATA*


NOTE*: Replace MacHD with the name of your hard drive volume.


Step Five

To remove the kextcache execute the following:

rm -rf /Volumes/MacHD/System/Library/Extensions.*


Note* Replace MacHD with the name of your drive volume.


Step Six

You may now restart your computer. I would suggest pressing F8 while booting and then entering -f as a boot option to force reloading of the kexts.



There are many causes of the "Still waiting for root device" error so please don't assume this will fix your problem. It is however a possible solution.





Will this be a reasonable solution? Or maybe it's just a waste of time.


Please help me.

Link to comment
Share on other sites

Try booting with -x ?


Yes i tried and the last two sentences i can see are:

CODE SIGNING: cs invalid page p=130 lssave clearing CS VALID

CODE SIGNING: cs invalid page p=143 lssave clearing CS VALID

and im stuck in that so ill try other way.


download kalyway 10.5.2 or boot with -v -f


Its really usefull downloading another DVD? However i tried with -V -F but it was stuck with:


B 1 Cannot Use ATS persistne store - swittcihng to old F0DB cache mode

CODE SIGNING: cs invalid page p=130 lssave clearing CS VALID

CODE SIGNING: cs invalid page p=138 lssave clearing CS VALID


when installing you need to install the correct chipset kext for your motherboard to stop this


Where i find the correct CHIPSET KEXT? and how i install it?

Link to comment
Share on other sites


  • Create New...