Jump to content

can someone help me install japanese?


7 posts in this topic

Recommended Posts

hello all.


i've gotten 10.5 up and running on my msi wind. but the japanese language fonts don't work at all. i've read on other forums/threads that i need to copy and paste the dictionaries from a clean copy of os x and then type in some commands in terminal.


i have no idea/experience using terminal.


can anyone please help me with this? i've copied the previous thread's instructions below:



You need to copy them from a clean installation of MacOS X.


The folder is:




After this, go to terminal, change into the directory fix the permissions with:


sudo chown -R root:wheel *



what is meant by 'change into the directory'?

Link to comment
Share on other sites

Terminal commands to do your above :


1. Open terminal application in the utilities folder under application.

2. type :

sudo -s

3. type : your password (the root password of your mac)

4. change directory by type

cd /system/library/extensions/

5 type

sudo chown -R root:wheel *

6. type

sudo chmod -R 755 *


then restart computer.


goog luck

Link to comment
Share on other sites

thanks for the response.


unfortunately, it did not work!


nothing changed. after restarting i opened text editor but still had the same problem. i switch to hiragana from the top menu but when i try to type the computer just becomes very slow and only english alphabet shows up.


any idea what i'm doing wrong? is there a special method i have to use to exit terminal?

Link to comment
Share on other sites

Sorry, the directory change should be (as you have changed the Frameworks not the extensions folder)


cd /system/library/Frameworks

instead of

cd /system/library/extensions



you can check if the terminal commands done are successful or not by right click the icons in


and select "get info"

under the "sharing & permissions

should show



Name Priviege

system Read & write

wheel Read only

everyone Read only

Link to comment
Share on other sites

thanks again for the response.


but still no luck :(


i tried the revised method but got the same result. i even checked the permissions as you described, which seem to be all correct.


so now i have no idea what i've done wrong.


please let me know if you have any other thoughts. thanks.

Link to comment
Share on other sites

hello again.


i checked and ensured that yes, i do have proper japanese fonts installed.


i also checked the pdf that you lined to. i may have found a problem.


i don't have any option for 'japanese kana palette'. i have all the other options i need (kotoeri, hiragana, katakana etc..).


would this be the problem? if so, not sure how to find/install the option for 'japanese kana palette'.



Link to comment
Share on other sites


  • Create New...