Jump to content

Radeon X1550 problem with Leo4Allv5


2 posts in this topic

Recommended Posts

I'm using the Leo4Allv5 - The X Server, in a Itautec Hardware - Model SM 3320.


Northbridge: GeForce 6150 (Working)

Southbridge: GeForce 430 (Working)


VideoCard: nVídia GeForce 6150 GO - With shared memory (does not work)


Network: NVIDIA nForce 430 Gigabit LAN Marvell PHY (work with nForce.kext - but only 10% of the time that I turn the machine ON, other moments the network say that the cable is not connected (but it is)).


Sound: SoundMax® ADI1986A (Working)




For the Graphics, I have a Radeon X1550 PCI-e with 256Mb / 64Bits.


I found in the forums that I need the NatitX1300.kext, but Didn't find it in any place to download.

I have tried the ATIinject.kext, changing the DeviceId to 0x7140 (the deviceid infomed by System Profiler), and put a ATIRadeonX1000.kext (from a forum in here - the Leo4Allv5 didn't come with this kext), but it doesn't worked for me. After the boot, I got a blue screen, and stopped there.


I tried a lot of stuffs, without success... After removing the ATINDRV.kext, and ATIRadeonX1000.kext, I can boot into Finder, but without CI/QE.


If I only remove the ATINDRV.kext, I still can boot, but All my graphics gets strange, no background into the top bar. But the System Profiler says that I have CI and QE.


So, I noticed that the problem is with the ATINDRV.kext not working with my ATIinjection.kext.


Someone know what I have to do to get it working?




For the network, I'm using a 3com old card, It says that is always connected.

Link to comment
Share on other sites


  • Create New...