Jump to content

OSX 10.5.5 On Toshiba P100 - No sound/wifi/powermanagement/usb

9 posts in this topic

Recommended Posts



Loving the work you guys do here, and ive successfully managed to install osx kalyway 10.5.2 and upgrade to 10.5.3 then to 10.5.5 (after a couple of attempts!! - had to switch back to sleepkernel to get it to boot!!!)


Any ways, all it working well except for these few things:


1. USB - Can get USB work, but at the expense of system stability.

When upgrading to 10.5.5 my usb stopped working, annoying! So i downgraded my IOUSBFamily.kext to the one that cam with the kalyway 10.5.2 disc, and lo and behold, USB starts working - but theres a big but! - The system is now very stuttery/juddery/jerky when moving the mouse cursor and generally quite slow to respond, not good. So ive upgraded back to the version that came with the 10.5.5 upgrade package using pacifist to extract it, and now my system is back up and running, no usb tho ;)


2. Wifi - Yup, got me an Intel 3945 - As far as im aware, the only sure fire method is to replace it with this:

Atheros AR5008 - Ebay

As noted from here: http://www.insanelymac.com/lofiversion/index.php/t65892.html

If anyone has managed to get their intel card working properly then please let me know!


3. Since upgrade to 10.5.5 my battery management stuff has vanished, so when working off battery i have no idea of how much is left. Have tried downgrading my powermanagement kexts to the 10.5.2 versions but no joy, anyone got any ideas?

Edit: Woohoo!!! Fixed this one with the help of this post:




4. Conexant sound - Still no joy with getting my conexant sound card to work, the only thig that im aware of is to upgrade my bios to a hacked version - bit scared of that!! Anybody got any advice?

Toshiba P100 modified bios


5. Sleep - going to sleep / monitor switching off is an issue, can't wake up from it. The monitor appears to have woken up but there is nothing on screen - annoying but i can just disable sleep


6. One more thing - Got my Ethernet Intel Pro/100 onboard lan to work after modifying the device/vendor id in the networking kexts -however, it doesnt work if I don't boot with -f kernel flag - seems the cached version doesnt work for some reason. Anyone know why?


Does anyone have any recomendations of things I can try?


Thanks all, :)



Link to comment
Share on other sites

Well if it aint broke why fix it?

Loads of people are haveing trouble with the 10.5.5 upgrade.

1 segenstion go back to 10.5.2 or 3 or 4 for that matter ;).

the new 9.4 XNU kernel is out why not try that one it could help you with your usb problems

Link to comment
Share on other sites

Hi Candykane


Thanks for your post.


Only the power problem is a 10.5.5 issue, the all the others affected 10.5.2 aswell!

Have fixed the power issue, see original post!


With respect to the XNU kernel - i noticed this, tho im still kinda new to all this. How would one go about getting hold of this new kenrel and installing it?

Link to comment
Share on other sites

kernels can fix a lot more problems :pirate2:

you download the kernel @



there also delivering a software speedstep project :whistle: @ the same site.


its verry easy to install you dont have to change a thing:


Installing the kernel

you down load the 9.5 beta file

When you unzip the archive, you will find a file named voodoo_beta. Simply copy this file to your Leopard

partition's root folder and you're ready to test! Note: Always keep a backup copy of your current kernel handy, so you can boot into it if Voodoo beta kernel does not work for you. It is recommended to copy the Voodoo kernel to your hard-drive as /voodoo_beta (not as mach_kernel!) and boot into it by typing voodoo_beta -v at the

bootloader prompt.


good luck to you

Link to comment
Share on other sites



Ill give that a shot.


I took a backup of my leopard partition after I had installed it with all the updates upto 10.5.5. Just decided to restore it as ive tried so many different things to get sound/power/ etc working, loaded up disk util from the installer disc, reformatteed the leopard partition, resotred the backup partition, reboot - now I get chain booting error, and I cant seem to find the solution, no matter how much I google around (dual booting with vista using easybcd).


Have you experienced this at all or can point me in the right direction?





Link to comment
Share on other sites

Well am trying the new voodookernel and its not made any improvements to my situation,


still get stuttering when the IOUSBFamily.kext is installed

still have to boot with -f to get the network card to work

still no sound :)

however going to sleep and waking works :) - although i did shut my laptop down to sleep last night and it woke up ok this morning - not using voodoo - so cant tell if its that or the 10.5.5 upgrade??


Solved my chain booting error - the hard way - reinstalled osx and then copied the backup i made of 10.5.5 ontop of it, boots fine.






Here's an odd one,


When i plug in a usb device and the iousbfamily.kext is installed, the system starts working smoothly, and when i unplug it goes back to stuttery.


Any ideas?

Link to comment
Share on other sites

yes its called graphical stuttering usaly its a Dell thing lol should have thought of that

try booting with cpus=1 you sould have no troubles any more.



sounds like the problem i have with my dell 6400 its called graphical stuttering and it goes away after a sleep mode, or if i boot with cpus=1 try that.


pulled form the genius bar:


Intel Core Duo and Core 2 Duo fix for graphical stuttering:


This famously associated issue with previous gen Dell laptops was a serious bottleneck.


The six most obvious signs of this issue is if the apple logo loading wheel stops intermittently, the mouse icon wheel flickers whilst spinning, the mouse pointer is jumpy, the loading bar moves unusually fast, the mouse pointer doesn't appear at all and if your installation hangs with a Blue Screen just before loading the desktop.


This problem was temporarily solved by using cpus=1 as your Kernel Flag:


<key>Kernel Flags</key>

<string>cpus=1 -v</string>


Thanks to OUI, we now have a permanent solution that doesn't require disabling the second cpu core.


A TSC sync kernel patch has been released to finally eliminate any graphical stuttering.

Head on over to this thread to learn more.


Link to comment
Share on other sites



That works, you man are a true legend!!


Thank you, now I can sync my iPhone, excellent!!!


On another note, do you have any ideas about the issue with my lan card, having to boot with -f to rebuild the cache, seems very wasteful to me to have to rebuild it every time I want to boot. Is there any way to exclude certain kexts from the cache, so that I can exclude the IONetworkingFamily.kext from being cached??


Im so close to getting a completely working system I can taste it :D




Ok, so im probably being a complete tard, but I read the whole thread about TSC and cant see how I can patch the voodoo kernel that I just installed, do you have any ideas ;)



Link to comment
Share on other sites

Seperate question for you,


My graphics are working nicely (Nvidia Go 7600 with qe and whatnot) however, it looks like my color depth isnt sufficient - even though its set to 32bit as on gradients (like at the top of this web page background or the grey gradients on finder windows etc in os x) arent smooth, they look like a set of seperate blocks getting slightly less dark with each strip, it looks like when you export an image from photoshop for the web and don't include enough colors in the palette, instead of a smooth gradient it goes down in steps.


Any ideas about this or should I start a new thread?


Thanks for all your help again.

Link to comment
Share on other sites


  • Create New...