Jump to content

10.5.4 iDaneb (Warcraft Installation Crashing)


3 posts in this topic

Recommended Posts

Original topic i made in Post-Installation Discussion and now moving to more os specific area :unsure:.



Anyway, world of warcraft installation is craching due some problem with Rosetta and QuickTime 7.2 Update, i have not found fix for this problem even after weeks of searching in internet.


Im using iDeneb 10.5.4, im getting it work fine in Kalyway 10.5.2 but i dont have 3D acceleration in Kalyway so cant use it.


Below is original post quoted and moderator of these forums can delete the original post in post-installation discussion.


Hello, i got problem with World of Warcraft installer in iDeneb 10.5.4 Leopard install.


Crash log below.





Sep 30 21:39:42 a88-85-142-181 ReportCrash[438]: Formulating crash report for process InstallerLauncher[437]

Sep 30 21:39:42 a88-85-142-181 com.apple.launchd[290] ([0x0-0x2b02b].com.blizzard.Installer[437]): Exited abnormally: Bus error

Sep 30 21:39:42 a88-85-142-181 ReportCrash[438]: Saved crashreport to /Users/DevilSaur/Library/Logs/CrashReporter/InstallerLauncher_2008-09-30-213942_devilsaurs-macpro31.crash using uid: 501 gid: 20, euid: 501 egid: 20

Sep 30 21:39:53 a88-85-142-181 login[441]: USER_PROCESS: 441 ttys000

Sep 30 21:39:53 a88-85-142-181 login[441]: DEAD_PROCESS: 441 ttys000


Crashreport Log


Process: InstallerLauncher [437]

Path: /Volumes/WoW DVD/World of Warcraft (OS X).app/Contents/MacOSClassic/InstallerLauncher

Identifier: com.blizzard.Installer

Version: ??? (???)

Code Type: PPC (Translated)

Parent Process: launchd [290]


Date/Time: 2008-09-30 21:39:42.646 +0300

OS Version: Mac OS X 10.5.4 (9E17)

Report Version: 6



Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000

Crashed Thread: 0


Thread 0 Crashed:

0 translate 0xb80bcd58 0xb8000000 + 773464

1 translate 0xb80b7007 0xb8000000 + 749575

2 translate 0xb80d49c0 0xb8000000 + 870848

3 translate 0xb813ce79 spin_lock_wrapper + 1981


Thread 1:

0 ??? 0x800bc4a6 0 + 2148254886

1 ??? 0x800c3c9c 0 + 2148285596

2 translate 0xb818b6ea CallPPCFunctionAtAddressInt + 202886

3 ??? 0x800ed6f5 0 + 2148456181

4 ??? 0x800ed5b2 0 + 2148455858


Thread 0 crashed with X86 Thread State (32-bit):

eax: 0x00000000 ebx: 0xb80bcd30 ecx: 0x00000000 edx: 0x0000000c

edi: 0x00000000 esi: 0x80303820 ebp: 0xb7fffa08 esp: 0xb7fff9d0

ss: 0x0000001f efl: 0x00010206 eip: 0xb80bcd58 cs: 0x00000017

ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037

cr2: 0x00000000


Binary Images:

0xb8000000 - 0xb81d7fe7 translate ??? (???) /usr/libexec/oah/translate


Translated Code Information:

Rosetta Version: 21.03

Args: /System/Library/Frameworks/Carbon.framework/Versions/A/Support/LaunchCFMApp /Volumes/WoW DVD/World of Warcraft (OS X).app/Contents/MacOSClassic/InstallerLauncher

Exception: EXC_BAD_ACCESS (0x0001)


Thread 0: Crashed (0xb7fff9d0, 0xb80bcd58)

0x001148f0: No symbol

0x852c55d0: No symbol

0x852cc838: No symbol


PPC Thread State

srr0: 0x00000000 srr1: 0x00000000 vrsave: 0x00000000

cr: 0xXXXXXXXX xer: 0x00000000 lr: 0x852c6ce8 ctr: 0x852cc7fc

r00: 0x852c55d0 r01: 0xbffff200 r02: 0x00812000 r03: 0x73797376

r04: 0xbffff240 r05: 0x00000000 r06: 0x008142fc r07: 0x852d30d4

r08: 0x852d31c4 r09: 0x00812000 r10: 0x96915da8 r11: 0xa0be78c8

r12: 0x00000000 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000

r16: 0x00000000 r17: 0x00000000 r18: 0x00000000 r19: 0xffffffff

r20: 0xbffff6d0 r21: 0xbffff528 r22: 0x00111420 r23: 0x00107100

r24: 0x00109600 r25: 0x0000300c r26: 0xbffff6c4 r27: 0xbffff314

r28: 0xa0be61e8 r29: 0x0011144a r30: 0x00000000 r31: 0x9691cb20


Can someone help me fix this error.?


I can install game with Kalyway 10.5.2 but then again i cannot get 3D to work in kalyway so i need stick with iDeneb.



Install this,and it will be ok!




Its not fixing the problem, at least for me.

Link to comment
Share on other sites

  • 1 month later...

Ok...in case anyone else is having this problem I found out how to fix it...least in my case. Judging by the OP it should work in this case since the error is practically verbatim.


Try looking for and installing "CarbonLib_Fix". Once I ran this all my PPC apps started working again. :P


I ran the translate fix before doing this, so I'm not to sure if its necessary but I just thought I should point it out.

Link to comment
Share on other sites


  • Create New...