Jump to content

9800GX2 partially working via GFX Strings


6 posts in this topic

Recommended Posts

Okay, so I read all about this card's issues in the other threads, like it not working on non-SLI boards, or boards without 2 x16 PCIe slots. Well I was bored today, and my replacement card hasn't come in yet, so I decided to start messing around with it


So I installed a fresh copy of 10.5.4 (Retail, via Boot-132), and then just did a combo update to 10.5.5. Then I went ahead and started using aqua-mac's GFX strings tutorial here, using his 9800GTX file. Finished that up, and rebooted it. It started to load, I got a cursor, and then it just stuck. I was left with a black screen, and a cursor. The funny thing was, that my resolution was clearly changed. It looked to be my monitor's native, which was 1920x1080. I didn't know what to do, so I just rebooted it, and this time, gave it verbose and safe mode parameters (-v -x). Wham! Came up with my login screen. Typed in my password, went to my "About This Mac", and what do I see?




It seems to be picking up the second port (Which is actually the primary) on the card. Nevermind the "9800 GTX DDL" part, as I didn't edit that out of my in.plist


Hooray! It looks like it's somewhat working. Now when I try to get some info on the other port, about as soon as I click on it, it locks up. I'm assuming it's because gfxutil didn't see the first port, and now Leopard doesn't know how to handle it? Is there any way to make gxutil see the port correctly, thus making a valid string? Or perhaps a way to make Leopard completely ignore that port?


Edit: My attached thumbnail at the bottom is just what I get showing up when I boot with -v -x


Link to comment
Share on other sites

This is what I found in Vista:




And this is what I ended up with:





Does the first one seem right? I know the second one is, because it's the one that was working before


Anyway, I tried it out using aqua-mac's dual card method (here), and it wouldn't work. I could still boot, but not the 1920x1080 safe mode I could do before. I'm wondering if maybe the first address is wrong?


Any help is appreciated. Thanks in advance. I suppose until then I'm just going to run around blind, going through as many different ideas as I can. I'm wondering if incorporating some of Azamic's modified kexts might help...

Link to comment
Share on other sites

Unfortunately the closest I've gotten to my 9800GX2 working is XDarwin's installer:



It doesn't have QE, and I can't change resolutions... but it at least sees the card correctly. I haven't had any luck with Aqua-Mac's strings or Azamic's kexts (because they don't include HDMI and that's what I'm using).


I'm also using a non-standard display (AX-200U projector) which may be why I can't change resolutions. It's pretty disheartening.

Link to comment
Share on other sites

@ EGOvoruhk


Did you get those information when your card is installed in the first pci-e slot? Reason I am asking is that this card is weird on X48 motherboard where it only works on the second pci-e slot. What motherboard are you using exactly?


Anyway, please try this in.plist (include the permission.command file also) that I edited for you. Just like aqua's gfx string procedure, use gfxutil to make a hex file out of it and place the string into your com.apple.boot.plist (Back it up before you overwrite it !), then run permission.command and restart... try using different dvi ports or even the hdmi ports if thing doesn't work on first try.


Good luck

Link to comment
Share on other sites

  • 2 weeks later...

alexlyc: It was the first (and only) PCI-E slot. I'm on a GA-EP35-DS3R


I tried your plist, but it didn't seem to work. I'm going to try it again on a fresh install, but I don't have my hopes up


I also have a GA-P35-DS4 (Which has 2 PCI-E slots). Do you think I would have more luck with that?

Link to comment
Share on other sites


  • Create New...